Answered

Sonos won't stop playing

  • 30 December 2016
  • 63 replies
  • 6797 views

I set an alarm up for my sonos play 3 in my room. Which has worked fine a couple of times letting me pause it but today every time i hit pause it just restarts the playlist I chose as the alarm music.

Now I cant use that speaker amd have just turned the volume right down.

Help
icon

Best answer by Pierre C 30 December 2016, 14:25

Hello everyone,



We are aware of the issue and actively looking into it. At this time, we'd like to ask you to remove your Sonos alarms. This will stop the alarms turning on over and over again.



We've created a new thread for this issue here: Sonos alarms not stopping. We'll update everyone on that thread once resolved.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

63 replies

Same here. It's also appears to be related to the alarm. I finally got the unit to shut down when I deleted the alarm otherwise it would keep restarting and keep skipping.
If you delete the alarm it appears to stop. Steaming outside of the alarm appears normal again after the alarm has been deleted. I deleted all of my alarms until they get this bug fixed.
Thanks for pointing to "alarms" as the root.

I use an alarm to fall asleep to streamed music. The music never stopped. I hit pause and it just advanced to the next track.

I disabled the alarm to stop the music. I tried creating a new alarm and it immediately started playing.

Quite a bug.
Same thing here.
Alarm related.
Just reading the above bug that has infected sonos today....... if an alarm is set the system won't let you change or switch of until you go In and switch of the alarm from settings ...... sonos Tec team get onto this as it's only just started .......
I also used an alarm to sleep to but it kept repeating and the volume would increase by itself. Tried shutting the power off from the unit and then turning back on but it just continued. Thanks for this post. Turned off the alarm and it finally stopped.
Same issue this morning. Thanks for the alarm tip. I deactivated it and it stopped playing. Hope Sonos releaes a fix asap, otherwise we're stuck without the alarm.
Disabling the alarm did not help for me. I had to delete it completely.
I set an alarm up for my sonos play 3 in my room. Which has worked fine a couple of times letting me pause it but today every time i hit pause it just restarts the playlist I chose as the alarm music.

Now I cant use that speaker amd have just turned the volume right down.

Help
i hafe the same whit my plai1
Same here. In our case, the 6am alarm went off as usual and stopped at 0645 as usual. But then the *Saturday* 8am alarm went off at 0800 (today is Friday!) and that won't stop. You can't even stop it at the device. We have just unplugged ours.
Same problem here. Couldn't stop the music after my alarm went off. It helped deleting the alarm. Is Sonos going to fix it?
Userlevel 7
Badge +21
It is most likely you guys are experiencing network issues - certainly the sympton of being unable to switch off a speaker is highly suggestive of connection issues.

You should all try a system reboot as below:-

Switch off your Wi-Fi Router
Switch off ALL your Sonos kit
Switch off ALL devices connected to your Network
- Computers, Laptops, Tablets
- Smartphones, thick phones
- NAS

Switch on Router. Wait until it has re-connecte to the internet
Switch on Sonos Bridge and/or Boost, Connect - Wait a minute or two for them to connect
Switch on your Sonos Plays and Playbar
Switch on all your other network devices


If this is not successful then you should explore interference on your system.

Whilst it is somehow comforting to point the finger at updates as the reason for issues it has to be said that it is unlikely this is really the cause and that a bug has been introduced. See how the above goes.
Update. We deleted the Saturday alarm, and that stopped the playback. But as soon as we reinstated the 0800 alarm for Saturday, it all started again, even though today is Friday and it's now 0830. Grrr! Please fix this Sonos!
Hi guys, this is the same for me today when i fall asleep with my sonos alarm. There is a link between this issue and the 31/12 maybe ?
It's a bug. See post by MaxP here: https://en.community.sonos.com/troubleshooting-228999/sonos-alarms-not-turning-off-6763393
Badge
Same here. Started this morning at 8am. On connect and 3x play1.
Greetings from Belgium
this is happening to me too. Alarm started about an hour after it was programmed to ( it had gone off correctly earlier). now it is going off by itself repeatedly about two seconds after I cancel it each time either on the controller app or on the pause button.
Do you really think all these people are suddenly having network issues simultaneously, Stuart_W ?
Same for me it's related to the Saturday alarm going off a day (?) early and not being able to pause/stop. If you turn the alarm off then you can pause as usual. Happened since last update.
Userlevel 7
Badge +21
this is happening to me too. Alarm started about an hour after it was programmed to ( it had gone off correctly earlier). now it is going off by itself repeatedly about two seconds after I cancel it each time either on the controller app or on the pause button.
Do you really think all these people are suddenly having network issues simultaneously, Stuart_W ?


It does appear in this case that Sonos have acknowledged there is a wider issue on-going. So as a direct answer to your question; no. It appears to be something other than network issues.
It is most likely you guys are experiencing network issues - certainly the sympton of being unable to switch off a speaker is highly suggestive of connection issues.

You should all try a system reboot as below:-

Switch off your Wi-Fi Router
Switch off ALL your Sonos kit
Switch off ALL devices connected to your Network
- Computers, Laptops, Tablets
- Smartphones, thick phones
- NAS

Switch on Router. Wait until it has re-connecte to the internet
Switch on Sonos Bridge and/or Boost, Connect - Wait a minute or two for them to connect
Switch on your Sonos Plays and Playbar
Switch on all your other network devices


If this is not successful then you should explore interference on your system.

Whilst it is somehow comforting to point the finger at updates as the reason for issues it has to be said that it is unlikely this is really the cause and that a bug has been introduced. See how the above goes.


I have tried this and the problem persists. It seems odd you'd think we'd all have network issues at the same time. I would think this is a bug rather than a network problem.
And so we wait for fix 🙂
https://en.community.sonos.com/troubleshooting-228999/sonos-alarms-not-turning-off-6763393
As others have suggested I have deleted all my alarms and I can now stop playback. Let's hope the issue is resolved soon.
Userlevel 2
Badge
Me too. Same problem - system turning itself on with alarm setting (tunein radio 4 for me) - every 30 seconds or so. If switched off or to another source the alarm setting came in again. I tried deleting monday to friday alarm - nothing happened - but when deleted Saturday alarm problem solved. Weird and bloody annoying has had hoped for a lie in today (had turned alarm off). Clearly a bug - let'shope Sonos fix it soon.
Same issue here. Solved by deleting the alarm.
Badge +1
Me too, also worked this out to be the Alarms, was just about to phone Sonos but checked some similar problems and found this. Had to disable the Alarms to switch the device off. Hoping it is fixed today as we use this alarm every day otherwise its down to the mobile.