Answered

Sonos S2 system not working well



Show first post

62 replies

S2 system update is terrible and my system rarely functions properly now even though it was fine 99% of the time before. Look at the Apple reviews recently. A great deal of them are 1 star. This app is extremely buggy. I have about 11-12 speakers and they’re basically functioning as ornaments now. 

As explained many times in this thread, it isn’t the sotware that you’re having issues with, it is your local network, the great majority of users are not experiencing any issues with either S1 or S2. 

Without details of your setup, two rather effective but general things to do are:

  1. Read and apply such solutions as can be found in the wifi interference FAQ. This kind of issue is by far the most common issue plaguing users.
  2. Refresh your Sonos network by unplugging all Sonos devices from power. While they are unplugged, reboot your router. Only when the router comes back up should you plug back in the Sonos devices.  This resolves several potential issues, by forcing both the router and Sonos devices to reboot, and reconnect. But it would only fix one of the potential issues if the Sonos devices are powered off while the router is rebooted, if they remain powered on, it won’t have the same effect.

Sonos is a networked speaker system, so if there is an issue internal to your network, it will reflect on the Sonos performance. Of course, the above two potential solutions probably cover only 98% or 99% of the potential issues, there are certainly less common ones. If those two solutions don’t work for you, I would recommend that you submit a system diagnostic , and call Sonos Support to discuss it, or post the number here.

There may be information included in the diagnostic that will help Sonos pinpoint the specific issue and help you find a solution.

When you speak directly to the phone folks, there are more options available beyond just the diagnostic analysis. 

What nonsense. Lots of people are having problems with S2.  I would suggest people look at the app reviews in the App Store rather than listen to the denialists in this thread. After S1 working perfectly fine suddenly all these problems. All because people have got network problems? Laughable

Sonos - please listen to your user community. There is something seriously wrong with S2. We all have a lot invested in this product. This S2 rollout has been an absolute failure. I have four rooms on my network and now only one works. Rooms appear out of no where and then disappear. What is the solution. Can we go back to S1?

Agreed.

4 Play:1s and 2 SLs working fine on S1 app…  Suddenly though, the last update to S1 app causes a crash whenever searching for a radio station.  So I upgraded to S2.

Now, none of the SL speakers show up in S2 app.  I’ve discussed on a forum thread here which led to calling support.  After clicking through multiple “solutions” I finally get a phone number.  After nearly 2 hours on the phone I’m sent an email of suggested router configurations… Like really?

If my all my speakers worked perfectly on S1 but then suddenly on S2 the SL speakers do not work, how is it an issue with my router or network which hasn’t been changed any time inbetween S1 to S2? Clearly there is an issue with the new system.

On my router’s connected devices I see TWO different Sonos:  “Sonos Inc” and “SonosZP” so seems like SL and Play:1 have two different clients but yet the S2 app can’t seem to ever find one of them.

As others have said, wanted to buy more Sonos for Christmas but with this I’m thinking I might need to trash all these speakers and find a whole new brand.  Absolutely a disgrace.  Especially the time I wasted with Sonos support and diagnostics. 

Sonos - please listen to your user community. There is something seriously wrong with S2. We all have a lot invested in this product. This S2 rollout has been an absolute failure. I have four rooms on my network and now only one works. Rooms appear out of no where and then disappear. What is the solution. Can we go back to S1?

 

Yes.  Same here.

My Play:1s all show fine.  The SLs though…  They come and go on the app.  And when they do come on the app and I attempt to play something I get a “cannot connect” popup.  And then on the Windows controller they don’t show up at all, just on the Android app.

Just horrible.  How did such a great system become a total dumpster fire?  Especially when downgrading is such a hassle.

I am frustrated beyond belief.  I have 8 Sonos speakers and a sub and Playbar.  Everything worked fine on the original Sonos app, but since upgrading, I can’t connect my speakers unless at least one is plugged into my router.  I could get some speakers to work but then they disappeared from the app.  I even deleted the app and two speakers continued to play and then I couldn’t turn them off because they were no longer on the app.  Sonos 1 was amazing and I had no issues.  I just want my old connections back.  i can’t even begin to count the number of hours I have spent rebooting, resetting and reconnecting with no success.  This is so disappointing.  I need to find a solution because this is not acceptable and after reading all of these posts, there is a huge issue going on here and it needs to be resolved.  

As a follow up….I finally came across a couple of speakers that had not been reset or upgraded to the new version of the app.  Unfortunately, I could not get all of my speakers to join the network wirelessly, so I was forced to connect one of my speakers directly to my router.  I am using the original Sonos app, but every time I access it, it tries to launch the new app. It is easy to mistakenly do this.  At the end of the day, I feel like I ended up surrendering, which is so disappointing since this worked so well before.  I guess I am just glad that I have music piped through my entire house at this point.  

I had really bad issues with my Sonos S2 system with 2 x Sonos Ones.

I assigned them static IP addresses and for some reason it is much more stable now. I have an Asus ZenWifi mesh network.

That’s the more permanent way to do 2. , in my post above. There just appear to be some routers that seem to regularly lose position in the IP table, and since Sonos does a soft reboot with each software update, it hits that issue more frequently than most devices. 

Userlevel 6
Badge +3

8 years with Sonos, 16 components now, (8 were recently upgraded so I could use S2 features) - purchased units almost every year.  Over years of trying to stabilize my system with the help of some high-level Sonos engineers, we’re still forced to WIRE over half of our Sonos components to get even reasonable stability!!  (wireless audio - my arse!)

Indeed I could have wired the same rooms for HiFi speakers had I not bought into the marketing hype Sonos sold all these years. 

Look! S2 is WAY MORE unstable than S1 and even if the fanboys here won’t admit it, many inside Sonos will (anonymously of course).  

I was an I.T. exec for decades, live in small home with no Wi-Fi interference for neighbors (who are far away) and I know more about routers/switches/modems/Wi-Fi than most consumers.

8 years of attempts to isolate Sonos units, Wi-Fi interference, cell phones, on and on! 

Several top end routers, all Cat 6 (or better) cabling.

Every single aspect (including a detailed network diagram) scrutinized by Sonos engineers year after year! 

100’s of diagnostics submitted, traffic managed, Static IPs assigned, then un-assigned, multiple units Wi-Fi turned off then on then off again. 

Engineers agree, I’ve done EVERYTHING CORRECTLY AND THERE ARE NO ISSUES WITH MY HOME OR SET UP!!!   Their advice; WIRE UP MORE UNITS!!  

FORGET Sonos HD radio!  Unstable b/c of the limitations of even Gen2 Sonos units.  Canceled my subscription after support admitted that it probably won’t get better soon!

And don’t get me started on the horrific management decisions to gut support and software programming staff, while farming out support to off-shore, contracted, companies with uncaring and under-trained staff.  And lastly the brain-dead, poorly managed roll-out of the S2 line! 

The few remaining top tier support staff are excellent, dedicated, smart, friendly, and helpful but there are limitations to what they can control. 

Rant off - Have a lovely holiday everyone and STAY SAFE!

Like many others here my Sonos system has been ruined since the launch of the s2 app. Basically for me when I load the app it takes 10-15 secs for the app to respond on my iPhone so I can’t change volume etc. I’ve since sold both my play 1’s and both play 3’s and as much as I have loved the play 5 as a lounge speaker I think it’s time to get rid. Such a shame as I was so invested in the setup but can no longer recommend 

Hi @benjamindm.

Thanks for reaching out and welcome to the community!

Sorry to hear about it, let me help you on figuring this out.

 

There are many potential causes when the speakers are dropping out of the system (Wireless interference, Gateway issue, Source issue, service issue, etc ).

This can cause audio interruptions during playback and with the Sonos performance as well.

 

If you’re having trouble using direct control, and your Sonos is not showing as the target device, I suggest trying the following steps:

 

Step 1 - Update both apps

  • Update the music service (Spotify) app and the Sonos app. Only the latest app versions work with Sonos
  • Please confirm that no updates are available and bot app are using the latest software version.

Step 2 - Ensure that Cloud Connections are active

  • In order for Sonos speakers to be discovered, they need to have established network connections.

Step 3 - Confirm the Sonos app displays all rooms

  • If the Sonos App can't see the Rooms, the Direct Control App won't work.

Step 4 - Please confirm that the device is on the same network as Sonos

  • It’s not uncommon for a mobile device to be streaming off of the cellular network.
  • Connect the device to the correct WiFi and test Direct Control.   

 

If the issue persists, kindly please submit a diagnostic report through the Mac’s Sonos app, and reply with the confirmation number.

I'd be glad to review your system further and it will also help in identifying what's causing the issue.

 

Let me know how it goes and if you have any other questions or run into any issues, please do not hesitate to reach out.

This is such a BS response. So many people are having major problems with S2 who had no problems with the old Sonos app.

Stop wasting people’s time telling them it is a problem at their end when quite obviously S2 is absolutely riddled with bugs. A big steaming pile of 💩 

Thanks for saying this!  You can tell the pattern of “resolution” that Sonos is using. My solution is now when I see people at Best Buy looking at Sonos, I tell them NO! I printed out one of these community messages and taped it on Sonos display. It lasted half a day before it was removed. I want the quarantine to be over just so more people will see it!  Bottom line; we don’t need a community forum, we need Sonos to do their job. Nevertheless, whatever at this point ain’t enuf.  I’m done. 

Reply