Answered

Sonos Connect incompatible with iPhone SE

  • 13 October 2019
  • 7 replies
  • 156 views

Playing my CDs via Sonos Connect has been problematic ever since I bought it 2 weeks ago. First it would not work and then one day it did work. Although the Sonos app on my iPhone SE showed the CD player running, there was no sound - Sometimes! On one occasion it was playing my CD and suddenly went silent even though the app still showed it playing. Next I re-installed the Sonos app on my iPhone SE but it did not fix the fault. Then I installed the app on my wife's iPhone SE and it would not work on that device either. My son installed the Sonos app on his Samsung Galaxy S8 and it worked perfectly. I also installed the app on our iPad and that also worked perfectly. Clearly there is an issue (conflict?) between the latest Sonos app and the latest iOS on the iPhone SE.
I can live with using the iPad but would prefer to use my iPhone to control my Sonos system. I wonder if anyone knows of a fix?

Chris
icon

Best answer by Ken_Griffiths 13 October 2019, 12:59

Chris,

What happens if you go to the Sonos App and navigate to “Settings/System/Audio Compression” and set the audio to compressed?

Does that perhaps work for you?
View original

7 replies

Userlevel 7
Badge +19
What version of iOS are your iPhones running?
Thank you for your prompt reply. I am running iOS 13.1.2.
Chris
Chris,

What happens if you go to the Sonos App and navigate to “Settings/System/Audio Compression” and set the audio to compressed?

Does that perhaps work for you?
Describe your system and network for us. What is wired? What is wireless?

Your symptoms suggest wireless network issues. SONOS attempts to keep a cache filled with music data. If there are small communication issues, data in the cache will be used to ride through the problem. If there are lots of problems, the cache will eventually empty. When the cache is empty, and there is a communication problem, the system will mute if it seems that the problem might clear soon. As you have experienced, this can result in intermittent muting if communication is on the edge. This is similar to a cat attempting to capture a toy that is a fraction of an inch out of reach. The cat should give up, but it can touch the toy occasionally, not snag it. Ever the optimist, it seems that with a little extra effort it will be able to snag the toy.

Ken's suggestion might help because it reduces the quantity of data to be sent over the network. Compression will result in a small time delay, but adding an additional time delay to a CD that may have been acquired decades ago is not an issue. If you are attempting to time align CONNECT's output with audio from a 3rd party device, the compression delay will be intolerable.
Hi Ken and Buzz,
Thank you both for your help.
Reply to Ken,
I switched my CD on after reading your comment and it played my CD ok this time. It has been intermittent like that. I followed your instruction anyway and changed from Uncompressed to Compressed. There was about 2 seconds of silence and then it continued playing just fine. I had avoided the Compressed setting before in the belief it might compromise sound quality but I'll leave it there for now and see if it fails silent again .

Reply to Buzz,
System is all in one room as below,
OnNetworks09 WiFi router: cat5 cables (3) connected to; main gateway router, TV and Playbar.
Samsung TV: optical cable to Playbar and cat5 to Router.
Sonos Playbar: optical cable to TV and cat5 to Router.
Sonos Subwoofer: wireless WiFi connection to router.
Sonos Surround (Play1 x2): wireless WiFi connection to router.
Sonos Connect: wireless WiFi connection to router and phono cable to Denon CD player.

To help overcome any communication issues (Sonos Connect was in a cabinet about 7 metres from the router) I put it on top of the cabinet but it remained silent yesterday. Today it works, so far (see above).

Many thanks, your advice gratefully received.
Chris

Chris in Cleeve,

Your SONOS system, because of the wired network connnection to PLAYBAR, is operating in SonosNet mode. SonosNet ignores WiFi and WiFi ignores SonosNet. However, it is best to use separate channels for WiFi and SonosNet. Use channel 1, 6, or 11 for WiFi, don’t use “Auto”. And use 20MHz channels for WiFi. 

If your router supports the feature, “Reserve” or “Fix” the IP address of all known clients that regularly use the network. IP addresses are “leased” for a period of time, often 24 hours or a week. As leases expire, clients return to the router and “renew” their lease. Think of this as giving certain clients a ‘VIP’ status to always renew at the reserved address. During a power failure the router forgets all of the leases. This is not a problem for the reserved clients, but the restarted router might give out an address duplicating a nonreserved client lease that has not yet expired. You can imagine the confusion when there are duplicates -- “Where is my order”, “I didn’t order that”, “No reply, must not be home”, etc. The human can be very confused over this chaos because “it never happened before” and and a day or two later everything seems to be working OK. (As the leases are renewed -- although this is not guarenteed)

Reconfiguring your router will reduce the risk of similar midadventures in the future. 

Wow! That’s what I call a comprehensive reply.  Thank you so much.  My Connect has been working well since I set Audio to Compressed.  If it displays any more problems I will take this further. Chris

Reply