Question

Snooze alarm on iPhone not working - No alarm playing


Hi,

when I use my Sonos One alarm I receive a notification on the screen of my iPhone XS (iOS 13.6.1). I then use 3D touch to be given the option to snooze. When I select snooze I get an alert to say “No alarm is playing” and can’t then snooze the alarm without opening Sonos App stopping the music and setting another alarm. It’s the same whether using music, radio or the Sonos chime options for the source.

Does anyone know how to fix this?

Thanks.


14 replies

Userlevel 2
Badge +1

It’s been broken for a very long time and Sonos doesn’t seem interested in addressing it.  See my thread from 2 years ago:

 

https://en.community.sonos.com/controllers-software-228995/iphone-3d-touch-alarm-menu-6805152

 

This was with an older version of iOS, but now mine does the same as what you describe.  I had to quit trying to use Sonos for my alarm.

Thanks JimmyT.

Its a shame really as it’s one of the reasons I bought the extra Sonos One for my bedroom! I might have to revert back to my old Sony speaker/dock - at least that has a snooze button!

i wonder why Sonos aren’t doing anything to resolve this issue. 

Userlevel 4
Badge +12

Hi folks, thanks for reaching out with the Sonos Community! We greatly appreciate you being a part of the Sonos family.

When a Sonos alarm goes off, it will appear on the lock screen of your iOS or Android device. You can use the notification to open the Sonos app in order to Snooze or Dismiss the alarm. On iOS, you can 3D Touch the notification to access a quick menu for these options.

That being said, it should work on your end. Try it with a different device, reset up alarm, and reinstall the Sonos app.

Let us know how it goes. It is our pleasure. We and the community are always here to help.

Issue I have is with Sonos Move, I use this for an alarm but I don’t even get any option to snooze - either on the lock screen or within the app … very annoying!

Userlevel 4
Badge +12

When a Sonos alarm goes off, it will appear on the lock screen of your iOS or Android device. You can use the notification to open the Sonos app in order to Snooze or Dismiss the alarm. On iOS, you can 3D Touch the notification to access a quick menu for these options.

That being said, it should work on your end. Try it with a different device, reset up alarm, and reinstall the Sonos app.

Hi @Brett Kav, welcome to the Sonos Community! Have you tried the above response? For more information, please click this link about controlling alarms

Let us know how it goes. We and the community are always here to help.

Yep the option to snooze is not offered all I can do is stop the alarm.

Userlevel 2
Badge +1

Yep the option to snooze is not offered all I can do is stop the alarm.

 

That’s right.  This hasn’t worked for a very long time and makes the alarm function unusable.  

Yep the option to snooze is not offered all I can do is stop the alarm.

 

That’s right.  This hasn’t worked for a very long time and makes the alarm function unusable.  

Thanks Jimmy … disappointing :-(

Userlevel 4
Badge +12

Hi folks. We’ve tried and tested the snooze functionality using the Sonos alarm and it works great. Make sure you check the Alarm options like Snooze duration and enabling the Snooze Alerts. If you all are having trouble, call 800-680-2345 from Monday to Friday from 10 am to 9 pm ET. Please let us know if there’s anything else we can help you with. We and the community are always here. 

Hi folks. We’ve tried and tested the snooze functionality using the Sonos alarm and it works great. Make sure you check the Alarm options like Snooze duration and enabling the Snooze Alerts. If you all are having trouble, call 800-680-2345 from Monday to Friday from 10 am to 9 pm ET. Please let us know if there’s anything else we can help you with. We and the community are always here. 

Hi Krishma, the snooze functionality does not work great it does not work at all.  For reference the snooze function is enabled and the snooze duration is set, but the option to snooze is never offered.

Userlevel 4
Badge +12

Hi @Brett Kav, thanks for your response. Have you tried checking in the notifications for Sonos and also trying in a different device? Also, try to remove the Sonos app from your phone and then re-add it, connect to the existing system, and make sure you allow the notifications. If still nothing, reach out to our phone support team so they can further help you and establish a remote session. Just let us know if you need anything. We and the community are always here to help.

Hi @Brett Kav, thanks for your response. Have you tried checking in the notifications for Sonos and also trying in a different device? Also, try to remove the Sonos app from your phone and then re-add it, connect to the existing system, and make sure you allow the notifications. If still nothing, reach out to our phone support team so they can further help you and establish a remote session. Just let us know if you need anything. We and the community are always here to help.

Done that and needless to say it still does not work.  Looking at all the forums this is a long standing and common issue.

Userlevel 4
Badge +12

Hi, @Brett Kav! I understand that it’s not working on your end and maybe to some customers but we just tried and tested it on our end and it’s perfectly working. It would be best if you reach out to our phone support team to further check it for you and enjoy the features of the Sonos speakers. Just let us know. We and the community are always here to help.

To work out your problem of snooze alarm on the iPhone not working, you could first update your device’s iOS system or check out some other basic settings. If they are unable to do the trick, then you might need an iOS system recovery application such as TunesKit iOS System Recovery to fix it with a 100% success rate and without data loss.

Reply