S2 controller app dropping rooms

I have updated to S2 app and added a move speaker to the 3 Sonos 1s, 1 Sonos 3, play bar and sub . The S2 app keeps dropping the speakers and I can’t see them on app, they will then re appear only to be dropped again later, this is very annoying. I have a play 5 also which now operates on a S1 controller on the same WiFi network and this seems to be operating ok. Are there fixes planned to be made to the S2 controller app as it seems very unstable or should I revert all speakers back to S1 controller if that’s possible?


25 replies

I’d recommend a refresh of your local network. Unplug all your Sonos devices. Reboot your router. Give the router a couple of minutes to come back up, then plug back in your Sonos devices. Give them a couple of minutes to reboot and reconnect as well, then test. 

I’d recommend a refresh of your local network. Unplug all your Sonos devices. Reboot your router. Give the router a couple of minutes to come back up, then plug back in your Sonos devices. Give them a couple of minutes to reboot and reconnect as well, then test. 

That is the general useless “did you try to turn it off and on again?”.
I’m a network engineer myself, and I see the same behaviour on my enterprise grade system too, since S2. OP also states he doesn’t have an issue with the Sonos speaker on a S1 controller, so very unlikely his network is the cause.
I did notice when you unplug/replug the speakers, they show up again for a brief moment… but that isn’t the solution we’re after.

That’s indeed the general ‘it might be a duplicate IP address issue due to problems with your router and improper IP assignments, which also fixes potential issues with DNS data not being transferred through the system properly‘, although the latter is not the issue that this user is experiencing. 

If you are indeed a network engineer, you’ll be familiar with both the more complex way that Sonos interacts with a network, as well as the challenges presented by some routers not handling proper DHCP assignments due to failures of various types within the router, exposed by the Sonos doing a soft reboot during the update process, and requesting new IP addresses. 

But I’m not a network engineer. I’m just familiar with the way Sonos works, and have been helping folks long enough to know that in greater than 95% of the cases, this resolves the issue. I’m also smart enough to know that it isn’t a silver bullet, but once it has been completed unsuccessfully, can then focus on other, rarer potential issues. 

But since you’re a network engineer, and must have greater knowledge than I, I will bow out, and let you resolve this user’s, and your, issues. 

I don’t know which part of: “The Play:5 still on the S1 controller operates normal and doesn’t drop off” you missed. Also personally never had routers hand out duplicate IP addresses. I’ve seen many ISP endpoints stop handing out IP addresses, bc the DHCP pool was too small, and/or leases of devices that left the network didn’t expire already (to make the IP address(es) available again for new clients).
I do agree that making IP reservations based on devices MAC-addresses outside of the DHCP scope, rules out many issues people have with bonjour/mdns and caching in their computers/other endpoints. That way, you simply cannot hand out the same IP address twice. Most of the time duplicate IP addresses are the user’s fault, bc they manually assigned one on a device, and didn’t exclude it from the DHCP scope. And maybe when the timing is right (and such IP is handed out by DHCP), and afterwards they start up the manually assigned device, mayhem happens… but any other order, prevents the router from handing out that IP, as it should be in it’s ARP cache.

I have the same exact problem since I upgraded to S2 and multiple attempts to get feedback from Sonos have not been answered.  Please note that the Sonos App on the MacOS is not dropping the speakers.   It is only the S2 app on my iPhone 11 (iOS 13.5.1).  And I did try to reboot the router.

I noticed too, that while the devices drop from the iOS controller, their Airplay keeps advertising.

i also use Roon, and while they dropped, I can also still see the Airplay endpoints, but the sonos ones disappeared. Not all Airplay endpoints are able to stream though.

Unplugging 1 speaker from mains, or ‘reset/reboot’, usually brings back the entire system.

I’m considering resetting all speakers, and do a downgrade to S1.

Userlevel 1

Upgraded to S2 - worked good for a week - now everything is dropping and can’t find my speakers????? What is going on?   Had Sonos for 8 years - now all kinda of problems!   This is not good - maybe sell everything and switch to Bose !

Userlevel 1

I have rebooted modem and router - nothing seems to be helping - music stops and speakers drop off.  I have my sonos using a  separate channel on my wireless router - is this an issue with S2?  Is my router no longer compatible? Is there a list of S2 compatible routers somewhere?

Userlevel 1

I fixed my problems.  First, checked my matrix: https://forums.homeseer.com/forum/media-plug-ins/media-discussion/sonoscontroller-dcorsus/1283672-sonos-network-matrix

Saw I had major wi-fi interference.  Purchased a Boost and switched back to SonosNet.  So 8 speakers on SonosNet and my Move on wi-fi - every thing back in order and working great.  You can group SonosNet speakers and wi-fi speakers with no issues. 

 i have the same issue - before upgrading to S1 ourer sonos was stable as a mofo,

We have a unifi network - all speakers worked like a charm


We have 2 x S1 + 1 Move + 2 x play5 - after upgrading its becoming very useless and really really unstable.


It’s definitely a Sonos S2 problem. I don’t want to be bothered to turn everything off and on again every time this happens and it’s happened several times. I think Sonos needs to take a hard look at S2 and provide us an update. This never happened with S1.

Hi - we solved all ourer issues by cabling some of the units - after this everything been rocksolid.

So you ran wires for a wireless system?


Same issues with ‘upgrading’ to S2 controller. For 2+ years on S1 my pairs of 3’s, 1’s and Connect worked liked a charm. Then upgraded to S2 and have had nothing but problems. For over a week I’ve tried to resolve with online, chat and phone support. Everyone keeps telling me to reboot my router, direct connect one of my 3s, direct connect my Connect to the router. Reboot my devices. Reboot my router. I have tried it all with no success. Sometimes my controller (and I have it installed on two laptops as well as my mobile) sees my network, sometimes it doesn’t. Sometimes it sees my network but not all rooms, something its does. Sometimes it sees all rooms but can not connect with all music services (Sirius and TuneIn primarily). Sometimes it plays fine for 5-10 minutes, then drops connectivity. This sounds to me like a software issue but support keeps claiming, no, its a wifi network issue. I have had Xfinity run a full diagnostic on my modem so I know that’s not the issue. Is my only option to keep rebooting the network until it sticks?

I had similar issues. Solved it by disabling the “AIRTIME FAIRNESS” on my Netgear router.  Check your routers and see if they have AIRTIME FAIRNESS enabled or anything that prevent network lag when slower devices connect and disable it.  Worked for me.

I had no problems with my S2 upgrade for at least 2-3 months.  My problems started the exact same day i took on the free trial for Sonos Radio HD.  My understanding is the HD upgrade requires a feature of the S2.   I’m stuck with literally $1000s of Sonos I can’t use.  Only my Sonos move seems to reliability connect.  I’ve also noticed that my iPad had one set of rooms working while my iPhone had a different partially functional list.  This sucks!

I am having the same problem. I upgraded to Sonos 2 and it is now randomly dropping speakers.  Very disappointing. Doesn’t seem like there is a good solution 

Userlevel 2

I’ll add to this thread - randomly dropping speakers from the controllers but they are still receiving input and playing. Most common is that the living room will only show the ARC and not the surronds or subs (even though the surrounds are defintely playing). It will let you try and add the Subs (and pings to say successful) but doesn’t show - can’t add surrounds. Force closing the app and restarting and they usually reappear but I have no idea what sound is being sent out. Dignostic 780540847. I have done a full reset, was told by support there was a faulty network cable which I have replaced but still happening. 

I’m curious: If you have  the desktop controller installed on a computer can you operate the system using that controller?

Userlevel 2

I can operate the system - speakers are grouped so I can still do that via the IOS app as well. I can’t access the controls for the Sub / Surround i.e. to alter balance. Its not that I want to do that its more to understand what is going on (for example the app doesn’t show it is broadcasting in ATMOS when this occurs).

You cannot manage the system using a desktop controller. Are you able to see all of the players, play music, and control Volume using the desktop controller?

Using a desktop controller you can go to About My Sonos System.. and check which audio format ARC is receiving.

I am also experiencing the speaker drop issue.  One SL, iPhone 11, latest os.  It will be playing and then drop.  S2 will hang looking for the speaker (I also have a Roam).  Restart app, speaker.  Still can't be picked up by the Sonos App.  however, it will appear on my iPad.  This can take 10 minutes to get it to work again.  This is an S2 & Sonosnet issue.  All of my streaming, internet, etc works.  I can stream (bluetooth) spotify to my Bose speaker. Initially I was excited about Sonos - It just works.  Now not so much.  

Userlevel 2

Unfortunately the only response I got from the help desk was:

  • Reset the system
  • Replace the LAN cable
  • Wire more devices (which is difficult and not the point of Sonos)

So it still happens and dealing with the service desk is frustrating as they keep going through the same script steps and when you have multiple devices going through the rest continually is time consuming and not fixing whatver is going on.

I have just got a new router from Sky but don’t think that is the root cause.

Userlevel 7
Badge +22

I have just got a new router from Sky but don’t think that is the root cause.

LOL what makes you think that?? SkyQ routers are known to destroy Sonos network packets, there is a great diagram somewhere on here detailing it.

There are also SkyQ specific notes on the general WiFi page:


Userlevel 2

Thanks - will have a play with sky q to see if I can follow what it says in the article