S2 App not working.

  • 21 June 2020
  • 5 replies

I am trying to install the S2 App on a Samsung Galaxy S9, But it will not install.  I get to the User agreement. Then there is no icon to accept terms.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Return from the display of the EULA to the Sonos app. You should see an accept button.

The flow is not all that obvious.

I tried that there is no "Accept" button. I have installed the S2 app on my other galaxy devices with no problem.


I have the same problem Sonos pleasr advise help!

So, when you go from the “terms of use” in your browser back to the app, you should see a button to accept/continue. You may have to scroll down to see it.

Another user reported that disabling “Don’t keep activities” solves his issue:

Userlevel 6
Badge +16

Hi @g2segundo and @Andrew and June, Thanks for reaching out and welcome to the community. I’ll agree with the suggestions of @rattyand @ClausN regarding this issue on accepting the End User License Agreement

I’ll also ask if have you tried other controllers if it will allow you to accept the End User License Agreement.

Let us know how you get on with the advice above.

We're here to answer any further questions you have.