Range extender issue

  • 12 October 2019
  • 6 replies

This is really frustrating. I have a Sonos One, a Connect hooked to the main stereo and 2 Play 5s. Usually, I control things by yelling at Alexa but today I was in the kitchen and grabbed my iPad. Searched for Stan Getz, found the album and pushed play. As the music started on the Play 5 closest to me, I saw a popup saying 'some of your devices are hooked to a wifi extender and may not play correctly.' The message was right; I only had sound out of one of the four devices.

I checked the app, all 4 devices were selected but no sound out of 3 of them. I moved the volume sliders up and down, nothing. The iPad was hooked to the main wireless network, so is everything else. The only reason I even have an extender is because I have a cable TiVo that must have an ethernet connection to update the guide. Yeah, I don't get that, either.

At any rate, I updated all the software, shut the iPad off, tried to start music with Alexa, tried from my iPhone and my desktop. Only one Play 5 would play. I unplugged the extender and after about 30 seconds, the other units came back on.

I then plugged the extender back in and everything is jolly. Sonos system works, so does the extender. I turned off Sonos, turned it back on and all is fine.

If it matters, both the main router and the extender are NetGear. Yes, the password is the same for both, it's my cell number.

I've only had this extender for a few months - the local cable co stopped supplying their generic cable box a few months ago. The TiVo has to have an ethernet connection to update the guide. Yeah, that seems dumb but there ya go.

I checked yesterday while talking about an insurance renewal and the main floor where I have all 4 units is 2000 sf. About 20 feet to the Connect and the One, about the same to the extender, maybe 30 to the Play 5s. The only one that did not grab the extender was the furthest away.

Yes, I've used it before with this configuration and no issues. No, other than install the extender, everything else is the same.

Not the end of the world if I have to unplug the extender every time ... but .... this is stupid.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

I would guess that your extender is not in 'bridge' or 'access point' mode and so is splitting your network into two separate subnets. Check the extender manual. Can't be sure on the information given but I would check that first.
As John mentions, the extender needs to be operating as an ethernet bridge, so that it’s connecting to your router (preferably just over the 5ghz Wifi band only) and not broadcasting its own WiFi network as the signal is not needed for (just) the ethernet wired TiVo box only, or if it’s not possible to switch it’s own WiFi hotspot off (which is unlikely), then at least give it a completely different SSID and channel number to stop your devices switching to it. Some Wifi extenders even have blacklists where a devices connection can be blocked.

The Sonos devices will then hopefully run just on your routers WiFi network.

If you do leave the extender broadcasting a 2.4ghz hotspot signal, for whatever reason (I cant think why?), aswell as changing it’s SSID, I would set it at least 5 channels away from the routers 2.4ghz channel too to prevent signal overlap and interference.
Okay ... I guess I can do that... but why are 3 of 4 Sonos devices just grabbing whatever signal they like? What happens when they hook up to the neighbor's?
Okay ... I guess I can do that... but why are 3 of 4 Sonos devices just grabbing whatever signal they like? What happens when they hook up to the neighbor's?
When running in wireless mode, they only latch onto a 2.4ghz signal with the correct/precise credentials (SSID & Password) that you set them up on initially. They do not attach to networks with different credentials.
Ken. Good call to just turn off wireless on the extender. In this scenario it's the quickest and easiest solution.