Phone no longer reconnects to Sonos when in range


  • Contributor I
  • 5 replies
Recently I've noticed that my phone (android) no longer reconnects to Sonos when in range. (eg, when I come back home). I noticed it a couple of updates ago, hoping it would be fixed, but not yet - hence the post:

Basically, in the past, with the android app, the controls are persistently in the notification area (or the lock screen), allowing you to control the speakers as expected. Even if you went out of range, it would pick up where you left off when returning home.
Not any more.
Now you have to load up the app back up each time to get the controls to show up in the notification area. Very annoying.

Sonos Bridge, 2x Play1, 1x Play3
Sony Xperia Z5 compact
Everything is up to date.
I've tried a reinstall, and resetting my Sonos set up.

Anyone else experiencing this?

11 replies

Userlevel 6
Badge +18
Hi, Rudie. I'm not sure if it's so much an issue of the controller not reloading in general, as it is the notification display not updating to reflect what's going on in-app. Something may have changed in that regard. How long has this been going on? Have you tried uninstalling and reinstalling the application?
Hi Edward
It's been going on I'd say for a couple of months or so.
I've tried reinstalling the app.
Bump

Another app update today, still not fixed
Userlevel 6
Badge +21
Are you on the latest Android version? Android: 5.0 and higher
Yes
Version 7.1.1
I guess the thing that's striking me as a possibility is more that the phone isn't connecting to your wifi... The phone shouldn't be connecting to the speakers, they're connected to your wifi. Might be worth trying a delete of your wifi credentials in the phone, then a hard reboot, and add connect the phone back to your wifi signal.
Thanks for your reply.
The problem isn't with the WiFi, it is the fact the app doesn't automatically kick back in when the phone reconnects to the WiFi.

Nevertheless, I have tried what you said just to be sure, but still no luck.
Userlevel 3
Badge +10
I have noticed the same issue. On a Samsung Galaxy S7. When returning home the lock screen would display the simple Sonos controls and the currently playing info. Now it doesn't.

To be honest, I changed my power settings at about the same time, so I just assumed it was the phone shutting down the app when I left home.
Sorry I can't be of any particular help, then. I can't make any logical conclusions on the process failing.
Badge
The phone is really not getting connected to the Sonos in the range and that is also happening because the system is not verified as I have to make the syncing process of the email and I had to recover gmail password then the system will get connected to the Sonos.
rick1221 wrote:

The phone is really not getting connected to the Sonos in the range and that is also happening because the system is not verified as I have to make the syncing process of the email and I had to recover gmail password then the system will get connected to the Sonos.



Sorry, this makes no sense :?

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings