Answered

New setup of Home Wifi separated 2.4ghz and 5Ghz on two SSID

  • 16 February 2021
  • 7 replies
  • 121 views

Good morning all,

I'm new to this community, your help and advise would greatly appreciated.

 

I have recently setup a new setup which consists of Bt Full fibre to house Fttp. Draytek AP1000C x 3 and a Draytek 48port PoE switch.

 

I decided to separate the 2.4ghz and the 5ghz as I wanted to know which bandwidth i am connecting too.

 

Yesterday, I setup my Sonos home cinema system to the 2.4ghz  SSID. It all works fine as long as im on that SSID, however if I then chose to move over to the 5ghz SSID it doesn't see a network and Sonos will not connect on my mobile phone. 

Sonos system is wifi only no ethernet connected.

Please can you advise if is it possible for the Sonos controller to work on both SSID. 

 

My system comprises of a Playbar with sub 2 xSonos one (Gen 2) surround (TV Room)

Additionally for music only.

Sonos play 5 (Gen2) x 2 lounge

Sonos one (Gen 2) x 2 office and bedroom

icon

Best answer by John B 17 February 2021, 10:19

It is fine to have separate SSIDs for the two bands, but whether you do so or not the Playbar can only connect to the 2.4GHz band, so if your phone is on 5GHz then your app may not be able to see the speakers.  I say ‘may’ because it depends on whether or not your router will pass data between the two bands.  It appears that yours does not.

As suggested, wiring a Sonos device to your network, so that SonosNet is used, would get round this limitation.

Data passes between your HT components by direct routing using the Sonos components’ 5GHz radios.   This traffic does not use your WiFi.

Hi John, thank you for taking the time to reply back,

My router is the new BT Smart Hub 2, I have turned off the wifi signal on the router. Plugged in an ethernet cable from Router to Switch, AP's are connected direct to the PoE switch.  Only the Ap's are producing the wifi signals. 

Would you suggest I try to connect t the playbar via ethernet, if possible. Would that help?

I think connecting one device to your router would be a very good idea - the playbar would be fine.  I would definitely try this.  I suggest you should also follow @ratty ‘s advice to disable the isolation of the two WiFi bands.

After wiring the Playbar, do NOT ‘Disable WiFi’ in the Playbar settings as some users incorrectly do - leave it enabled.  Give the system a couple of minutes to reconfigure, and then check in ‘About My System’ that all Sonos devices are on WM:0 not WM:1.  This proves that all speakers are connected to SonosNet.  If any are not, power them off and on again.

If all seems well and speakers are playing OK then go into Settings, System, Network and remove your WiFi details from Sonos.

Hope that helps.  Please let us know how it goes.

 

View original

7 replies

From the user guide for those APs:

Isolate 2.4GHz and 5GHz bands: The default setting is “Enable”. It means that the wireless client using 2.4GHz band is unable to connect to the wireless client with 5GHz band, and vice versa

 

Disable it.

 

I’m probably old-fashioned but I find it often helps to read the manual.

Userlevel 7
Badge +20

I have the same and it works.  I do have both SSIDs set with the Same password.  Not sure if that is relevant though.

I also have my Sonos Playbase connected to the Ethernet and that sets up Sonosnet so I am guessing that’s why I have no issue.  Have you tried setting one Sonos device up with Ethernet?  You don’t have to use Sonos Net.

It is fine to have separate SSIDs for the two bands, but whether you do so or not the Playbar can only connect to the 2.4GHz band, so if your phone is on 5GHz then your app may not be able to see the speakers.  I say ‘may’ because it depends on whether or not your router will pass data between the two bands.  It appears that yours does not.

As suggested, wiring a Sonos device to your network, so that SonosNet is used, would get round this limitation.

Data passes between your HT components by direct routing using the Sonos components’ 5GHz radios.   This traffic does not use your WiFi.

From the user guide for those APs:

Isolate 2.4GHz and 5GHz bands: The default setting is “Enable”. It means that the wireless client using 2.4GHz band is unable to connect to the wireless client with 5GHz band, and vice versa

 

Disable it.

 

I’m probably old-fashioned but I find it often helps to read the manual.

Ratty, thank you.. yes it does help if you read the manual.  Agree. Lol.. these days you need to download it... Nothing comes with manual these days.

I very much appreciate your help and advise on these Ap's I will certain check this out.  I will download the manual now. 👌🏽

 

 

It is fine to have separate SSIDs for the two bands, but whether you do so or not the Playbar can only connect to the 2.4GHz band, so if your phone is on 5GHz then your app may not be able to see the speakers.  I say ‘may’ because it depends on whether or not your router will pass data between the two bands.  It appears that yours does not.

As suggested, wiring a Sonos device to your network, so that SonosNet is used, would get round this limitation.

Data passes between your HT components by direct routing using the Sonos components’ 5GHz radios.   This traffic does not use your WiFi.

Hi John, thank you for taking the time to reply back,

My router is the new BT Smart Hub 2, I have turned off the wifi signal on the router. Plugged in an ethernet cable from Router to Switch, AP's are connected direct to the PoE switch.  Only the Ap's are producing the wifi signals. 

Would you suggest I try to connect t the playbar via ethernet, if possible. Would that help?

I think connecting one device to your router would be a very good idea - the playbar would be fine.  I would definitely try this.  I suggest you should also follow @ratty ‘s advice to disable the isolation of the two WiFi bands.

After wiring the Playbar, do NOT ‘Disable WiFi’ in the Playbar settings as some users incorrectly do - leave it enabled.  Give the system a couple of minutes to reconfigure, and then check in ‘About My System’ that all Sonos devices are on WM:0 not WM:1.  This proves that all speakers are connected to SonosNet.  If any are not, power them off and on again.

If all seems well and speakers are playing OK then go into Settings, System, Network and remove your WiFi details from Sonos.

Hope that helps.  Please let us know how it goes.

 

I have the same and it works.  I do have both SSIDs set with the Same password.  Not sure if that is relevant though.

I also have my Sonos Playbase connected to the Ethernet and that sets up Sonosnet so I am guessing that’s why I have no issue.  Have you tried setting one Sonos device up with Ethernet?  You don’t have to use Sonos Net.

Thank you so much, for taking the time to reply. I will try the Sonos one connected via Ethernet.

It is fine to have separate SSIDs for the two bands, but whether you do so or not the Playbar can only connect to the 2.4GHz band, so if your phone is on 5GHz then your app may not be able to see the speakers.  I say ‘may’ because it depends on whether or not your router will pass data between the two bands.  It appears that yours does not.

As suggested, wiring a Sonos device to your network, so that SonosNet is used, would get round this limitation.

Data passes between your HT components by direct routing using the Sonos components’ 5GHz radios.   This traffic does not use your WiFi.

Hi John, thank you for taking the time to reply back,

My router is the new BT Smart Hub 2, I have turned off the wifi signal on the router. Plugged in an ethernet cable from Router to Switch, AP's are connected direct to the PoE switch.  Only the Ap's are producing the wifi signals. 

Would you suggest I try to connect t the playbar via ethernet, if possible. Would that help?

Reply