New PC


Hi Guys

I have a new PC running windows 10, I have rebuilt my library, I can see all the albums and tracks however I can not get any to play, I have tried rebooting me Sonos rooter, bridge and Play 1, I managed to get one track to play this stopped soon after stated, I just get unable to play.  I have tried the methods    ENABLE SMB and DISABLE SMB after watching videos on YouTube via the Sonos website however still no tracks playing 

 

Please help


19 replies

Did you remove the old library and add a new one from the new PC?  If not, you must.  See these links:

 

Removing your music library

 

Adding and updating your music library

 

Hi jgatie

 

Thanks for the advice. Yes I removed the old one from my old PC, I still have the old PC and now only use ift for downloading I have also deleted the Sonos software from my old PC. 

 

Kind regards Mercury2021 

Hi jgatie

 

Thanks for the advice. Yes I removed the old one from my old PC, I still have the old PC and now only use ift for downloading I have also deleted the Sonos software from my old PC. 

 

Kind regards Mercury2021 

 

I’m afraid you have misunderstood.  Your Sonos devices are where the library information is stored, not the Sonos software.  Therefore, deleting the software from the old PC makes no difference, the Sonos devices themselves are still looking for the library on the old PC. You need to follow the links given above to delete the old library information from the Sonos devices, and then add the new library to the Sonos devices.  

Hi  jgatie

 

Yes I did just as in the link first before adding the library on my new PC. Below is my new library on the new PC

 

Kind regards mercury2021 

 

Userlevel 7
Badge +21

So it is working now? i am confused. You should set up your library using the PC Sonos app, as that can fix the file permissions if necessary, and also sets up the http file daemon service. The screenshot is from the iOS app, which cannot do any of that. (Plus why so many shares, but that is orthogonal).

So it is working now? i am confused. You should set up your library using the PC Sonos app, as that can fix the file permissions if necessary, and also sets up the http file daemon service. The screenshot is from the iOS app, which cannot do any of that. (Plus why so many shares, but that is orthogonal).

Huh? So some setup has to b done from a PC still, after everything was moved to phones?

Userlevel 7
Badge +21

Huh? So some setup has to b done from a PC still, after everything was moved to phones?

If the files are on a PC, duh yeah.

Phones can’t just magically access all the stuff on your PC. That would be kind of a enormous security hole.

Huh? So some setup has to b done from a PC still, after everything was moved to phones?

If the files are on a PC, duh yeah.

Phones can’t just magically access all the stuff on your PC. That would be kind of a enormous security hole.

I seem to have an ‘add shared music folder’ on my android phone, which one assumes would be used to add a share….

Hi guys 

 

Sorry for the confusion. 

 

I have deleted all the folders and music from my old PC following the Sonos instructions I have added my new library on my new PC following the instructions.  I have tryed adding all the music as individual folders and all in one go in My Music, every time the first track plays fine as soon as it change track the system can not access the foldernof My Music. I have also have an error message 1001 and 1002 I have rebooted the system this make no difference.

 

I have added music librarys using Sonos for many years and never had any issues in the past.

 

Any help would be much appreciated 

 

Regards mercury2021 

Userlevel 3
Badge +11

Hi there,

Is the music filed being streamed from a NAS, external hard drive, from a local storage on a computer, or mobile device on the local area network?

Hi Sedastien

 

Thanks for getting back. 

 

I all in folders on my PC hard drive.

Regards Dave 

Userlevel 3
Badge +11

It's possible that a minor network communication issue is what's causing the problem. As a troubleshooting step, start by unplugging both your Wi-Fi router from power for 30 seconds. After they're plugged back in, restart your Desktop. Give everything a few minutes to come back online and then attempt to add the music library share again.

 

Let meknow how it goes. If you don’t mind, Submitting a diagnostic through the Sonos app provides us with a snapshot of your system so we can help identify what is causing your issue. Then, please reply back the diagnostic confirmation number so I can take a closer look at the issue.

Hi Seb

 

Thanks for getting back I have done as you asked my log number is

497719391

 

Kind regards Dave 

Userlevel 3
Badge +11

No problem at all, let’s also check your Windows firewall settings are appropriate for use with Sonos. The following guides should help you to that end.

 

Configuring your firewall to work with Sonos

 

Configuring Windows to work with Sonos

 

Let me know what you think.

Hi Seb

 

Thanks for the info, I have gone through the setting as in the instructions and my setting are the same, however I’m still having the same problem, the first track plays fine as soon I change track or album, I lose the system.

 

Any other advice would be much appreciated, as at the moment I have a library of 300gb over 17 folders and not way to playing this via my Sonso.  I can’t understand whats gone wrong I rebuilt my library many time on my old PC without any issues.

 

Kine regards Dave 

Userlevel 3
Badge +11

Hello Dave,

 

As you have tried the steps highlighted in that guide and you're still having troubles with the connection, we would probably need to have a look at your Music Library configuration through a remote session.

In that case, do you think it would be possible for you to call us in during weekdays (Mon-Fri 10am-9pm EST), so that we can provide you with live assistance and a remote session on your PC?

Hi Seb

 

This is the message I'm getting this was after trying to change tracks

 

Regards Dave 

Is your PC going to sleep?  If so, that’s why it can’t be found.  

Hi jgatie

 

Thanks for the advice, the PC is not going to sleep. 

 

Kind regards Dave 

Reply