Need possibility of adding delay in addition to the normal 70ms



Show first post

178 replies

I have recently upgraded to a new Yamaha AV receiver and have the same issue - how a "high end" system (such as SONOS) can not be customised to improve compatibility with other high end products is beyond belief! Surely a simple add-in in the advanced user settings can't be take a year of "consideration" !
In addition - the amount of people impacted by this issue is only going to increase over time - as people upgrade their home electronics. Like me - my SONOS worked fine until i upgrades a 14year old amp - now SONOS is the item that looks behind the times because of the lack of flexibility - something I thought I would never say!
I think it is lame that i got redirected to this after submitting a question to Sonos support when i was hoping for a real answer as this is the primary reason i won't buy any Sonos products & it is completely dumb that this feature doesn't exist.  i've been investigating purchase options & have avoided jumping in to Sonos because of this feature.  I really hope that either this is resolved or another company comes up with a better system.

i've seen suggestions of Sonos surround for movies, perhaps using play 1s for the back speakers.  well, i feel like anyone who is interested in a well synchronized multiroom system would also want a real amp (as opposed to a connect) to drive the main front speakers.  and if you use your nice amp, well those front speakers won't match in time with the rear until this issue is resolved.
Userlevel 1
I think it is lame that i got redirected to this after submitting a question to Sonos support when i was hoping for a real answer as this is the primary reason i won't buy any Sonos products & it is completely dumb that this feature doesn't exist.  i've been investigating purchase options & have avoided jumping in to Sonos because of this feature.  I really hope that either this is resolved or another company comes up with a better system.

i've seen suggestions of Sonos surround for movies, perhaps using play 1s for the back speakers.  well, i feel like anyone who is interested in a well synchronized multiroom system would also want a real amp (as opposed to a connect) to drive the main front speakers.  and if you use your nice amp, well those front speakers won't match in time with the rear until this issue is resolved.

Hi Steve, I'm not sure you understand the delay and when it comes into play. I believe a standard analog stereo amplifier with no processing will play in sync with a connect. The trouble is a lot of us have theater receivers which process and add delay. Some are lucky enough to disable this processing. The delay is hideous and I believe it is the responsibility of sonos to correct and make a connect a viable option. That and no integration virtually eliminate my recommendation of sonos in many applications. Bose has recently released their copycat product. You may want to investigate that a bit
I think it is lame that i got redirected to this after submitting a question to Sonos support when i was hoping for a real answer as this is the primary reason i won't buy any Sonos products & it is completely dumb that this feature doesn't exist.  i've been investigating purchase options & have avoided jumping in to Sonos because of this feature.  I really hope that either this is resolved or another company comes up with a better system.

i've seen suggestions of Sonos surround for movies, perhaps using play 1s for the back speakers.  well, i feel like anyone who is interested in a well synchronized multiroom system would also want a real amp (as opposed to a connect) to drive the main front speakers.  and if you use your nice amp, well those front speakers won't match in time with the rear until this issue is resolved.

Yes, I know.  not sure if this link works, but here's was my initial support question.  I'm using amp/receiver interchangeably to refer to a device capable of doing the signal processing.
https://sonos.custhelp.com/app/account/questions/detail/i_id/1074702
+1. I have a Yamaha YSP 4100 and purchased the Connect and used the Analog RCA and uncompressed SONOS music. Still a delay. 
+1.  Yamaha YSP 4100 has a delay too. Even using analog rca and uncompressed on sonos didn't work.
+1 I have the same Problem with my Bose lifestyle 135. SONOS PLEASE !!! 🙂
Userlevel 1
It has been over a year since Sonos put this problem "under consideration". It remains a significant issue, and this thread has become a wailing wall of voices in the wilderness. My suggestion at this point is to call technical support with the issue, and escalate it. Express your dissatisfaction to a person. One paranoid concern is that the delay favors establishing Sonos' own equipment as a proprietary closed system by exploiting the inability of other sound bars/amplifiers to make the adjustment. You'll need to give up on that Yamaha sound bar for one from Sonos, or purchase a new AV receiver offering the proprietary Sonos port.
Plz add a delay funtinality, how hard can it be? A mic on line in @ the Connect or the mic in the smartphone? Come on now!
Plz add a delay functionality. How hard can it be? Use the line in with a mic on the Connect or use the mic on the smartphone... Come on now!
Require this functionality Zones are out of synch. ZP90 on Onkyo AVR and S5 in the kitchen. Very annoying! I would recommend Sonos to finally address this issue. Todays Quality AVRs are very costly and delays through DSPs will not be smaller but larger! Using "Pure or Direct Modes" of the AVRs is NOT the answer. Its like buying a Ferrari and only allowed to drive in 1st gear. A simple statement from Sonos that they will not support this feature is sufficent. But no comment for over several years (has already been adressed on the forums much earlier) is just not customer oriented for a premium product/company that Sonos claims to be.
I had this problem too. lag between connect plugged in to my yamaha AV receiver and play 5. Even with direct/pure (no processing) audio there was a noticeable lag and delay when the connect was plugged in through optical audio, but when i switched it to RCA red and white connection... the lag was no longer noticeable FYI

However, I still think this is a very important issue for Sonos to address... there should be a option to put in delay to certain selected zones.
Any news on this important issue?  Your product does not work as advertised. Party mode is useless because of this.

If this is not fix during the next few weeks (or at least give us an announcement for a future fix), I will return my connect, play 1s and play 5s starter setup that I just bought.  I was planning on adding more unit but this is a deal breaker for me.

Thanks for you honesty.
Adding my two cents. I own a V35 and wanted a playbar and sub for the bedroom as well as some play 1s for moving around the house. Was literally about to buy until I discovered this thread. Wont be buying anything until its resolved.
Please add a Delay function. Any word on its progress?
update??
Please sonos you are selling this piece of equipment, which is not fit for purpose in a complete system without this update , sort it out
Hi, will this be implemented in the next 20 days?  I got a Play:3 for christmas to test out the system, loved it, and then bought a 2nd Play:3, 2 Play:1's and a Connect hooked up to a Denon AVR-3313Cl, and the echo is totally unacceptable for anything but very quiet listening.  I plan to return all components if not fixed within my return window, so I can get a refund.  I am very disappointed, because it is otherwise fantastic.   PLEASE FIX THIS ASAP!
Don't count on it, I have been requesting this for 2.5 years and Sonos seems oblivious to the need, I even called them directly and send them emails to all the posts out there looking for this ability....no response, Sonos really dropped the ball on this one...I do build-outs on smart homes,I had to swich away from Sonos years ago for that exact reason.  They have lost several hundreds-of-thousands, if not close to a million in sales from me alone due to this issue....Though I shouldn't be, I am still hopeful they will eventually fix this as I have Sonos at my house.  They haven't even indicated if this is on the drawing board, all I can get from them is "We will forward this to our development team"....Time to dump Sonos!
I suggest you return all your Sonos stuff with a letter explaining why....Maybe that will get their attention.  Alternatives:  HTD makes a pretty good solution, Elan or Savant are the best, but will cost you.  I can confirm that all three of those can adjust for zone delay introduced by modern audio processors.  The thing that pisses me off about Sonos is:  THIS USED TO BE A FEATURE...in very old software versions and they got rid of it for some reason?????? 
That's too bad... I still have a few days until I can't return them anymore, I'll wait until then. Please sonos, break the silence.
FYI - Sonos is NOT a high end system...It is among the cheapest out there...will lets say "most affordable" since I do believe the Sonos hardware is quality.  You can do a entire house with Sonos for under 5K, I have installed systems costing 250K+, of course those systems are far more capable as far as integrating with other systems such as pools, lighting, HVAC, alarms, etc....Sonos just doesn't realize how much a site like this hurts them...anyone doing research will find this and steer clear.
Yeah, those hits must add up very quickly.  Past AND future sales...  I for one, wouldn't have invested so much in Sonos product if I had known this before.  I feel that they're practically doing *false advertising. 

* They should at least put a warning in "small print".  "Won't work properly with most moderns Hi-Fi systems."
I send back my connect, because i don't accept the delay to yamaha.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings