Answered

Music Library is not imported

  • 18 July 2021
  • 3 replies
  • 54 views

My music library consists of several thousand recordings managed through iTunes (though I’ve just discovered iTunes has been replaced by Music).  I have configured iTunes/Music to load and access files from an external hard drive attached to a MacMini running macOS Catalina 10.17.5.

This MacMini runs S1, and I have several Sonos components on S1 in my home.  I have used the MacMini’s S1 Controller’s Music Library Settings to assign the correct directory with my music files on the external drive.  This had worked for many years, but at some time in the recent past the Music Library listings disappeared. 

After putting off dealing with this issue for a while, I bit the bullet this weekend and began troubleshooting.  Progress so far:

  • I downloaded and installed the latest version of S1 Controller for Mac (11.2.9)
  • I have configured S1 to access the music files on the external drive several times
  • I have run the indexing several times
  • I have explored various permissions configurations on the MacMini, and rebooted each time

The Sonos Music Library remains empty.

One anomaly -- when I configure the S1 Controller on the MacMini using the My Music Folder option some of the stray music files that didn’t get transferred to the external drive show up in the Music Library section.

 

icon

Best answer by Potter3 18 July 2021, 18:14

While waiting for a Support chat, I unearthed https://support.sonos.com/s/article/2401?language=en_US which had this suggestion that did not make intuitive sense:

 

Configure your Mac’s file sharing settings

If you’re using macOS, try disabling File Sharing by going to System Preferences > Sharing. Uncheck File Sharing and try re-adding your music library.

 

And, of course, it worked.

View original

3 replies

Your anomaly suggests that the Sonos speakers can’t ‘see’ the external drive. Any chance this external drive is an NAS? If so, the most likely issue is a setting needs to be adjusted to allow access via SMB v1 on it, which is currently required by Sonos, and frequently turned off by software updates to NAS drives, often without any explicit warning that the update is doing so.

If it isn’t an NAS drive, it does suggest an issue with the address given Sonos to ‘see’ where the drive is, so perhaps more detail is needed to give you additional assistance. Have you submitted a diagnostic, and spoken to Sonos support folks?

Thanks Bruce.  This is an external drive directly attached to the MacMini, not a NAS.  I do agree that it is probably a permissions issue.  I have not contacted Sonos support yet but will shortly.

While waiting for a Support chat, I unearthed https://support.sonos.com/s/article/2401?language=en_US which had this suggestion that did not make intuitive sense:

 

Configure your Mac’s file sharing settings

If you’re using macOS, try disabling File Sharing by going to System Preferences > Sharing. Uncheck File Sharing and try re-adding your music library.

 

And, of course, it worked.

Reply