Question

Lost AirPlay connection with Apple Music

  • 19 May 2020
  • 5 replies
  • 76 views

Userlevel 2

Hello,

When I pause/stop my music on Apple Music, my Sonos is often not available anymore after to play through AirPlay. I have to close Apple Music a few times and my Sonos will be back online. Here is the latest diagnostic number: 1995294878.

If it could help... When I use the Sonos application on my iPhone, I never have any problems. It's always with Apple Music and AirPlay on my MacBook Pro.

Thanks.
Jean-Philippe


5 replies

@jprlauzier Thank you again for the follow up and sorry any confusion from your original post pointing towards issues with your Macbook pro. I would ask that you follow the steps provided in my previous post with your Sonos One wired to the router first. If you are not noticing the issue then remove the Ethernet wire and test again in Station Mode with your Sonos One on the routers wifi connection. Knowing we are looking at the Airplay option having trouble finding Sonos as a target on the wifi network you will want to refresh the network and Sonos device(s) along with the Apple products that can Airplay. You may find that a network, app controller, and Sonos product refresh may be needed once every 30 days to 6 weeks.

Lastly, due to what we can see as wifi interference you may want to keep your router on channel 11 when having your Sonos One connected wirelessly to your network. When you are wired for Sonosnet, test your router on channel 6 and Sonosnet as channel 11.

You can follow up here with the testing results and a new diagnostic report number.

Userlevel 2

@John G I was unaware of the Sonos Controller for Mac application. I downloaded and submitted the diagnostic report 422165823. “jprl-studio” and “jprl-studio-5G” are my networks. I never saw the “Network9 3/4” before. However, when I use the Sonos Controller, I have no problem to play music on the Sonos so it doesn’t seem to be a problem with the wireless network. It’s only when I want to use Apple Music that the Sonos is not always listed as a AirPlay device. Thanks!

@jprlauzier Thank you for the follow up and the new diagnostic report number. We needed to see the new report being sent from your Mac controller. That one is showing from an iOS mobile device. I am still concerned that we do not have your full network topology as your Sonos One shows many connection options in the area but ones from your network setup with names like “jprl-studio”, “Network9 3/4” and “jprl-studio-5G”.

I would next ask that you power re-boot off your wifi equipment for 30 seconds with no lights on it, meaning no battery backup, then power it back up. While this equipment is powering back on then power re-boot off your Sonos unit(s) for the same time with no lights and plug them back in to power, no button pressing is needed. Also, for testing, Ethernet wire your Sonos One to the router during these steps. While we are powering back on then re-boot the device(s) running the Sonos app. When you are reconnected then test the music playback for 30+ minutes. You can follow up here with the testing results and a new diagnostic report number from your Mac controller.

Lastly, when we point out wifi interference it includes the home environment, meaning where you have Sonos products sitting on or next to items/materials from that previous link, as well as network interference. I would also recommend in your testing to set you router to wifi channel 6 and when wired with your Sonos One set it up on Sonosnet channel 11 as there seems to be the most wifi interference on channel 1.

Userlevel 2

@John G Thanks for the response. I got the situation once again a few minutes ago. Here is the diagnostic report: 256629015. My network topology is simple with a modem/router Hitron CODA-4680 from my provider.

  • Wireless network 2.4G (20MHz/channel 8 )
    • Only the Sonos One is connected on this network
  • Wireless network 5G (80MHz/channel 153)
    • Apple TV
    • Macbook Pro
    • iPhone
  • Wired
    • Philips Hue bridge

I also tried to change the channel from 3 to 8 a few days ago. I am trying the channel 6 for now.

@jprlauzier Sorry for the slow reply and welcome to the Sonos Community. Are you still running into this issue from your Mac controller? If yes, please update use with new diagnostic report number from your Mac controller when the issue is happening. Also, we will need your full network topology with the model names and numbers of the products that are wired or wirelessly connected on your network for any modem, router(s), extenders, access points or switches (managed or unmanaged). What you are describing may be tied into WiFi interference that you may be able to correct in your home or network equipment environment.

Reply