Line-in sound cuts out all the time

  • 22 March 2014
  • 37 replies
  • 16745 views

I connected one of my Sonos Play5's to my computer via the line-in headphone jack. I have 2 other Play5's and a bridge. Those other 2 Play5's not connected to the headphone jack very rarely produce sound consistently. This is a really bad problem for me considering that I play all sporting events and video thru my computer. I'll have guests over to watch a game, and 2 of my relatively expensive Sonos speakers constantly flicker in and out so bad that I just have to turn them off and hardwire other speakers. What I've tried: rotating the speakers, disconnecting/reconnecting, removing all components and re-adding all components in the Sonos program. The router is not near any of my Sonos components. I'm not running other programs that take bandwidth, and if I'm streaming something online, the video will continue to work while the sound cuts out. I have a 110mbps connection. Thanks for the help. -Kevin

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

37 replies

Userlevel 7
Badge +26
Hello Kevin,

Sounds like you have a lot of wireless interference there which can cause this issue. The audio signal from the PLAY:5 is getting transmitted digitally across the network to the other two units and if that signal is having trouble you'll get cutouts or it'll fail to play completely.

I'd recommend starting with changing the wireless channel on your Sonos system to start with. If you can check the channel on your router, please make sure that it's a good 5 channels away from the channel of your Sonos system.

If you're still having trouble, can you please submit a diagnostic from your system and reply back with your conformation number?

Thanks
I am having the same issue. However the option to change a wireless channel is no longer an option in the Mac or iOS Advanced Settings menus. Is there another way to deal with wireless interferance?

Thanks.
Userlevel 1
Badge +1
Try enabling audio compression in the controller settings (if has not been enabled already)
Under Sonos > Preferences > Advanced > Audio Compression the system is already set to "Automatic". Do you recommend setting it to "Compressed"?
Userlevel 1
Badge +1
Try to see if it is any better. Also worth trying is setting up your system without the sonosnet, but using your default wireless network.
Setting the default to Compressed seems to have resolved the issue for me. Thanks!
Userlevel 2
Badge
I have do ask, what does Audio Compressions do and is it best to set the default to Compressed or Automatic?
Userlevel 7
Badge +26
I have do ask, what does Audio Compressions do and is it best to set the default to Compressed or Automatic?
The uncompressed Line-In streams a WAV audio format across the network while compressed uses the SBC codec. Compressed is a smaller data transfer so it uses less bandwidth and can have more transfers fail before you hear any audio cutting out. If you're familiar with audio formats, Uncompressed is a lossless format while Compressed is lossy.

In general, we recommend leaving the system at Automatic. But if you run into streaming issues, Compressed will help. The downside to using Compressed is it has a lower quality stream and more of a delay. Automatic will use Uncompressed until you have several rooms and will then switch to Compressed.
Hello Kevin,

Sounds like you have a lot of wireless interference there which can cause this issue. The audio signal from the PLAY:5 is getting transmitted digitally across the network to the other two units and if that signal is having trouble you'll get cutouts or it'll fail to play completely.

I'd recommend starting with changing the wireless channel on your Sonos system to start with. If you can check the channel on your router, please make sure that it's a good 5 channels away from the channel of your Sonos system.

If you're still having trouble, can you please submit a diagnostic from your system and reply back with your conformation number?

Thanks


I am having the same issue. My diagnostics confirmation number is 5605651

My line-in audio is going into my play 5 and it is my record player which I use a ton.
Userlevel 7
Badge +20
Hello Kevin,

Sounds like you have a lot of wireless interference there which can cause this issue. The audio signal from the PLAY:5 is getting transmitted digitally across the network to the other two units and if that signal is having trouble you'll get cutouts or it'll fail to play completely.

I'd recommend starting with changing the wireless channel on your Sonos system to start with. If you can check the channel on your router, please make sure that it's a good 5 channels away from the channel of your Sonos system.

If you're still having trouble, can you please submit a diagnostic from your system and reply back with your conformation number?

Thanks


I am having the same issue. My diagnostics confirmation number is 5605651

My line-in audio is going into my play 5 and it is my record player which I use a ton.


Hi Abj0028,

There's a significant amount of wireless interference showing on your Sonos system. This is causing communication errors between your PLAY:5, which is accepting the line-in feed, and the other 4 speakers you have grouped with it. Please try changing the wireless channel that your Sonos system is using, here's how. Try each of the other channel options and see if that helps.

It is also worth noting the audio compression setting, in the settings menu, under advanced settings. If it is set to uncompressed, you are potentially sending a very large amount of data from your PLAY:5 to the other 4 speakers. This can lead to audio interruptions as the bandwidth is exceeded. If changing the wireless channel does not help, try setting the compression level to compressed and see if that helps.
Changing the channel seemed to have helped! Thanks so much!
Userlevel 7
Badge +20
Changing the channel seemed to have helped! Thanks so much!

Hi Abj0028,

That's great to hear. Please let me know if you have any more issues.
Badge +1
I just hooked up a turntable and am having the same option. Changing to compressed worked but I hate that I'm having to compress my music. Is there any kinda work around to get the full experience?
I'm having the same issue. Can you check my diagnostics? 6980171
Userlevel 7
Badge +20
I'm having the same issue. Can you check my diagnostics? 6980171

Hi Keenant,

It may help to set your audio compression rate to compressed. To do so, head into the settings menu of the Sonos app and choose advanced settings. Uncompressed audio can use a quite high level of bandwidth, which can lead to audio interruptions when streaming to other players.

You may also be able to improve the connection between your speakers by changing the wireless channel your Sonos system is using. There's a bit of interference showing up which can limit the effective bandwidth.
HI I am also havinbg issue with the line 1 cutting in and out...
Here is my diagnostic number; 7069403

Any help would be greatly appreciated.
Same problem I'm afraid (with a Mac line-in). Have tried compression. Diagnostic: 7072997.
Userlevel 7
Badge +20
HI I am also havinbg issue with the line 1 cutting in and out...
Here is my diagnostic number; 7069403

Any help would be greatly appreciated.


Hi SankeysRTW,

There's quite a bit of wireless interference showing up which is likely the cause of your playback issues. Please start by changing the wireless channel your Sonos system is using. It may also help to set the audio compression to compressed in the Sonos app's settings menu under advanced settings.
Userlevel 7
Badge +20
Same problem I'm afraid (with a Mac line-in). Have tried compression. Diagnostic: 7072997.

Hi fecklessstudent,

It looks like your PLAY:5 is connecting to your wireless network but that it is losing connection from time to time. Also, there's an ethernet cable connected to the PLAY:5. We don't recommend using the ethernet port when your speakers are connecting to the wireless network.

There are some other wireless networks in range on the same channel as yours. This could be the reason your speaker is losing connection occasionally. Please try changing your router's wireless channel to 1 and see if things improve.

It may also help to head into the Sonos app's settings menu, then choose advanced settings and set the compress level to compressed.
I was having the same problem with speakers cutting out when playing my turntable connected via line-in. Yes, setting to "compressed" worked, but who wants that when dealing with vinyl?
A solution found mentioned on here somewhere (can't find it to thank the guy) is to switch the line-in device name to "Airplay device". That apparently gives a second more of buffering time (as Sonos thinks its dealing with an airplay device) and since switching I haven't had one drop.
I am having the same issue. When I play music from the app all 3 of my units play great (1 play 5 and 2 play 3's). When I play audio to the line in it cuts in and out so bad that you can't even use it. I've tried every possible setting. I even went from using an aux cord to an optical cable from my TV. No luck. I've tried compressed/uncompressed, every channel possible. It's pretty frustrating. I've submitted 2 different diagnostics and haven't received any help. I just receive "call us to troubleshoot". Which I know they are just going to have me try all of the things I've already read and tried. Seems to be a very common issue. odd to think that they haven't found a bug fix or admitted that the line in and sending audio to grouped systems doesn't work well.
Userlevel 2
Badge +1
Hi Angrybear,

We hear you and would like to find a solution for you to get this Line-In working more reliably. I understand that you have been told to call in by a technician before t call in. We have multiple levels of Support, so if our Tier 1 technician is unable to get the line-in to work, our Tier 2 will continue working with you until we do.

If you have the ticket number with us, I'd be happy to take a look at that and see if there are any other immediate changes that will need to be made.
I'm getting cut outs on the play 5/connect combination, as well. Can you take a peek at my diagnostic? My confirmation number is: 7618574.
yeah Sonos is pretty garbage TBH, if you are serious about getting good sound. NOBODY who is trying to listen to vinyl wants to stream a compressed signal!!!! I dont care what the hell the compression setting is. I just bought a boost because some support moron said it would certainly be able to stream uncompressed with no drops, but it is still dropping just as bad. I want to sell all this sonos garbage. AWFUL product
I was having the same problem with speakers cutting out when playing my turntable connected via line-in. Yes, setting to "compressed" worked, but who wants that when dealing with vinyl?
A solution found mentioned on here somewhere (can't find it to thank the guy) is to switch the line-in device name to "Airplay device". That apparently gives a second more of buffering time (as Sonos thinks its dealing with an airplay device) and since switching I haven't had one drop.
HOW DO YOU DO THIS?