Answered

Issues using two S1 controllers in one household


I’ve been successfully using the S1 app for a couple of years to control my Play:5 but after adding a Play:3 I want both me and my wife to be able to control the speakers. My wife downloaded the S1 app and can use it fine but ever since she did I keep getting a message in my S1 app that it can’t connect to Sonos and no speakers are visible. It clears when she moves out of wifi range then i can control the speakers again.

I always understood two people could have the S1 app in the same household and control the same speakers. Is this not the case? This is a showstopper for us if we can’t get it to work for both of us.

Thanks

icon

Best answer by Corry P 24 March 2021, 15:00

Hi @Venusi74 

Welcome to the Sonos Community!

This is a weird one, no doubt. But as @John B stated, you can use multiple controllers on one system. 

Please uninstall the Sonos app from your phone, reinstall it and test. If that hasn’t fixed the problem, please reset your phone’s network settings (this will erase all known WiFis from it’s memory), reconnect to your WiFi and test again.

To Reset your Network Settings: Tap Settings (iPhone settings) > General > Reset > Reset Network Settings. This resets Wi-Fi networks and passwords, cellular settings, and VPN and APN settings that you’ve used before.

View original

12 replies

I have absolutely no idea what could be causing that bizarre behaviour, but it is still the case that multiple controllers can be used on the same Sonos system.  Getting highly speculative, I wonder if this is caused by devices flipping between two router bands.  If you have a dual band router are you able to temporarily disable the 5GHz band and see if that makes any difference?

Do you have any access points or mesh devices, or just a single router?

Thanks John, might be something in that. My Vodafone router is indeed dual band but the 5GHz band is labelled differently and the S1 app is only connected to the 2.4GHz band. I’ll see if i can disable the 5GHz band as I don’t really use it for anything. 
I do also have a couple of Mesh devices to boost signal around the house though not sure how this would impact app use as they use the same wifi network name as the router?

Thanks John, might be something in that. My Vodafone router is indeed dual band but the 5GHz band is labelled differently and the S1 app is only connected to the 2.4GHz band. I’ll see if i can disable the 5GHz band as I don’t really use it for anything. 
I do also have a couple of Mesh devices to boost signal around the house though not sure how this would impact app use as they use the same wifi network name as the router?

There is probably no point in disabling the 5GHz band if you are sure that both controllers are on 2.4GHz and are staying on it throughout.  Same SSID and password isn’t sufficient - are your access points set up in ‘bridge’ mode or could they still be acting as DHCP servers?  Simplest experiment is to power off the access points and see if you still experience the odd behaviour on the controllers.

Further thought.  After powering off access points (if you decide to try this), you should power off the router, Sonos speakers, and controller devices, power router back on, then power up other devices.

Userlevel 7
Badge +21

I would guess that her phone has a VPN installed for her work, and VPNs will block the local network access. If this is an iPhone then the “Local Network” option needs to be allowed for the app, and there is also the “random mac address” option that is sometimes required to be disabled on multi-frequency routers.

I would guess that her phone has a VPN installed for her work, and VPNs will block the local network access. If this is an iPhone then the “Local Network” option needs to be allowed for the app, and there is also the “random mac address” option that is sometimes required to be disabled on multi-frequency routers.

Thanks. Her phone is a personal phone with no VPN. Both mine and hers have “Local Network” allowed for the S1 app.

Userlevel 6
Badge +16

Hi @Venusi74 

Welcome to the Sonos Community!

This is a weird one, no doubt. But as @John B stated, you can use multiple controllers on one system. 

Please uninstall the Sonos app from your phone, reinstall it and test. If that hasn’t fixed the problem, please reset your phone’s network settings (this will erase all known WiFis from it’s memory), reconnect to your WiFi and test again.

To Reset your Network Settings: Tap Settings (iPhone settings) > General > Reset > Reset Network Settings. This resets Wi-Fi networks and passwords, cellular settings, and VPN and APN settings that you’ve used before.

Hi @Venusi74 

Welcome to the Sonos Community!

This is a weird one, no doubt. But as @John B stated, you can use multiple controllers on one system. 

Please uninstall the Sonos app from your phone, reinstall it and test. If that hasn’t fixed the problem, please reset your phone’s network settings (this will erase all known WiFis from it’s memory), reconnect to your WiFi and test again.

To Reset your Network Settings: Tap Settings (iPhone settings) > General > Reset > Reset Network Settings. This resets Wi-Fi networks and passwords, cellular settings, and VPN and APN settings that you’ve used before.


Thankyou. I’ll try an uninstall and reinstall tonight. I more or less did that two days ago as i had trouble getting the S1 to recognise the new Play:3 but I’ll completely remove the app this time and start again.

Never a horrible thing to reboot the controller device, too, just as an extra “belt and suspenders” kind of thing. Fresh load of both OS and application is good. 

Userlevel 6
Badge +16

@Venusi74 

Did that help? If so, could you please mark the best answer?

@Venusi74

Did that help? If so, could you please mark the best answer?

Not sure how to mark the best answer but in my case I uninstalled and re-installed the app then added a Symfonisk lamp to my system a couple of days later and since then I’ve not had the issue so touch wood it’s now sorted itself out!

Just going through a change of ISP now so I’ve no doubt that will cause more fun in the coming days. Thanks all for your suggestions. :)

Userlevel 6
Badge +16

@Venusi74 

Apologies - my mistake. You couldn’t mark best answer as the topic had been converted to a conversation. Fixed now.

Glad to hear things are working better now!

Reply