Answered

iPhone lock screen not showing up

  • 10 November 2021
  • 11 replies
  • 111 views

My sonos app will not show up in my lock screen. I have disconnected all other devices including airpods. I’ve restarted the app. I’ve toggled the setting for lock screen on and off. I’ve turned both my phone and the system off and on. I’ve uninstalled my sonos and reinstalled.

 

Is there anything else that can be done to correct this issue?

icon

Best answer by GuitarSuperstar 10 November 2021, 19:48

View original

11 replies

Userlevel 7

Be sure to read through these limitations:

Lock screen controls will not appear in the following scenarios:

  • A non-Sonos AirPlay capable device is present.
    • To allow lock screen controls to appear when using Sonos, disable the AirPlay feature on all non-Sonos AirPlay endpoints such as Apple TVs or Apple AirPort base stations.
  • Another app on the iOS device is playing music or video.
  • While the iOS device is connected to a non-Sonos Bluetooth audio device.
  • VoiceOver is enabled.
  • Headphones are connected to the iOS device.

The limitations above do not apply when playing audio to Sonos using an app that supports Sonos direct control or when playing AirPlay audio directly to Sonos. We recommend using either of these options if the above limitations are preventing lock screen controls from appearing on your iOS device.

https://support.sonos.com/s/article/3381?language=en_US

Unfortunately none of these things are the case. Is there a different kind of hard reset that I can do?

Userlevel 7

Are you sure you don’t have any other AirPlay compatible devices like an Apple TV, Roku, or AirPlay-enabled TV?

I don’t have any airplay devices connected, and I turned off Automatically airplay to TVs.

I do have airpods, but those are bluetooth not airplay, and obviously i’m not trying to play music on both of those at the same time.

Is there anything else I should check on @GuitarSuperstar 

Userlevel 7

An AirPlay device doesn’t have to be connected for it to affect Lock Screen controls.

What model TV do you have? What external media devices do you use?

I use a samsung TV, but it has never been connected to my phone. I have an appleTV, but have never used airplay from my phone with it. Is there a way to block the appleTV from connecting entirely to fix the issue? @GuitarSuperstar 

Userlevel 7

In the Apple TV settings, go to “AirPlay and HomeKit” and turn AirPlay off.

If the Samsung TV is AirPlay-enabled, disable the AirPlay setting in the TV settings.

Reboot the Sonos app after changing these settings.

Thanks so much @GuitarSuperstar – that worked. Appreciate the clarification on the devices not needing to be connected to interfere.

Badge +3

Google has lead me here for help with the same issue.

 

So I have an Apple TV which sometimes I want to use AirPlay on, does this mean there’s no way to get my Sonos Lock Screen controls working and still have AirPlay available on the TV??

 

I assume this is an Apple issue and nothing Sonos can do about it? 🙁

Userlevel 7

Google has lead me here for help with the same issue.

 

So I have an Apple TV which sometimes I want to use AirPlay on, does this mean there’s no way to get my Sonos Lock Screen controls working and still have AirPlay available on the TV??

 

I assume this is an Apple issue and nothing Sonos can do about it? 🙁

If you have AirPlay enabled on any non-Sonos AirPlay capable device, then Sonos Lock Screen controls will not work.

Badge +3

Thanks @GuitarSuperstar 

That’s rubbish though.

Reply