Answered

How do I stop popup notification in the corner of Mac screen every time song changes? :)


Userlevel 1
How do I stop popup notification in the corner of Mac screen every time song changes? 🙂
icon

Best answer by Ken_Griffiths 22 June 2016, 14:19

I'm not a MAC user, but I read that it's a setting in the notification centre, if that means anything to you?
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

19 replies

I'm not a MAC user, but I read that it's a setting in the notification centre, if that means anything to you?
Userlevel 6
Badge +3
How do I stop popup notification in the corner of Mac screen every time song changes? :)
Hi Tommy,

Ken, is spot on. Mac OS -> System Preferences -> Notifications. Scroll down to Sonos and click on "None".
Let us know how it goes.
Userlevel 1
"Problem" solved. Thanks for fast reply guys!:D
Thank you! Sometimes I think everything is designed to annoy me in new and different ways.
Userlevel 5
Badge +3
Yeah...turned that off immediately too! IMO, a case of TMI.
Yuck. No thanks.
I tried this but I still get the notifiations in the top right corner whenever it starts playing a new song.
Userlevel 5
Badge +3
Select NONE
Same problem.
However don't see Sonos in notifications.....Difficult to disable.
Same problem.
However don't see Sonos in notifications.....Difficult to disable.



The problem was GROWL. It had Sonos notifications. Problem SOLVED
Really needs to be part of the SONOS application preferences; and not buried only in System Preferences.
Userlevel 5
Badge +3
Some apps do allow for turning on/off. But in general this is a part of Apple's design to control Notification preferences in the system settings on a Mac or iOS device.
How do I stop popup notification in the corner of Mac screen every time song changes? :)

Thank you, yes... that worked.

thank you for showing screen shots. i couldn't' find the "none"! it's super annoying when one needs the whole screen to have sonos pop up every couple minutes. Finally i hope i've found freedom from a sonos annoyance!
I cleared all the notification options for Sonos in the Systems dialog (Mac 10.12.6) , and even closed + reopened Sonos, but I'm still getting the (extremely annoying!) notifications with each new song.
Admit that have not yet tried rebooting the laptop, but barring that, there seems to be a bug. Help?
jackieros,

You may want to ask Apple about the issue, since it's an Apple feature that you want to turn off.
I cleared all the notification options for Sonos in the Systems dialog (Mac 10.12.6) , and even closed + reopened Sonos, but I'm still getting the (extremely annoying!) notifications with each new song.
Admit that have not yet tried rebooting the laptop, but barring that, there seems to be a bug. Help?


Did you also select the Alert Style and set it to 'none'.. ? Also Check it’s not another app you may have installed that provides such notifications.
Thanks @Ken_Griffiths! Totally missed that at the top. Had just quickly cleared all the check boxes assuming that clearing all of them would avoid all notifications. Problem solved 🙂

@sonos - Given the desperate requests from so many customers to figure out how to turn off these notifications, you might want to consider adding the setting to the app preferences & making it easier for people to find and turn off. You might even consider not having them on by default or making it an option for users to select on initial set up...
screenshot super helpful - THANK YOU! Phew finally they are gone, so annoying! ??