Drop outs finally solved...at last!!!!!

  • 29 December 2016
  • 2 replies
  • 368 views

After what must be close to 2 years I have finally solved drop outs on my Sonos system!
I have quite a 'rambling' property and my system originally consisted of 3 bridges, a soundbar, a sub, 2 x play 1s and a play 5. I recently replaced one of the bridges with a boost in the hope that this would solve my drop out problems on Spotify, Apple Music and Amazon music - my music library on my iMac was slightly more reliable but nowhere near even 70% reliability. Curiously my play bar and sub and play 1s worked perfectly with my tv and sky.
However, my typical music listening experience would be Spotify or Apple or Amazon music services playing for a few seconds then cutting out, restarting, then stuttering and finally cutting out altogether.
I had spoken to two or three Helpdesk folks over the past 1-2 years and never got the problem fully solved. And I'd tried many other fixes in the meantime.
Most recently I was promised a call back - which never came - so I decided to try to fix the problem once and for all.
So here's what finally worked for me: it wasn't my router proximity to the boost, it wasn't the channels selected, it wasn't removing and re-adding the music services, it wasn't unplugging / restarting, it wasn't anything to do with my house dect phone or my microwave oven or any of the other solutions I'd seen posted - IT WAS ASSIGNING PERMANENT IP ADDRESSES TO EACH AND EVERY SONOS COMPONENT - problem solved!!!!! At last!!! After years!!!!
I have a BT Home Hub 4 - I accessed advanced settings and found 'devices' then I could see that two devices were not on the appropriate LAN - once I'd moved them (I disconnected one from from an Ethernet cable - Helpdesk advice I'd previously been given!), I then clicked on each device and made the allocated IP address permanent - I then saw an instruction which told me the device would have to restart before the change would take effect - this was done automatically and I just worked my way through each device until all were done.
My system has been working perfectly ever since.
Why Sonos Helpdesk folks couldn't have told me about this before I really don't know.
I was about one day away from selling my whole system - this solution stopped me doing that.
If, like me, you've tried what you think is everything and live in a permanent state of frustration and annoyance with your Sonos kit (but you love it when it does work) - I really hope this post helps.
I can now enjoy my Sonos system and now I don't spend my time regretting spending £000's...and my wife is much happier too!
Good luck
Keith

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Refreshing the entire network and reserving IP addresses for Sonos units is so ubiquitous a recommendation around here, I have it saved off in a Notepad file so I can easily cut-and-paste. Sorry that you never encountered it before, but it certainly is standard operational procedure for people helping out here.

Why Sonos phone support does not suggest it is another question entirely. Sonos support is top notch, but sometimes the users actually know better tricks of the trade that support may not have in their database.

Anyway, glad you got it working, not so pleased it took so long. You certainly have patience.
Hi
Thanks for the reply. I'm sure that is the case - but sadly not my experience. I did post my problem at least once, I'm sure, and I was asked to submit a diagnostic report. Then I received a few calls but unfortunately the all pervading solution wasn't made available to me.
Anyway, better late than never!
Loving my Sonos system now - and believe me it still feels a bit odd!