Crossfade option from Spotify. Not available through Sonos?

  • 27 December 2013
  • 8 replies
  • 1079 views

On Spotify, I can have a 'Crossfade' of up to 12 seconds. I hear the music blend in together with this while listening through the Spotify app. However this does not seem to carry over when listening to the same music off of my Spotify app through my Sonos players. Is there something I am doing wrong? I searched through the Sonos configuration and menu and do not see any way to do this. It is in the Spotify app though. Any thoughts?

8 replies

Userlevel 7
Badge +25
Hello Peter,

The Sonos software has a Crossfade feature you'll need to turn on, which will fade all of the tracks your listening to. This FAQ has directions for turning on the various play modes in Sonos.

Cheers.
I have Sonos:1 and Sonos:3 which I use with Spotify. Each time I am playing to my Sonos systtem I have to manually turn Crossfade on. Is there any way to set it and forget it? It's kind of annoying to have to load the Sonos app on my phone when I'm playing Spotify to my Sonos from my laptop.
So what is the solution ? Still can’t crossfade Spotify playlist in sonos app
Crossfade is no longer in the app. Whats happening??
Cross fade is still in my app by pressing the 3 dots next to a song. But even with that on I can’t get it to do it playing a Spotify playlist.
Before it was set it and forget it. Thanks, I was able to find it and set it in the app on Android while playing the Spotify that I initiated on my PC. I then started a playlist and it did crossfade my playlist songs.

I have a Sonos 3.
Fever 905, what do you mean “playing the Spotify you initiated on my pc” ? I don’t use Spotify on a computer, only on my iPhone Spotify app. I wonder if yours is working because you have a pc and android? Just can’t figure this darn thing out. What settings do you have set on your Spotify account ? Do you have crossfade and gapless playback on? Or just crossfade?
I have crossfade on but I notice certain albums play gapless. I do not know of a setting for that, I thought it was automatic.

If you turn the crossfade on using the Sonos app while playing spotify it's supposed to keep that setting until turn off your units. I never turn mine off they are always connected. My spotify is the premium family account. Is yours a paid spotify or a free one? That's the only thing I can think of.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings