Question

Controller Menus Grayed Out.

  • 25 December 2013
  • 28 replies
  • 24192 views

Using Windows 8. Controller on my computer. Under "Manage" drop-down, "Music Library Settings" is grayed out. I can't add any songs because I don't have access to the menu!!!!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

28 replies

Badge +3
When the menu options are greyed-out like that, it usually means one of two things.  Either the Controller isn't able to see the players, or one or more of the players requires an update.

If you look on the lefthand side of the screen, under the rooms menu, are you seeing all your players?  If not, make sure that nothing on the PC could be blocking the connection, such as a firewall.

If you are seeing the Players, one or more of them might require an update.  If this is the case, you'll see an Update Now icon in the menu on the righthand side of the Controller.
Worked a treat thanks, pity Sonos has to stop working just to force an update - sometimes if it aint broke dont fix it - but thanks again.
I have his problem now. Even check for updates is greyed out. It is the same on both controllers (Mac and Windows PC) I have just updated the windows one now, still the same? Just bought a play one and I can't add it to the system.
Badge
same here says it finds controler then cant find system and cant update all greyed out works great on my phone have uninstalled turned off firewall nothing reset controller reset bridge still nothing
I'm sorted. Called Sonos support they were really good!
I was in demo mode, no idea how? They sent me a link to fix. There was also a bug so I had to factory reset the devices (connect, play 1's and 5). All my playlist are in Spotify so no problem. All good again!
Badge
ok guys had to phone and got the fix not sure why its not on here but i changed to windows 10 a while back and when you make a new connection by default it sets in to public .it need to reset to private ..so here is what you need to do press on networks bottom of right screen then press network settings then advanced options then turn on find devices and content ..job done ...the guy on the phone was great but one think if they know a lot of people will be changing to windows 10 why is this not on a email or easer to find ..but any all working great love my sonos
if they know a lot of people will be changing to windows 10 why is this not on a email or easer to find
https://sonos.custhelp.com/app/answers/detail/a_id/823/~/configuring-windows-firewall-to-work-with-sonos#Windows10
I have his problem now. Everything inside "Manage" Menu is greyed out. It is the same on every controller (Ipad, Windows PC Win7 and Android phone) I have 2 Play1 which I can use, but Play5 that I have, is not recognisized by the controller and I can't use it. I have installed controller once again, no help. Ccan't do anything more....
That sounds like you don't have the same version on the devices as you have on the controllers, go to settings - about my Sonos system and check what versions everything is running.
OK, It seems to me, that PC controller's version is 6.0 and two Play1s and connect are version 5.5. Play5 is not recognised by controller, so no information is shown. What to do next?

SONOS CONTROLLER FOR PC
Version: 6.0
Build: 31322220
Sonos ID: 109811457


Associated ZP: 192.168.1.101
---------------------------------
PLAY:1: Keittio
Serial Number: B8-E9-37-BA-1E-DE:0
Version: 5.5 (build 29693090)
Hardware Version: 1.8.3.7-2
IP Address: 192.168.1.103
WM: 0
OTP:
---------------------------------
PLAY:1: Makuuhuone
Serial Number: B8-E9-37-8B-E9-3C:B
Version: 5.5 (build 29693090)
Hardware Version: 1.8.3.7-2
IP Address: 192.168.1.104
WM: 0
OTP:
---------------------------------
CONNECT: olohuone
Serial Number: 00-0E-58-27-A8-10:5
Version: 5.5 (build 29693090)
Hardware Version: 1.1.16.4-2
IP Address: 192.168.1.101
WM: 0
r8: 16.0-7
Go into settings and check for updates. It should download to each unit and update. Try rebooting the Play:5 to get it recognized. If it doesn't show, temporarilyconnect it to the router with an Ethernet cable and then try to update. After it does, you can unplug and use it wirelessly.
Run the update from the app and allow the devices to update to 6.0. I'm not at home right now do I can't tell you exactly where to look but it's usually pretty obvious.
I am not aware how to update my speakers and Sonos connect. Like I said earlier, everything inside Manage-menu is gray, so I am not able to check for updates or run to update...
I am not aware how to update my speakers and Sonos connect. Like I said earlier, everything inside Manage-menu is gray, so I am not able to check for updates or run to update...

It's under the settings menu according to jgatie, you can obviously get to that as you posted the "about" details, which is also under Settings.
Settings->Online Updates to be exact. At least on the mobiles it is.
Badge
ok guys had to phone and got the fix not sure why its not on here but i changed to windows 10 a while back and when you make a new connection by default it sets in to public .it need to reset to private ..so here is what you need to do press on networks bottom of right screen then press network settings then advanced options then turn on find devices and content ..job done ...the guy on the phone was great but one think if they know a lot of people will be changing to windows 10 why is this not on a email or easer to find ..but any all working great love my sonos

and now not working again every thing connects apart from pc and this time it is still on a private network if i had hair i would have pulled it out by now just dont get why menus are greyed out no help ..so will just have to Waite for phone call again
Badge
update after trying every thing from system recovery to install uninstall just about to give up phoned sonos they have upgraded fault to level 2 so still waiting but i have found if i turn the windows firewall off it works ..not that i can do that all the time but at least i know its the firewall ..its allowed on the firewall if i remove it and run controller it will ask to re add it but it will still not let sonos connect just dont get it
Badge
Dear Mr Sheriff,

then there is a conflict in your Windows firewall that goes back to when AVG was installed. There are 2 options to fix that issue.

First option: http://windows.microsoft.com/en-us/windows7/restore-windows-firewall-settings
2nd option: through the command prompt:

Type:
netsh firewall reset
netsh int ipv reset

and restart your windows machine. yes i have my sonos working again
I am not aware how to update my speakers and Sonos connect. Like I said earlier, everything inside Manage-menu is gray, so I am not able to check for updates or run to update...

It's under the settings menu according to jgatie, you can obviously get to that as you posted the "about" details, which is also under Settings.


I am not sure it is that obvious that we can get to that. For me, at least "about" is under the main "Sonos" menu and the two "settings" menus ("Music Library Settings" and "Service Settings") are both under the "Manage" menu...which all the options are greyed out.

I can get to "about" but I cannot get to "settings".
I can get to "about" but I cannot get to "settings".
What does 'About' say in terms of software versions, for the controller and for the players? And what's the operating system on your computer?
I can get to "about" but I cannot get to "settings".
What does 'About' say in terms of software versions, for the controller and for the players? And what's the operating system on your computer?


Thanks for the quick reply!

It's long but "about" says:

Associated ZP: 192.168.1.74
---------------------------------
PLAY:3: Bedroom
Serial Number: 00-0E-58-70-21-CE:E
Version: 6.4.2 (build 331533210)
Hardware Version: 1.8.1.2-1
IP Address: 192.168.1.74
WM: 0
OTP:
---------------------------------
BRIDGE: BRIDGE
Serial Number: 00-0E-58-48-CD-C6:2
Version: 6.4 (build 331532141)
Hardware Version: 1.5.0.0-1
IP Address: 192.168.1.67
WM: 0
---------------------------------
PLAY:3: Kitchen
Serial Number: 00-0E-58-70-11-BC:E
Version: 6.4.2 (build 331533210)
Hardware Version: 1.8.1.2-1
IP Address: 192.168.1.69
WM: 0
OTP:
---------------------------------
PLAY:3: Nursery
Serial Number: 00-0E-58-70-15-66:0
Version: 6.4.2 (build 331533210)
Hardware Version: 1.8.1.2-1
IP Address: 192.168.1.71
WM: 0
OTP:

I'm going to make a guess that I need to update my bridge software?
I'm going to make a guess that I need to update my bridge software?
No. The BRIDGE is up to date. What version is the controller? To be honest, I imagine your problem is in fact that your operating system is no longer fully supported. See here.
I'm going to make a guess that I need to update my bridge software?
No. The BRIDGE is up to date. What version is the controller? To be honest, I imagine your problem is in fact that your operating system is no longer fully supported. See here.


Oh, man...I feel super-dumb. What is the "controller"? The app?
I'm going to make a guess that I need to update my bridge software?
No. The BRIDGE is up to date. What version is the controller? To be honest, I imagine your problem is in fact that your operating system is no longer fully supported. See here.


Okay...I am updating my OS. I hope that helps. Thanks!
What is the "controller"? The app?
Yes, the Sonos controller app. The version is listed at the top of the About My Sonos System pane.