Answered

Continue playing when receiving phonecall


Badge
We use Sonos at work. When I receive a call that goes through my iPhone and MacBook, all the speakers on our system turn down (or pause.... not exactly sure which.) How do I set Sonos to NOT pause/turn down when a call comes through? I can't seem to find the setting within Sonos and all the similar chats I've read are actually requesting the opposite! ¯\_(ツ)_/¯
icon

Best answer by echarterswork 4 May 2018, 22:10

Thanks, Chris and AjTrek1.
We primarily use Spotify to stream music, and everything is controlled through my computer. I turned off FaceTime on my computer, and that seems to have stopped the system from pausing/turning-down. Perhaps the problem was just FaceTime and that's the only option.....
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7
Hi echarterswork

I can't recall that happening in fact (to my memory) I have turn my Sonos down when I get a call on my iPhone. The only way I can see that happening as you say (and this is a long shot) is if you have a Amazon Dot or Echo linked to your Sonos and you in turn have your iPhone linked to the Dot or Echo via BT:? As I said it a long shot guess :8

In any event I'm going to test your anomally over the weekend:)

Cheers!
Userlevel 7
Badge +22
Yea I'm unaware of it doing that in past. Is the source of the music actually the phone (vs. using an online source).

You may want to go into your iphone settings ... Sonos ...and turn off the lock screen controls (they could be doing something).
Badge
Thanks, Chris and AjTrek1.
We primarily use Spotify to stream music, and everything is controlled through my computer. I turned off FaceTime on my computer, and that seems to have stopped the system from pausing/turning-down. Perhaps the problem was just FaceTime and that's the only option.....
Userlevel 7
Badge +22
Very strange
Userlevel 7
Very strange

Agreed :8 Let us know if the issue reoccurs after a while.

Cheers!
This is a Mac/iPhone & Spotify feature rather than a Sonos issue. iPhone has a feature to receive "Calls on Other Devices". When that device is your mac which you are playing Spotify on the mac will pause/silence Spotify and thus pause your music on the Sonos.