Cannot connect/server can't be found


Userlevel 1
same problem as most with the inability to connect to my library on macbook pro. I've sent a diagnostic#4659600. pls advice on how to resolve issue

6 replies

Userlevel 4
Badge +4
Hi,

Make sure that 'Put hard disks to sleep when possible' is unticked for Battery or Power Adapter (or both) and Computer Sleep is set to never in the Power Adapter to prevent the computer (and the connection to SONOS) itself going to sleep when it's plugged in (the display will still turn off.)
Userlevel 3
Badge +3
Hey Clive, any update on your progress? Let us know if you're still having this problem.
Hi,

I had the same problem for months...finally figured it out....

Make sure you don't just have admin rights, but really were created as "administrator" not just as a "standard" user with admin rights box checked to "on".
Solution: create a new user:

.
Use this admin-user when asked to unlock the music folder!

Hopefully this works for you too.
I'm having the same problem. I've started getting a message that server not available. I use an administrative account routinely.
OK - it's retarded that nobody in Sonos Support worked this out themselves, but here is the solution for Mac!!!

Simply edit your computer name to be less than 15 characters and make sure it does not contain any special characters such as apostrophes. If you do not do this, OS X assigns you a default NetBIOS name for Windows networking, which does not match your computer name. The Sonos application expects to connect to your default computer name over Windows networking. Note this is clearly a ridiculous bug. Sonos should be trying to connect to the NetBIOS name that OS X is actually using, not the default computer name.

To edit your computer name so that OS X can use the same name for Windows networking, go to
System Preferences... -> Sharing -> Edit...

Final note to developer dummies at Sonos. You can retrieve the NetBIOS name actually being used with the following command

> defaults read /Library/Preferences/SystemConfiguration/com.apple.smb.server NetBIOSName
Userlevel 3
Badge +3
D Williams wrote:

OK - it's retarded that nobody in Sonos Support worked this out themselves, but here is the solution for Mac!!!

Simply edit your computer name to be less than 15 characters and make sure it does not contain any special characters such as apostrophes. If you do not do this, OS X assigns you a default NetBIOS name for Windows networking, which does not match your computer name. The Sonos application expects to connect to your default computer name over Windows networking. Note this is clearly a ridiculous bug. Sonos should be trying to connect to the NetBIOS name that OS X is actually using, not the default computer name.

To edit your computer name so that OS X can use the same name for Windows networking, go to
System Preferences... -> Sharing -> Edit...

Final note to developer dummies at Sonos. You can retrieve the NetBIOS name actually being used with the following command

> defaults read /Library/Preferences/SystemConfiguration/com.apple.smb.server NetBIOSName


Thanks for posting, we do have an article for this: https://sonos.custhelp.com/app/answers/detail/a_id/2068/kw/mac%20sharing

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings