Question

Can I fix a new, bad audio Line-In delay from Connect & speakers?

  • 23 September 2017
  • 7 replies
  • 853 views

I have a Sonos Connect and 3 Sonos wireless speakers. I primarily use this as sound for my TV and DVD, which are wired to the Connect with the RCA connectors in the back and are shown in the Apt as "Line-In." I was advised when I set this up, about 3 years ago, that there might be a slight delay in the sound witht the direct Line-In, but there never was. After an "update" a few months ago, the entire system was not working and I let it be. Now, with some help from support I've got everything back up and working well, except - I guess after the update because everything else is exactly the same - there now is almost a 2 second(!) delay in the sound, which makes it impossible to watch a DVD or TV. Since we got the Sonos, my wife and I have watched a lot of DVDs with the sound just coming from the Sonos speakers, and I've had a lot of friends over to watch football games (including 2 or 3 big Superbowl parties) using the Sonos and it always worked so well. Now, well right now it's a useless piece of electronics. Does anyone have any idea how to fix this? As I said, it has always worked great and everything is the same - except for the update - but now the delay is LONG! BTW, if there was any delay before, it was so short that we nor any of our guests ever noticed it.
Thanks

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 4
Badge +3
I presume you've checked through the TV menus just in case there's been a software or firmware update that has affected the audio output and added a delay there.

You'll also have powered off the entire Sonos system so it has rebooted from cold?

Once those two things are done then next you can have a look at Audio Compression for Line-In within the Sonos menus.

Line-In is an analogue signal, so the first thing required is to convert it to digital for retransmission. This adds a small delay for the processing time. However, the raw digitized signal still takes up a lot of bandwidth - 1400kbps. Compare that to good quality mp3 at 192kbps and you start to see there's a big difference.

As the name suggests, Audio Compression reduces the data size to a more manageable size. It ends up at approx 320kbps. This is far more tolerant of wireless interference as there's time to retransmit any lost packets. However, the processing adds another delay to the sound.

You can switch Audio Compression off. Just be aware that the system will be transmitting the raw high-bandwidth data stream. If your wireless network gets interference then the Sonos will drop out during reconnects.
LUCID AV - THANK YOU! That fixed it, perfectly. I appreciate it so much that you took the time to reply. I used to be really good - with IBM XT, 260 and 360s, but now there are so many settings, and such depth I NEVER would have found this. I really can't express my gratitude. Guess that's what makes a "community." I can't do anything to thank you personally, but there will be a few random acts of kindness in your name this week. You've made my world a better place - I'll do the same. Thanks again
Userlevel 4
Badge +3
I have to say that this is one of the most genuine and heartfelt thank you replies I have ever received. You've given me a lovely warm fuzzy feeling, so thank you too. I'm very happy that you plan to put a smile on other people's faces 😃
hi there, i have a similar problem. My TV has only digital out, so i use a DAC to go from tv digital out to the connect's analog line in. Do you think it is better to use the digital out on the connect or keep going with the analog (my ampli has both so no problem on that side. Thanks 🙂
Userlevel 4
Badge +3
The digital connections are Outs on a Sonos Connect. "Out" is similar to an Exit. It's for signal leaving the Connect to go somewhere else such as an amplifier.

If a Connect had Coax or Optical In then you would be able to hook up the TV audio without so much (if any) digitisation delay. "Ins" are like an Entrance. It's for signal arriving at a device from somewhere else.

The Connect doesn't have digital inputs.
How would one go about "switching audio compression off"? I looked under the sonos preferences menu and did not see that option. Thank You!
Userlevel 7
Badge +20
How would one go about "switching audio compression off"? I looked under the sonos preferences menu and did not see that option. Thank You!
Since 9.2 this needs to be set using a mobile controller app, not a desktop app:
More | Settings | Advanced Settings | Audio Compression -> 'Compressed'