Answered

Battery drain on iPad

  • 20 June 2022
  • 4 replies
  • 70 views

Userlevel 1
Badge +1

Sonos app seems to be draining a lot of battery while my iPad is idling. It says 2 min on screen but 23h 19m background. Weird thing is I disabled the background app refresh for Sonos specifically.

this has both happened while the iPad was at home at same Wi-Fi as Sonos and away on another Wi-Fi.

 

I have submitted a diagnostic at number 412593457.

 

I need my Sonos app to not kill the battery while idling.

 

icon

Best answer by Corry P 24 June 2022, 11:36

View original

4 replies

I’ll be interested to see what Sonos sees in that diagnostic. I use my iPad all the time to control Sonos, but don’t see any significant drain at all, unless I’m using AirPlay 2 to generate a signal that the Sonos is reading….

Userlevel 1
Badge

Did you close the sonos app fully when not in use?

Userlevel 7
Badge +18

Hi @Peheje 

Thanks for your post!

I presume this is related to the difficulty your Boost is having in communicating with the rest of your Sonos system - frankly, I’m surprised you (and the speakers) aren’t reporting audio interruptions. As the signal strengths between the Boost and the other devices is strong, I’m pretty certain that the cause of the problem (and of other problems you’re likely having with your Sonos system) is interference. 

Commonly, this is due to the Boost being too close to the router - they should be at least 1m apart. The same goes for any other smart-home hub you have connected to the router - all WiFi devices like to have 1m space from all other WiFi devices (or other devices that use 2.4GHz radio).

If the router and Boost are not close, our Reducing wireless interference help page should assist.

What I think is happening is that the Boost is losing connections to rooms, then when they come back, it informs the app. This keeps the app more active than usual.

At time of writing, your Port was offline and it was also missing from the diagnostics - is it powered-off?

I hope this helps.

Edit: you may also want to reboot your iPad.

Userlevel 1
Badge +1

Hi Corry thanks for taking a look. There’s a lot of interference here where I am, I think that’s just how it is living in an apartment. 
 

I will try to separate the router and the boost even more. Even though I disabled the 2.4ghz band of my router so I would assume it shouldn’t matter?
 

I disabled the Lock Screen controls and the hardware volume control on the iPad app, haven’t had the issue since. 
 

there must be something different with the iOS app and the android app as I haven’t had this issue on android

Reply