Question

App connection issue

  • 25 July 2020
  • 7 replies
  • 119 views

So I own 4 play:1 for a couple of years now and this always happened. I’m trying to figure out if it’s fixable because I’m considering the addition of the Sonos Move to the set-up. 

Problem is simple : I get the message that the app cannot connect to the sonos product at any random moment. I get the message when the music is actually playing and let’s say I want to change the song, or just pause it for some reason. I thought it was my phone that was getting old, but then I still get the message after an upgrade to an iPhone 11. However, I do not encounter that issue with my wife’s Samsung Galaxy S10 (is there a known issue with IOS?). That brings me to think that it is not an network/wifi problem.

This problem prevented me to get the Beam and before looking elsewhere for a Sonos Move equivalant, I figured I could ask here.

I’m one of those who actually like the Sonos App and the combination of all my streaming services. Also, I don’t mind the price tag of the Move, but at this price tag, it just needs to work.

Has anyone had this issue ?


7 replies

Userlevel 4
Badge +12

Hi @spaquin, thanks for your interest and welcome to the community! Let’s check your system first and help you out but you can always add up to 32 Sonos devices per household. Since you said it’s only happening on iOS devices, can you please submit a diagnostic from the device you’re having trouble with? Make sure to submit it after getting the problem and also it would be best to submit it as well on the working device. Reply to us with the confirmation number. Thanks! 

Hi @Krishma M 

Thank you for your quick reply.
This morning it hapened again. More specifically, I started the music on all my 4 speakers and immediatly after I wanted to mute one of them. The app could just not connect to my speakers. 
The only solution I found in time when it happens is to restart my phone. 
I did as you suggested in your reply and submitted a diagnostic. Oddly though, my attempt to do so was not working until I re-booted my phone. I suppose the whole connection between the app and the speaker becomes unreliable when it happens.

The diagnostic number is 680507704.

i did sent the diagnostic report a second time right after when everything was working : 955957071.

I hope it helps in fixing the issue.

Thanks

 

Userlevel 4
Badge +12

Hi @spaquin, thanks for the diagnostics. If it’s okay now after reboot, observe the connection and please let us know if you'll encounter it again. Reply to us with the model of your Sagemcom router for further checking on our end. Just let us know, we’re here to help. Thanks! 

Hello @Krishma M ,

My modem was provided to me by the internet supplier in June 2019 (so pretty new aslo). But again, if the problem comes from the internet connection, it would not work on my wifés Samsumg device.

And to be honest rebooting my iPhone everytime the connection fails on me is not what I call a solution. Especially when I try to skip a song with guests in the house.

So my initial question remains: is there a known connection issue between the Sonos App and IOS ?

 

Thanks,

 

SP

Userlevel 4
Badge +12

Hi @spaquin, thanks for your response. I understand that it’s fine with your wife’s phone and it should perfectly work with your iPhone as well. Yes, it’s not okay to reboot your phone every now and then just to fix it. It would be best if you can give the model of your modem and router so we can check it on our end if there’s a known issue why you’re experiencing that. 

It is our pleasure. We and the community are always here to help.

Hello @Krishma M 

I am now using a Sagemcom Fast 5566. I really hopes ot helps.

Thanks

SP

Userlevel 4
Badge +12

Hi @spaquin, thanks again. I found no issues with that but have you tried rebooting your router? Like disconnect it from power for 5 to 10 seconds then connect it back to power. If it will still be the same, do you have other devices that you can try, like another iOS if possible? If not, remove the Sonos app from your phone and reinstall it again. Check if there’s an available software update on your phone as well. 

If it’s all set and tried, try to change your router’s wireless channel from channel 11 to 1/6 if it will make any difference, and lastly hardwire one speaker to your router using an ethernet cable. 

These will be my best suggestions for your case. Keep us posted. We and the community are always here to help.

Reply