Android Widget Dropping connection?

  • 28 November 2017
  • 7 replies
  • 356 views

Userlevel 7
Badge +21
If I have one of my Android tablets' Sonos widget connected to a player and I remove power from that player the widget drops the connection to my Sonos setup. Powering the component back on does not restore the connection to the Sonos system.

Hadn't noticed this until 8.1 or so but it may have been an issue earlier.

How do I get the widget to reconnect to the Sonos system without having to reboot the tablet?

7 replies

Userlevel 7
Badge +19
Hey there, Stanley_4. Thanks for reaching out. Does the widget reconnect if you relaunch the Sonos app after the player goes back to a solid white LED? You shouldn't have to reboot the tablet to re-establish a connection. Once the player comes back on the network you may need to relaunch the Sonos app in order to be able to control it.

Let us know what happens. Thanks again.
Userlevel 7
Badge +21
Well tonight the widget is acting entirely differently, it continues to show the powered off room for a few minutes then switches to a "room not found, pick a different room" message. You can pick another room or wait for the Sonos Play to power back up and pick it.

I have a Boost and the original problem device is connected via wireless only so it's presence shouldn't have been key to the system's operation in any case.

I'll write it off as a glitch for now and if I see it again I'll fire off a diagnostic to see if that can capture whatever it is acting strange.
Userlevel 7
Badge +19
Sounds like a plan. Keep us in the loop, Stanley_4.
Userlevel 7
Badge +21
Another widget issue, showing: "Not connected to Sonos tap for more info."

Same issue on my Tab-A and S-2 tablets, the S-3 is working as expected.

A tap on the widget opens the Sonos app but doesn't seem to reconnect the widget.

No other option is available from the widgets on the Tab-A and S-2 tablets while the S-3 shows the connected Player and audio options as well as the change room option.

Connected and disconnected the WiFi, put the tablets to sleep (powered and unpowered) as well as rebooting them and the widget stays disconnected.

Diagnostic # 8215490

After multiple reboots the Tab-A is now connected, the S-2 is not.

Moved the S-2 widget to the trash. Installed new Widget, it asked "what room" and is now working as expected.
Userlevel 7
Badge +21
Did you get my diagnostic? Did it show anything?
Same here: "Not connected to Sonos tap for more info." on a Samsung Galaxy S4.
Is Sonos staff working on this?
Please, fix it asap.
Userlevel 2
...same here...Galaxy S7, Galaxy S2 and Galaxy Tab2
Seems SONOS doesn't care 😞

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings