Question

Android "hide notification" button not working

  • 15 February 2020
  • 9 replies
  • 249 views

Badge

I can't dismiss the Sonos android notification anymore. 


9 replies

Userlevel 3
Badge +10

@bobend 

 

Thank you for reaching to the Sonos community.

 

Since you are having issues with dismissing the Sonos notification, Do you have a section in your device that lists all the apps you have installed? I would like for you to search for the Sonos app and see if “Allow Notifications” is turned on.  If so toggle the switch to view notifications on/off/on. That may clear the memory to allow you to dismiss the notification.

Userlevel 6
Badge +4

Thanks for the question and response.  I’m not wanting to upgrade beyond 10.4 at the moment (probably forever) and was getting update notifications on at least one device.  I’ll keep an eye on this.

Badge

@bobend

 

Thank you for reaching to the Sonos community.

 

Since you are having issues with dismissing the Sonos notification, Do you have a section in your device that lists all the apps you have installed? I would like for you to search for the Sonos app and see if “Allow Notifications” is turned on.  If so toggle the switch to view notifications on/off/on. That may clear the memory to allow you to dismiss the notification.

Hi, I do not want to hide the notification when music is playing, but when I stop playing music I would like to dismiss the notification. It worked before but stopped working some time ago. 

Userlevel 6
Badge +4

Yes… “It worked before but stopped working some time ago.” 

Today when accessing my phone controller I was dismayed to see that I had an update notification for the controller app.

I can absolutely confirm that my phone apps are globally set to not auto-update and within my ‘Applications’ setting for the SONOS app (Android, Settings, Application Manager, Sonos) the ‘Notifications’ are ‘Blocked’.  How come then I received a notification of an update today?

I suggest a bug.

Hi all. I know this post is a couple of months old, but I’m having the same issue as the original poster.  The music control notification (play/pause/music info/etc) is NOT clearable after playback is stopped.  It’s not something I would want to disable permanently, since controlling music that way is important. But the issue is that the notification is impossible to clear afterwards. The “Hide Notification” prompt is nonfunctional, and the notification can’t be swiped away.

I’ve already tried disabling notifications and re-enabling them. This will clear the notification, obviously, but the problem happens every time regardless of system settings.  I’m on a Huawei P30 Pro on Android 10.

 

Any ideas? Thanks in advance.

Userlevel 4
Badge +12

Hi @clockworkmagus. Thanks for posting. 

Have you tried uninstalling the application? The controls are present on your notifications when the process is being recognized as active. 

Try re-installing the app to see if that resolves the problem, If not, would you be able to let me know if the controls go away when you force close the app?

I have the same issue, OnePlus 7 Pro... I can confirm once I force close the app, the notification window goes away, but just reiterating that is unacceptable and I want to hide that "control" window once I stop playing music.

Same problem here. (Sonos S1, Pixel 3, Android 10). Workaround for me was simply to clear the queue in the Sonos app, which immediately cleared the notification without further intervention.
… But I agree with others, this is a bug which should be resolved. For *every* other application, I can just swipe notifications away, so annoying enough that instead I have to tap “Hide notification”. Even worse that “Hide notification”  doesn’t work (at least sometimes) because it’s greyed out.

Userlevel 3
Badge +6

Hi @Phil Bee and @mrthomas33.

Welcome to the Sonos community and thanks for reaching out.

I would like you guys to try to un-install and re-install the Sonos app as recommended by @Adam S

I would also like to recommend turning off the notification for Sonos on the settings of your mobile phone.

Mobile phone settings » apps & notifications.

I hope this helps.

Please let me know if you have further questions or concerns.

Thanks,

Reply