Android controller dies in background since 9.2


Userlevel 1
Badge
Since upgrading to 9.2 the Sonos app doesn't stay running in the background anymore. Up to 9.2 it has always been there in the notification bar and on the lockscreen, now I have to manually start the app every time I need to do anything with it. It's also a pain in the ass every morning when I want to shut the alarm off. Very frustrating. Anyone knows what has happened?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

21 replies

There's a known issue related to the widget. As far as I know a fix is already in the works.
Userlevel 1
Badge
There's a known issue related to the widget. As far as I know a fix is already in the works.

Hmmm... I'm not talking about the widget (never used it), but maybe this fix you're referring to is relevant to my problem as well?
Userlevel 7
Badge +21
Hope so, my app keeps failing to respond getting me the Android wait/kill box.
Same here. And when I open it again my whole playlist, and where it was playing, is reset and the speakers are out of their group again. Very annoying!
Userlevel 1
Badge
Just for the record: I have now tried downgrading my Sonos app to 9.1 and have still got the same problem. So the problem is NOT within the app itself but it has to bee something else in the Sonos system. Infuriously irritating.
Another thing, after a while, when controlling the volume from my home screen and pulling down all volume controls, I have multiple sonos volume bars. At this moment there are 7 volume bars from sonos... 😕
Userlevel 7
Badge +20
Hi folks,

There should be a new update available for the Android controller app which may help with these issues. Please update and let me know how it goes.
Userlevel 7
Badge +21
Just grabbed the Oct 17 update, 9.2.1 and giving it a run on my pile of Android controllers.
Userlevel 1
Badge
Nope. Sorry to tell you, but 9.2.1 didn't make any difference here 😞
Any chance you could submit another diagnostic for them to look at? Might help, certainly won't hurt.
Userlevel 7
Badge +21
danielmalmgren, Try rebooting your tablet/phone and see if that makes any difference, still no issues here today.

A diagnostic to sonos and reporting the number to them is probably the only path to getting a second fix if it is needed.
Userlevel 1
Badge
Nope, reboots doesn't make any difference.

I've sent a diagnostic (never done that before), got the number 954121655 for it. Is there any other way for support or is this community the preferred way to report problems?
Userlevel 1
Badge
So how do I know if anyone over att Sonos even noticed the diagnostic that I sent in? Sonos has been a struggle to use the last weeks and I don't even know if Sonos are aware of the problems...
Userlevel 7
Badge +21
Telling if a diagnostic has been looked at is pretty simple, they ignore all of them by default. The only ones they look at ate ones that someone has communicated with them about, here, Twitter, Facebook or phone - all from the contact page.

If you are on Android and 9.2 the 9.21 seems to be a lot better about dying unexpectedly so upgrade to it and wait for a crash. Submit a diagnostic and then tell Sonos your issue and give them the number.
Userlevel 1
Badge
Why on earth don't they have a proper bug report system? Well, anyway, I've been on 9.2.1 since two weeks (mentioned it above) and it's working as crappy as 9.2 for me. Guess I have to report my problems using multiple channels since nobody from Sonos actually seems to read much here...
Userlevel 7
Badge +21
I believe they read every post here so saying that is a bit unfair.

Complaining that they aren't here more often is more reasonable but as Sonos has said this is primarily a user to user community site with no promised response time from Sonos.

Phones, Twitter or Facebook are the way to go if you want a Sonos employee's opinion.
Userlevel 1
Badge
Well, maybe they read, but it's not handled like a real customer support. Last answer from an official Sonos representative was two weeks ago and I have no idea if anyone actually looked at the problem.

All previous problems that have arisen in Sonos have been fixed within a day or two, so I'm just surprised to find this being handled so badly...
Something that seems to be working for me is changing the notification priority from Medium to High for 'Playback Controls'. I'm not 100% sure yet, as only made the changes a few hours ago but seems to have improved things.

On my Samsung Galaxy S7, to make this change the steps were:

Settings -> Notifications -> Sonos -> Playback Controls -> Importance -> High

On other phones this setting might be elsewhere, and if it's a fix I'm not quite sure yet, but thought it worth sharing here as it does seem to have helped me.
Userlevel 7
Badge +21
Well, maybe they read, but it's not handled like a real customer support. Last answer from an official Sonos representative was two weeks ago and I have no idea if anyone actually looked at the problem.

All previous problems that have arisen in Sonos have been fixed within a day or two, so I'm just surprised to find this being handled so badly...


Of course these forums aren't "handled like a real customer support" what else would one expect of a place primarily designed for user to user communication?

Ask the community
Our community is a great place to share and connect with other people that are passionate about the same things you are.


Sonos offers "real customer support" via phone, e-mail, facebook and twitter if that is what you are looking for.
Badge
Has anybody found a way to fix this? I really miss the reliable notification controls. I'm liking the app less and less, even though we're being forced to use it more and more to control our Sonos systems...
Hi I have the same problem.

The controller used to pop up automatically when I was reaching home and connecting to my wifi. But now sadly I have to open the app to turn on the speakers.

Please fix this or let us downgrade to 9.1!