Question

After update "Unable to connect to Sonos" error in app

  • 12 August 2020
  • 3 replies
  • 383 views

So I just had the update to the app yesterday but now get the message “unable to connect to Sonos”, I know this is not correct as removed the speakers and was able to re apply them to the app but then they were unable to connect again.  Speaker and phone on same wifi, speaker work with good assistant so clearly have wifi but the app after the update doesn't work.  Have tried both the S! and S2 app as well. 

 

Clearly seems to be a app issue or a server issue but no information seems to be available online?

 

Speakers are Sonos One.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 5
Badge +16

Hi @1slyB.

Thanks for reaching out and welcome to the community!

I appreciate your detailed post outlining the issue as well as the troubleshooting steps that you did, let me help and try to figure this out.

Most of the time, it could be an IP address related issues after an update.

Have you tried using another controller?

First, I’d recommend a refresh of your local network: 

  • Unplug all your Sonos devices.
  • Reboot your router.
  • Give the router a couple of minutes to come back up, then plug back in your Sonos devices.
  • Give them a couple of minutes to reboot and reconnect as well, then test. 

 

You may also check our support article that provides some steps to follow to get your app reconnected to your Sonos system.

Kindly please submit a diagnostic report through the Sonos app, and reply with the confirmation number.

I'd be glad to review your system further and it will also help in identifying what's causing the issue.

 

Let me know how it does with the advice above, and if you have any other questions or concerns, don’t hesitate to reach out.

Thanks Annazel but it was nothing to do with my system.  I installed the PC app firstly and worked fine, went back to android and still would not work.  A few hours later the tried the android app and worked again, I would say it was an issue with the update or Sonos servers as it is working now and I did nothing.

It could be an issue with your network, especially if you have access points, an oddly configured mesh, or a power line adapter. That supposition, however, presumes that the Android device was connected to a different subnet than the PC was originally, but transferred at a later point to the same subnet as the PC and the Sonos. Without further data analysis from Sonos on a diagnostic, though, it would remain a supposition.