Adding folder from WinXP PC to Music Library Error (1002)


3304012 Dear folks@Sonos, As a pre christmas present we got a Play:3 + BRIDGE which work fine with my Tab and S2 Android systems. When I want to add music stored locally on my Windows XP Dell laptop though, I get an error (1002) telling me "Sonos was unable to add the music folder Reason: Unable to add the shared folder \\PCNAME\\folder to your Music Library (1002)". I've tried: -turning my windows firewall off -adding Sonos as an exception to that firewall when on -linking my laptop to the Bridge with a network cable -adding the folder from my shared documents All with the same, fruitless result. What can I do to add locally stored music files to my Sonos Music Library? Happy Holidays, Mike

18 replies

Tried wiring my laptop to the modem/router comb. - doesn't do the trick.
Userlevel 7
Badge +3
Hello Mike,

Sounds like you've done most of the basic steps there, but you might be running into something causing trouble in the background. Can you please submit a diagnostic from the system there so we can get a closer look at what's going on?

Cheers.
I'm having same problem - so I have submitted diags 
Your confirmation number is: 3321213
Userlevel 7
Badge +3
27/12/2013 06:58 PM wrote:

I'm having same problem - so I have submitted diags 


Hello,

Thank you for that diagnostic. The error message that's showing up in there is usually related to a firewall blocking the connection. I see that you have Kaspersky Anti-Virus running on that computer, can you please make sure that it's setup to allow file sharing? Also, if you have any other firewalls running on the computer I'd recommend turning them off. As a test, I'd recommend turning off Kaspersky too.

Cheers.

Ok, you Sonos reps are complete morons when it comes to this.  Yes, lets just turn off kaspersky EVERY time we want to listen to music.  Did that for 6 months no thanks to your crap instructions for Kaspersky 2014.  You do realize that they've changed to 2014, right???  The world did not end like the Mayans thought and software companies are going to continue to update their software.  

Anyway, here's my solution:   I tried uninstalling/reinstalling both sonos and kaspersky, tried the TCP and UDP settings in the guide... nothing worked except turning off Kaspersky.  Finally I ran across another post here that said to make sure your windows network profile is set to home or local and that it is a trusted network.  Did that... still nothing.  As a last resort, I took a look at the homegroup settings for my network (you can access this by typing in Homegroup into the start menu search box).  I noticed that the Stream Media With Device was not checked so I checked it and then went into the Choose Media Streaming Options.  JACKPOT!!!  All of my Sonos gear was blocked!!!  Changed the setting for each piece of Sonos and away I went.  Black Sabbath came out loud and clear from my PC's music library!!  

On a side note: My system resources were being completely used up after I checked that Stream Media w/ Device option.  Apparently it starts a process linked to WMP11 and is a complete HOG. Just leave this option unchecked but still change the Choose Media Streaming Options to allow each piece of Sonos gear to access the library.  If that does work, go to the Resource Monitor and take note of the process eating 30% or more.  It will be the only one above 5% so you cant miss it.  Do a google search on how to disable this to get your resources back.  Sonos still works perfect!

Stupid Windows, stupid Kaspersky, and stupid Sonos for not updating your guide to the 2014 version of Kaspersky.
Brad Wenzel wrote:

Ok, you Sonos reps are complete morons when it comes to this.  Yes, lets just turn off kaspersky EVERY time we want to listen to music.  Did that for 6 months no thanks to your crap instructions for Kaspersky 2014.  You do realize that they've changed to 2014, right???  The world did not end like the Mayans thought and software companies are going to continue to update their software.  

Anyway, here's my solution:   I tried uninstalling/reinstalling both sonos and kaspersky, tried the TCP and UDP settings in the guide... nothing worked except turning off Kaspersky.  Finally I ran across another post here that said to make sure your windows network profile is set to home or local and that it is a trusted network.  Did that... still nothing.  As a last resort, I took a look at the homegroup settings for my network (you can access this by typing in Homegroup into the start menu search box).  I noticed that the Stream Media With Device was not checked so I checked it and then went into the Choose Media Streaming Options.  JACKPOT!!!  All of my Sonos gear was blocked!!!  Changed the setting for each piece of Sonos and away I went.  Black Sabbath came out loud and clear from my PC's music library!!  

On a side note: My system resources were being completely used up after I checked that Stream Media w/ Device option.  Apparently it starts a process linked to WMP11 and is a complete HOG. Just leave this option unchecked but still change the Choose Media Streaming Options to allow each piece of Sonos gear to access the library.  If that does work, go to the Resource Monitor and take note of the process eating 30% or more.  It will be the only one above 5% so you cant miss it.  Do a google search on how to disable this to get your resources back.  Sonos still works perfect!

Stupid Windows, stupid Kaspersky, and stupid Sonos for not updating your guide to the 2014 version of Kaspersky.


Hi Brad

I am having issues too and would like to try out your solution that you have posted using Homegroup and Stream Media with Device but cannot find this option. I am using Windows 8.1. I did the search Homegroup from start menu and went to the Homegroup Settings - selected Music to be on but that didn't seem to do the trick... maybe I am not selecting in the correct place? Any for dummies advice would be much appreciated. Thanks

Amreet

Userlevel 7
Badge +3
Brad Wenzel wrote:

Ok, you Sonos reps are complete morons when it comes to this.  Yes, lets just turn off kaspersky EVERY time we want to listen to music.  Did that for 6 months no thanks to your crap instructions for Kaspersky 2014.  You do realize that they've changed to 2014, right???  The world did not end like the Mayans thought and software companies are going to continue to update their software.  

Anyway, here's my solution:   I tried uninstalling/reinstalling both sonos and kaspersky, tried the TCP and UDP settings in the guide... nothing worked except turning off Kaspersky.  Finally I ran across another post here that said to make sure your windows network profile is set to home or local and that it is a trusted network.  Did that... still nothing.  As a last resort, I took a look at the homegroup settings for my network (you can access this by typing in Homegroup into the start menu search box).  I noticed that the Stream Media With Device was not checked so I checked it and then went into the Choose Media Streaming Options.  JACKPOT!!!  All of my Sonos gear was blocked!!!  Changed the setting for each piece of Sonos and away I went.  Black Sabbath came out loud and clear from my PC's music library!!  

On a side note: My system resources were being completely used up after I checked that Stream Media w/ Device option.  Apparently it starts a process linked to WMP11 and is a complete HOG. Just leave this option unchecked but still change the Choose Media Streaming Options to allow each piece of Sonos gear to access the library.  If that does work, go to the Resource Monitor and take note of the process eating 30% or more.  It will be the only one above 5% so you cant miss it.  Do a google search on how to disable this to get your resources back.  Sonos still works perfect!

Stupid Windows, stupid Kaspersky, and stupid Sonos for not updating your guide to the 2014 version of Kaspersky.


Hi Amreet, 

Brad was running into a problem where his network profile on his computer was set to Public, and Kaspersky was using that profile to set its access restrictions. Disabling Kaspersky would work, but that's not a solution, just temporary patch. The fix is going into the Network and Sharing Center and changing the profile to Private. This page has some directions for doing this. 

If you're not running a firewall, or have the network set as Private or Home already, you could be running into another issue. If you'd like a hand, can you please submit a diagnostic from the system there so we can get a closer look at what's going on?

Thanks

I have the exact same problem and tried EVERYTHING, but the problem is still not solved:
- Turning off Firewall and turning off Antivirus;
- Use the name of the shared folder "JOHN-PC\Music" instead of "D:\John\Music", while having the firewall and AV turned on;
- Providing network credentials when connecting with a NAS (actually, choosing the option to add music from a NAS and then specifying my local folder on my PC);
- Run Sonos Desktop Controller with Administrative privileges;
- Assigning Sonos Full Control on NTFS permission on the "D:\John\Music" folder;
- Manually share the "D:\John\Music" folder and assigning Sonos Full Control share permissions;
- Adding Sonos Desktop Controller as an exception for the firewall and having the firewall turned on;
- My network location is set to "Private / Home " or as some call it a "trusted" network location;

The funny thing is, I am able to play music to my Sonos Playbar and Play 3's when I right click a music file on my pc, choosing the option "Play to > Sonos Playbar". The music starts playing.
So, I have tried every possible thing I could think of, but my problem is still not resolved. Can you help me?

(Windows 8.1 Professional with Administrator account)
My diagnostic number is 4110353.

Thanks in advance,

John
Userlevel 7
Badge +3
User121429 wrote:

I have the exact same problem and tried EVERYTHING, but the problem is still not solved:
- Turning off Firewall and turning off Antivirus;
- Use the name of the shared folder "JOHN-PC\Music" instead of "D:\John\Music", while having the firewall and AV turned on;
- Providing network credentials when connecting with a NAS (actually, choosing the option to add music from a NAS and then specifying my local folder on my PC);
- Run Sonos Desktop Controller with Administrative privileges;
- Assigning Sonos Full Control on NTFS permission on the "D:\John\Music" folder;
- Manually share the "D:\John\Music" folder and assigning Sonos Full Control share permissions;
- Adding Sonos Desktop Controller as an exception for the firewall and having the firewall turned on;
- My network location is set to "Private / Home " or as some call it a "trusted" network location;

The funny thing is, I am able to play music to my Sonos Playbar and Play 3's when I right click a music file on my pc, choosing the option "Play to > Sonos Playbar". The music starts playing.
So, I have tried every possible thing I could think of, but my problem is still not resolved. Can you help me?

(Windows 8.1 Professional with Administrator account)
My diagnostic number is 4110353.

Thanks in advance,

John


Hi John,

Thanks for the details and the diagnostic. The error message that's showing in the diagnostic comes up when the network adapter settings has sharing disabled. Can you check the File and Printer Sharing is enabled under the Network and Sharing Center > Network Adapter? Right click on the active network connection and choose Properties. There is a check box for File and Printer sharing there.

Are you on a Lenovo or IBM Thinkpad computer?

Thanks and let us know how it goes.

User121429 wrote:

I have the exact same problem and tried EVERYTHING, but the problem is still not solved:
- Turning off Firewall and turning off Antivirus;
- Use the name of the shared folder "JOHN-PC\Music" instead of "D:\John\Music", while having the firewall and AV turned on;
- Providing network credentials when connecting with a NAS (actually, choosing the option to add music from a NAS and then specifying my local folder on my PC);
- Run Sonos Desktop Controller with Administrative privileges;
- Assigning Sonos Full Control on NTFS permission on the "D:\John\Music" folder;
- Manually share the "D:\John\Music" folder and assigning Sonos Full Control share permissions;
- Adding Sonos Desktop Controller as an exception for the firewall and having the firewall turned on;
- My network location is set to "Private / Home " or as some call it a "trusted" network location;

The funny thing is, I am able to play music to my Sonos Playbar and Play 3's when I right click a music file on my pc, choosing the option "Play to > Sonos Playbar". The music starts playing.
So, I have tried every possible thing I could think of, but my problem is still not resolved. Can you help me?

(Windows 8.1 Professional with Administrator account)
My diagnostic number is 4110353.

Thanks in advance,

John


Hi Ryan,

Thanks for the quick response. I have checked the File and Printer Sharing settings under the Network and Sharing Center > Network Adapter. This is enabled for all my network adapters.

I am on a BTO laptop.
User121429 wrote:

I have the exact same problem and tried EVERYTHING, but the problem is still not solved:
- Turning off Firewall and turning off Antivirus;
- Use the name of the shared folder "JOHN-PC\Music" instead of "D:\John\Music", while having the firewall and AV turned on;
- Providing network credentials when connecting with a NAS (actually, choosing the option to add music from a NAS and then specifying my local folder on my PC);
- Run Sonos Desktop Controller with Administrative privileges;
- Assigning Sonos Full Control on NTFS permission on the "D:\John\Music" folder;
- Manually share the "D:\John\Music" folder and assigning Sonos Full Control share permissions;
- Adding Sonos Desktop Controller as an exception for the firewall and having the firewall turned on;
- My network location is set to "Private / Home " or as some call it a "trusted" network location;

The funny thing is, I am able to play music to my Sonos Playbar and Play 3's when I right click a music file on my pc, choosing the option "Play to > Sonos Playbar". The music starts playing.
So, I have tried every possible thing I could think of, but my problem is still not resolved. Can you help me?

(Windows 8.1 Professional with Administrator account)
My diagnostic number is 4110353.

Thanks in advance,

John


I also have Media Sharing turned on on my Windows 8.1 Professional 64-bit laptop.
It still does not work. Please help.
Userlevel 7
Badge +3
User121429 wrote:

I have the exact same problem and tried EVERYTHING, but the problem is still not solved:
- Turning off Firewall and turning off Antivirus;
- Use the name of the shared folder "JOHN-PC\Music" instead of "D:\John\Music", while having the firewall and AV turned on;
- Providing network credentials when connecting with a NAS (actually, choosing the option to add music from a NAS and then specifying my local folder on my PC);
- Run Sonos Desktop Controller with Administrative privileges;
- Assigning Sonos Full Control on NTFS permission on the "D:\John\Music" folder;
- Manually share the "D:\John\Music" folder and assigning Sonos Full Control share permissions;
- Adding Sonos Desktop Controller as an exception for the firewall and having the firewall turned on;
- My network location is set to "Private / Home " or as some call it a "trusted" network location;

The funny thing is, I am able to play music to my Sonos Playbar and Play 3's when I right click a music file on my pc, choosing the option "Play to > Sonos Playbar". The music starts playing.
So, I have tried every possible thing I could think of, but my problem is still not resolved. Can you help me?

(Windows 8.1 Professional with Administrator account)
My diagnostic number is 4110353.

Thanks in advance,

John


Thanks again for the details. It'd be best to work with a technician live at this time. I've created a ticket for you under reference number 
141208-002007 which has all of our notes and steps. Can you please give us a call with that number so the technician you speak with can review what you've done so far?

Hi,

I just installed my sonos system (play:5 & play:connect) and i'm also having trouble adding my music folder to the sonos system. 

It is on a external drive connected to my laptop.

I've tried about everything i have read in several threads on the sonos forums including:

- Disconnected and reconnected all devices from power in the given order.
- Checked my windows firewall exeptions + tried turning it off
- Disabled my AVG free.
- Checked all Network & Sharing options stated above.
- Tried sharing my folder manually with full access for all
- Media streaming is on, and i also can stream to the sonos devices.

I've submitted diagnostics, confirmation code: 4267415

I hope this can be resolved soon.

Hi,

I'm having exactly the same issue, my diagnostics confirmation number below:

Your confirmation number is: 4601551.

Thanks,

Isabel
Userlevel 7
Badge +3
User69787 wrote:

Hi,

I'm having exactly the same issue, my diagnostics confirmation number below:

Your confirmation number is: 4601551.

Thanks,

Isabel


Hi Isabel,

Thanks for that diagnostic. It looks like the name of the computer isn't responding properly when Sonos goes to find it. Usually this is due to a firewall or security software running on the computer, such as the Bitdefender program you have installed. You'll want to check that the network is set to trusted or safe within that software.

Also, for Windows, make sure that the network profile is also set as Private or Home.

If you're still having trouble, it'd probably be best to give us a call on our Support Line so a technician can assist live.

Thanks
Ryan S wrote:

Brad Wenzel wrote:

Ok, you Sonos reps are complete morons when it comes to this.  Yes, lets just turn off kaspersky EVERY time we want to listen to music.  Did that for 6 months no thanks to your crap instructions for Kaspersky 2014.  You do realize that they've changed to 2014, right???  The world did not end like the Mayans thought and software companies are going to continue to update their software.  

Anyway, here's my solution:   I tried uninstalling/reinstalling both sonos and kaspersky, tried the TCP and UDP settings in the guide... nothing worked except turning off Kaspersky.  Finally I ran across another post here that said to make sure your windows network profile is set to home or local and that it is a trusted network.  Did that... still nothing.  As a last resort, I took a look at the homegroup settings for my network (you can access this by typing in Homegroup into the start menu search box).  I noticed that the Stream Media With Device was not checked so I checked it and then went into the Choose Media Streaming Options.  JACKPOT!!!  All of my Sonos gear was blocked!!!  Changed the setting for each piece of Sonos and away I went.  Black Sabbath came out loud and clear from my PC's music library!!  

On a side note: My system resources were being completely used up after I checked that Stream Media w/ Device option.  Apparently it starts a process linked to WMP11 and is a complete HOG. Just leave this option unchecked but still change the Choose Media Streaming Options to allow each piece of Sonos gear to access the library.  If that does work, go to the Resource Monitor and take note of the process eating 30% or more.  It will be the only one above 5% so you cant miss it.  Do a google search on how to disable this to get your resources back.  Sonos still works perfect!

Stupid Windows, stupid Kaspersky, and stupid Sonos for not updating your guide to the 2014 version of Kaspersky.


Hi Amreet, 

Brad was running into a problem where his network profile on his computer was set to Public, and Kaspersky was using that profile to set its access restrictions. Disabling Kaspersky would work, but that's not a solution, just temporary patch. The fix is going into the Network and Sharing Center and changing the profile to Private. This page has some directions for doing this. 

If you're not running a firewall, or have the network set as Private or Home already, you could be running into another issue. If you'd like a hand, can you please submit a diagnostic from the system there so we can get a closer look at what's going on?

Thanks



For KASPERSKY users.
Go to Settings - Protection - Firewall - Configure Packet Rules. If Local Services (TCP) is blocked, edit it and change it to allow and apply it. Check if sonos now works. If not, change all the blocked rules into allow, and use logic to find out which of these rules are preventing the functions. If all of these don't work, just disable the firewall option entirely. Hope this helps, worked for me.
Brad Wenzel_1 wrote:

Ok, you Sonos reps are complete morons when it comes to this.  Yes, lets just turn off kaspersky EVERY time we want to listen to music.  Did that for 6 months no thanks to your crap instructions for Kaspersky 2014.  You do realize that they've changed to 2014, right???  The world did not end like the Mayans thought and software companies are going to continue to update their software.  

Anyway, here's my solution:   I tried uninstalling/reinstalling both sonos and kaspersky, tried the TCP and UDP settings in the guide... nothing worked except turning off Kaspersky.  Finally I ran across another post here that said to make sure your windows network profile is set to home or local and that it is a trusted network.  Did that... still nothing.  As a last resort, I took a look at the homegroup settings for my network (you can access this by typing in Homegroup into the start menu search box).  I noticed that the Stream Media With Device was not checked so I checked it and then went into the Choose Media Streaming Options.  JACKPOT!!!  All of my Sonos gear was blocked!!!  Changed the setting for each piece of Sonos and away I went.  Black Sabbath came out loud and clear from my PC's music library!!  

On a side note: My system resources were being completely used up after I checked that Stream Media w/ Device option.  Apparently it starts a process linked to WMP11 and is a complete HOG. Just leave this option unchecked but still change the Choose Media Streaming Options to allow each piece of Sonos gear to access the library.  If that does work, go to the Resource Monitor and take note of the process eating 30% or more.  It will be the only one above 5% so you cant miss it.  Do a google search on how to disable this to get your resources back.  Sonos still works perfect!

Stupid Windows, stupid Kaspersky, and stupid Sonos for not updating your guide to the 2014 version of Kaspersky.



Thank you for posting what worked for you. I would like to confirm that this worked for me on Windows 8. You have to go to Control Panels then click on Homegroup or search for Homegroup when you are in the Control Panel then follow the directions above. Make sure you have selected a network then on Homegroup click on "Allow all devices on this network to play my shared content". In this screen, make sure that your Sonos devices are not blocked to access your data because they were by default on my computer. I have BitDefender Security on and I did not have to turn this off in order to allow Sonos to access my Music data.
I'm having the same problem; I've submitted support diagnostics (ref. 5102322).
Thanks

Reply

    • :D
    • :?
    • :cool:
    • :S
    • :(
    • :@
    • :$
    • :8
    • :)
    • :P
    • ;)