Unable to play X - and the song is not encoded correctly

I was getting this error from time to time, but now I'm getting it on 3/4 of songs... Seems random, as sometimes a song that was working fine would refuse to play and start showing this error (or vice versa). 

My music source is YouTube Music. I've tried rebooting the speaker, reinstalling te app, rebooting the Wi-Fi router, etc. Also tried using an ethernet cable instead of Wi-Fi. Nothing seems to work. 

Diagnostic number : 1167656549

Screenshot :

Thanks in advance! 



Best answer by Annazel S 22 January 2021, 22:23

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

101 replies

I will echo the previous posts. Any play list created via Amazon Music will not play. The songs are no longer encoded correctly. 

I’ve just tried several Amazon Music Service Playlists including one called ‘Easy Hits’ …and as you can perhaps see (screenshot attached) they’re working okay here, but it might be a local issue.

The Sonos status page isn’t showing anything at the moment, but maybe keep an eye on that for any updates. 

Sonos Services Status Page

I will echo the previous posts. Any play list created via Amazon Music will not play. The songs are no longer encoded correctly. 

I am having the same issue with Apple Music as my provider I am very anxious that this is not going to be resolved. I have invested a lot in to my Sonos systems! very worried! 


My Sonos just succeeded in playing a file that had not previously worked.   I loaded the .wav into Audacity, and executed EXPORT/EXPORT MULTIPLE.  Resulting display offers a Format option—I selected 16 bit WAV, then clicked on EXPORT (directed to destination folder with original file, but renamed the export file).  Then I needed to open Sonos app and remove the master folder that is supposed to include the newly formatted file, and then add it back in.   (I tried an option under ‘manage’ that sounded like it would update new files but couldn’t make that work.  It would be nice to know if that ‘manage’ function does work and how to make that happen--because the reconnecting procedure is time consuming).   Only then did the new file show up in the Sonos app, and it played right away.

While it will be a long time before all my files are likely to be converted, this is great news for me, and hope it helps others.   Thanks very much, Airgetiam!!


This makes a TON of sense.  I’ve got a ton of music that I uploaded or added to my Apple Music library via iTunes Match years ago.  Deleting from my library and re-adding (with the AM DRM version) works for me, but there’s no chance I’m going to do this dance for thousands of songs.

Many (many) years ago, I opted to get an iTunes Match yearly subscription, it was less than £20 IIRC🤔?

I highlighted every single ‘digitally purchased’ track in iTunes and deleted those tracks, literally in minutes, then I highlighted all again (each now showing as being stored in the iCloud) and downloaded the track again, giving me the DRM-free version of every highlighted track - it took seconds to undertake these things, but took many hours (overnight) to re-download the thousands of tracks - I have a medium-large music  library (25,000 tracks) many purchased digitally and many ripped from purchased CD’s put together over a good many years - but it was well worth that single yearly iTunes Match subscription payment to sort these things back in the day - and it really is easy to delete and re-download all overnight, or perhaps several nights, if your library is huge.

The action of doing the switch to DRM-free does not take much effort at all to get the process underway, once the download starts for all, you can just walk away and goto bed, or work, or whatever.

The issue I have (sounds like it is similar to others on this thread) is that playlists or songs from Amazon that I saved a while ago are now not playing and have an error saying the song isn't encoded correctly.  Current playlists will play. Seems maybe the playlist points to a file that has been changed on Amazon.  Really could do with a quick way to re add songs to playlists in order to get the 'new' song location.  Or for it to be fixed within Sonos or Amazon. I've also tried re-adding Amazon music in the app, but without success.  Songs in the playlists that are saved locally still play, it just skips any that are streamed from Amazon.

It seems Amazon are switching their ‘standard music account users’ over to their HD/UltraHD services at no extra charge to the customer, so I wonder if that’s the reason🤔? …and that some of the older saved playlist shortcuts are pointing to tracks that have been updated to higher resolution audio, but the shortcut should be sending the Sonos Speaker the original (lower bitrate) version. but is somehow getting ‘confused’ …causing these ‘occasional’ (saved playlist) errors.

I’ve seen some users here say they’ve re-added/saved their tracks/playlists again and that they then work okay. So maybe its a problem with some old shortcut links to some files on the Amazon servers… just a guess 🤔?

I’ve been subscribed to the Amazon HD/UltraHD Unlimited service since it was first launched, so maybe that’s perhaps why I’m not (yet) encountering this issue too (possibly).

Same problem here with Sirius and Google play music which morphed into the crappy YouTube music. I have had the not encoded message for years but is getting worse as time moves on. When it disconnects the wifi is still available so I find it hard to believe it is a wifi router issue. I actually got a new router because I thought it may be the problem but no, it still exists. This is undoubtedly a Sonos issue as the cross service problem shows. As I said it is now happening 5-6 times in 6 hours and if there isn't a fix soon I will selling my Sonos and go elsewhere

I am having the same problem.  All of the playlists that I have taken so much time to develop will not play and I get the “song is not encoded correctly” error. Very frustrating.  I primarily use Amazon.

I am having the same problem.  All of the playlists that I have taken so much time to develop will not play and I get the “song is not encoded correctly” error. Very frustrating.  I primarily use Amazon.

I seem to recall another Amazon Music user posting here in recent weeks with a similar issue, but in their case they had added some tracks to their ‘continuing’ playlists whilst they were subscribed to Amazon Prime Music, but later had updated their subscription to Amazon Music HD/Ultra HD and some tracks had changed - I believe the user contacted Amazon and the Support Staff we’re trying to resolve the matter with them, but I think they still had to recreate some of their playlists in the Sonos App, albeit it was an Amazon issue... not sure if the same thing may apply in your case  but if it does and you have switched music service, it might be worth speaking to Amazon Support about the issue.

Ken, are you an engineer at Sonos? Tech support? It's incredibly frustrating the amount of money people have spent on these speakers to be having an issue like this...for two years now! How clueless are you? How many times do people have to tell you, yeah, I tried that!? 

No, I’m not a Sonos employee and apologies 🙏 if I’ve perhaps upset you in some way. I’m just another Sonos user like yourself and was trying to offer some simple things to try to fix your issue. I’ll just step out and leave it with you and just to add I sincerely hope you get it sorted. If not, you can always go onto submit a Sonos Diagnostic Report, noting it’s reference number, and then contact Sonos Support Staff direct via this LINK.

Good luck and hope you find the answer to the issue.

Thanks Ken. As stated, I did this. 

I am not technically educated to delve into the areas discussed here.  My system has progressively degenerated over the years to the point where I wished I just connected my phone to Sonos like I do to my car’s sound system.  I can no longer listen to radio episodes nor shows. Sonos don’t have staff available at weekends to discuss.  Seems to me their entire systems are too fragile for 2022 when electronics are becoming ever more easy to operate and intuitive. Sonos have my contact detail should they wish to persuade me otherwise.  If they fix it, I’ll post again. Silence suggests they can’t be bothered. 

I’m getting sick of this. Every time a Sonos update, same issue, and always blaming streaming service.

Songs starts playing absolutely fine then part way through stops with errors not encoded correctly. Same on next song, it’s playing fine then just stops midway through not encoded correctly. Was working fine yesterday, today after update, it’s broken again. 


I can’t see me buying Sonos again, i’m fed up of issues just trying to get it to play my music - shouldn’t be this hard.

If i use web app the steaming service strangely enough works just fine through my pc speakers.

Userlevel 3

Been getting the same here too for the last week or so with Amazon Music, but mostly only with my Sonos Playlists that have tracks from Amazon, but I can play it find if I browse Amazon Music to the same album I added it from

Thanks for the tip, Bruce.



Thanks for the prompt reply Airgetlam.

I'll give it a whirl, once I've overcome the Christmas festivities and report back.

Thanks again.

Certainly Sonos  provides essentially no tools for us to use at a local level. However, they do provide a method to submit a diagnostic from our systems, and a customer support group to call in to and have them interpret the data.

Sadly, not all Sonos Radio HD comes off of Sonos servers. 

I’ve had the same exact issue over the last day or so with Amazon Music. Based on our recent posts, there must have been an issue either with Amazon introducing HD (like eworthi said), or with some other software update. However, I just unplugged my Sonos bridge, unplugged and restarted my router, and then plugged Sonos back in, and so far (fingers crossed) it seems to now be working.

Good luck!


same problem for free sonos radio, it seems Sonos internal problem. 



I’d have to concur. It’s unfortunate that most routers do not have a better facility to point out the issue. 

Thats all very well but not everyone is an IT expert.  Some of us are simply customers of SONOS endeavouring to use their products purchased in good faith.  I have no idea how to "PING" an IP address to the router.  

For some reason SONOS, out of the blue,  indicate that tracks on our playlists are not encoded correctly. 

I'd much prefer to receive proactive emails from them indicating there are apparent issues and suggesting fix's, in layman's terms, rather than emails trying to sell me something every two minutes.

I’ll add my data point. My music is all local -- I occasionally will listen to a SXM channel, but mostly my library is ALAC or FLAC files that I ripped from CDs. The library resides on my iMac.

Things were working fine for the past two years or so. I have two sets of stereo pairs, each pair a One connected via ethernet and a One SL connected via WiFi. Each room has a WiFi access point so the One SLs are no more than 10ft from the router.

At first it happed fairly rarely and I just assumed I had a bad fine. Once it started happing more frequently, I’ve gone back and played the files on my Mac with iTunes or VLC and they play fine, so I don’t believe it is an encoding issue.

I haven’t done the phone support -- I guess I will do that but I’ve spent too much of my life on hold to some support/customer service line to look forward to that.

My thoughts are it’s the network connection, possibly related to the WiFi extenders, perhaps🤔 - I would simply reboot the entire local network, including all the extenders to see if that resolves the issue.

Sonos is crap with crap customer support. They said they would escalate my call to engineering and call me back. I'm still waiting on an update 3 weeks later.

 I checked my emails and my Amazon music account has been automatically updated to include Amazon Music HD.

I have just had the following from Sonos support


"We have noticed issues with the old playlists after updating to Amazon Music HD.

We have two workarounds, either re-create the Sonos playlist by searching for the respective Amazon music content and adding it to a new Sonos Playlist or re-create the playlist on Amazon Music Natively.

This is an uncommon issue that our team is aware of working to address in a future software release."

I’ve had the same problem getting ‘file not encoded properly’ error message. My source files are .wav, created either from an LP recording device or Audacity, or in some cases recording sessions.   I think my device is an A100.   Know less than nothing about the technical stuff, but in reading this trail it feels like Sonos devices return this encoding error message from many different sources.   Assuming those source devices work fine with other players, it feels illogical to suspect they are all the cause.  Doesn’t it seem more likely the coding error problem may have to do with the Sonos devices?  Or perhaps some of the technology the Sonos devices are using?   I spent a year recording my LP collection and gave the vinyl away over a year ago thinking I’d still be able to listen to the music.  Sad my only playback is Windows Media Player, and empathize with the other writers in this trail.  Wouldn’t it be be great if Sonos  figures this out; and have been hoping some update will bring this music back!!!

Any chance of naming some tracks that don’t work for you via the built-in Apple service. I subscribe to Apple Music and I’m sure there must be many others here too. I’m happy to see if the tracks you name work for my Sonos setup and will let you know whether they play on my setup (or not) - if not, then it will at least give the Staff here some data to work with and perhaps will help Apple (or Sonos) to fix the issue. I’ll add a diagnostic here too if they don’t play.

I’m not currently seeing any issues with the tracks I’ve been listening to since the latest update and that’s playing standard audio and many Atmos tracks too.

My issue was only with one speaker, a SONOS Five. If I unplugged my SONOS Five and PING that assigned IP address I was still getting a response! My issue was due to an IP address conflict. I solved the issue by logging into my router and finding the conflicting device on my local network. Once I forced the other device to use a different unassigned IP address the streaming problem with my SONOS Five went away. Hope this helps, you problem may be similar to mine.


In my 14 years posting here, I’ve found IP conflicts are the cause of 98% of all problems, despite the protests of “My network is fine!”. 

I’d have to concur. It’s unfortunate that most routers do not have a better facility to point out the issue.