TruePlay simply does not work in the new App


Userlevel 7
Badge +4

I tried to TruePlay Arc / Sub / Ones but the tuning is simply stuck on “Continue” step.

I’ve updated to the latest version 80.00.04. 
 

@Corry P do u guys are aware of this?

 


357 replies

Userlevel 2

Same problem here. I’ve tried again after an iPhone reboot but the error is the same. Also tried contacting Technical Support but no agents available unfortunately.

For info, I’m trying TruePlay in a room with an Arc, Sub and 2 x ERA300 speakers.

Thank you

Userlevel 2

Same issue is happening with me idk what to do

Userlevel 1

Hey I found a fix for this. Go on the Sonos app and make sure you have Spotify or Apple Music on it. Play about 10 seconds of any song and pause it, then go into trueplay and it’ll work. 

Same issue here. I’m also trying TruePlay in a room with an Arc, Sub and 2 x ERA300 speakers.

Userlevel 2
Badge

Not to pile it on, but same here. I get stuck at the Begin button, nothing happens, and the app soft freezes and has to be restarted to try again.

Attempting on an Arc/Minisub/play:1s setup, and in another room with just a playpar, same behavior.

Interestingly, I have an Era 100 that it will get past the Begin button and allow me to tune, but it is creating the same pew pew pew sounds, albeit at 1/3 volume, out of a Play 5 gen 2 in an adjacent room.

Seriously ready to sell all this gear and move on since this app update. Nothing seems to work as well, or at all, as before.

These are all FACTS! And I'm amazed that a company with such successful audio equipment is so incompetent with the software. Maybe they should have left Google alone and worked with Google because Google probably could have helped them with what they're trying to do. Ever since they've been trying to cut Google out of all their software, they've been trash. And the Sonos assistant is trash. It's nowhere near an equivocal replacement for the Google Assistant. They should have left good enough alone and kept fixing the app that they had which was already problematic. It wasn't perfect but it was way better than this new release! And I'm willing to overlook all of the other things that the app is missing but not TRUEPLAY! That's the one thing that makes the SONOS system SONOS. They've got to be kidding me. I mean the reason we bought all of the equipment is because we could tune our rooms and make it work. A lot of people have odd rooms and SONOS and TRUEPLAY was an excellent way to get the sound you were looking for without spending another $5,000 to do it on top of the equipment. And Sonos equipment isn't cheap? I have the era 300s, 2 Sub Gen 3s and the ARC for my theater. I have Two SL1s  in my garage. And I have two moves in my bedroom! And I was thinking about getting a mini sub but THE SOFTWARE IS A SERIOUS SCHOOLED HEEL! 

Userlevel 2

The Trueplay issue has been ongoing for almost a month, and no one from Sonos has addressed it. They have released updates to patch some issues since the release of version 80.xx.xx, but the Trueplay issue has never been mentioned in their fixes. It seems there is no solution or workaround available, or perhaps they simply don't care since they already have our hard-earned money for their expensive products. Despite our troubleshooting efforts, we end up disappointed and frustrated. This problem lies within their Sonos application, not the hardware. All we can do is wait and hope for a fix, which likely won't happen until they realize their sales are affected by this mess they've released.

I’m having the same issue 

Userlevel 1

My arc had its microphone disabled for some reason and when enabled I was able to get past the “continue” screen and started to tune but was not able to complete it as it was getting stuck at the final stage. 
 

issue still persists unfortunately 

Userlevel 1

I am in the same situation, with new SONOS app on iOS. I have a Beam Gen2 and a pair of ERA 300 as surround speakers, and I am unable to perform the TRUEPLAY calibration since the update to the new Sonos app. Is it possible to provide a quick fix because the products are excellent, but unfortunately,  the new app Sonos update is an absolute disaster.  😕

 

@Corry P do u guys are aware of this?

I am having this exact problem with the exact same set up/devices, the App is so unreliable, buggy, clunky, why can they not just listen to the feedback? Take your money and run! 

Userlevel 3
Badge +3

I am wondering if anyone from you got the same error message at the end of the first stage like me saying: “an error occurred and we couldnt tune your system. Please try again”…. I feel that all of you have common issues with trueplay and maybe my problem is of another nature…


Yes, happens to me too. Sometimes I can get it to get to the end where it says it is completed but then there is no toggle for Trueplay (ie. It didn’t actually complete). I often get that error too or it just hangs in the first stage where it is balancing for your seating position. The app is a total mess. I’m more worried at how slowly they are fixing issues. This has been now going for almost a month and it is not getting any better. 
 

I was considering upgrading my Move in my Kitchen to a Move 2 and my stereo pair of One’s in my bedroom to Era 100’s (and maybe even a Sub Mini to go with them) given the Father’s Day discounts on right now.  
 

No longer. Think I’ll just hold on my old speakers. And it’s not just trueplay or the missing features that are coming soon. App is just slow, unresponsive and buggy. I hope someone at Sonos is paying attention as they are losing sales. And I’m sure I’m not the only one. 

Userlevel 3
Badge +3

Same issue as everyone else. I’m on version 80.01.11 with Arc + Sub + Era 300’s and I don’t get the toggle on for trueplay after the process completes (if it doesn’t give me an error half the times I try). I can trueplay my pair of Ones in the bedroom just fine. But not this Arc HT setup. I keep trying it again every day after reading the new tricks mentioned in this thread (reset arc, reset app, etc) but nothing works and end up looking like an idiot. My wife now thinks I’m crazy. 

Userlevel 1
Badge

Still not working for me with my iPAD 9th generation newest OS and App :-(

Userlevel 1
I just did the latest update of the app. I updated all the firmware on the Sonos speakers, then went to the AppStore to update the app. Once this is done, I confirm for my part, that the TruePlay calibration worked well for me in a surround configuration with a Beam Gen2 and 2xERA300s. :-)
Userlevel 1

Evidently, it doesn't take much to understand that the TRUEPLAY calibration is NOT working since the new update of the SONOS app, despite all the good faith efforts to meet all the requirements for it to function normally. So, in light of all the feedback from your clients and consumers and the phenomenal BADBUZZ this regrettable situation is generating, is it possible to get a real response from the support team to inform us clearly and simply about the upcoming update needed for this new application so that those who purchase your products can finally get them to work correctly?  🙏🏼

Userlevel 2
Badge

I'm literally so pissed that I spent over $5,000 on my Sonos equipment and I can't tune my room like I'm supposed to be able to do that. I could actually eat an entire box of nails. I wish there was someone at sono's that I could literally punch in the solar plexus right now! You can do all the retuning and all of the resetting and all of the factory resetting of your internet provider. You can do all of that and you still will not get that true play to complete its diagnostic when it is tuning your room. What the freak is going on?

Userlevel 2
Badge

I just checked to see if there are any improvements, but alas TruePlay still gets stuck at the “begin tuning” stage. I have a Sonos Arc and Sub Gen 3. Since Sonos are ignoring customers, I think we should alert Apple to this as we depend on Apple products to use TruePlay on those products. Had I known Sonos products were heavily dependent on a buggy app I would never have bought their products, and will never do so again!

Userlevel 2
Badge

Can confirm the new update finally solved this problem. I sincerely hope this will be smoother in the future, but I have doubts.

Userlevel 1

Same issue. Reinstalled app and rebooted as well but no luck. 

  1. See A LOT of people in this thread with the same issues that I have,  Trueplay button does nothing with the new update. 
    what I Don’t see is ANY sort of Advice or Information from Sonos. 

    Sonos
  2. If there’s a problem with the App Update then say so and let us know you are either aware and attempting a fix or will put out a new update to solve the issue. 
    Simply telling individuals to contact support isn’t good enough as many have said they can’t even get through to support, I assume because we are all having the same issues. 
     
  3. For the price of your products we all expect better support and service, it’s also causing you to lose sales as at least two individuals in this thread have returned their speakers because of these issues. And, I’m sure will not be recommending to their friends & colleagues. 
     
  4. Now I’m wondering if I will get a response to this that isn’t a bog standard Contact Support, the response should be aimed at ALL of the individuals having the same issue. 
Userlevel 7
Badge +4

Hi @Majo133 

Thanks for your post!

Not if you are using an iOS device, no. If rebooting the phone does not help, I’d encourage you to get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

I hope this helps.

Thanks Cory, it seems that reboot of iPhone helped and TruePlay now works! 

I got it to work by not rotating my iPhone until as soon as the first tones started . Not ideal but still a workaround till they fix it. 

Hey I found a fix for this. Go on the Sonos app and make sure you have Spotify or Apple Music on it. Play about 10 seconds of any song and pause it, then go into trueplay and it’ll work. 

The fix posted by @Rdawkins fixed my issue, not sure why the fix works, but 

Same problem here. Just got a new arc, and Trueplay is blocked at that same step. Tried rebooting and it still doesn’t work.

Userlevel 7
Badge +4

Jesus, i did not expecy so many replies. Its sad to hear that even after 2 months, there are still so many issues with TruePlay. Sonos really did drop the ball on the new app.

The new app completely broke our perfectly working Arc + Sub. I had to factory reseted both of them, deleted and reinstalled the new app for them to pair again. Not only that, the connection dropped after 20’ and could not be found at all within the app. TruePlay also stuck during setup as reported by many other users - no matter what method I have tried.

Luckily, my iPad still used the previous version, so I used it to re-setup everything. Now it is working perfectly!

I still cannot believe that Sonos is able to produce top-notch high quality hardware, but they allowed this half-baked untested software to be released though. Huge disappointment!

Reply