Sonos cannot index USB drive on TP-Link Router


Is this problem still on the SONOS software team’s bug list to be resolved?  Has any progress been made?


Prior thread below.

Sonos cannot connect to USB drive on TP-Link router

Cannot share USB audio files with SONOS v2 system
Model: TP-Link Archer C8  
Hardware Version: V3
Firmware Version: 1.1.3 Build 20220510 rel.32759(5553)

The USB drive plugged into the Archer C8 shows it is active in the Archer C8 advanced USB settings.  All files are shared with no login required.

The network address is:  \\\sda1\USB_Music

Windows explorer can find the music files OK and can play them,  but the SONOS v2 system cannot access the music library.

Sonos initially connects to the USB drive at the network address entered, but gives the error message below after about 10 seconds.

I have worked extensively with SONOS customer support, but they were unable to resolve this problem.  SONOS suspects a problem with the TP-Link Archer C8's implementation of SMB1 and/or SMB2 protocols.

I have tried sharing the USB drive with and without user login and password, but neither works.

I just updated this router to the latest version firmware, but that did not resolve this problem.

Any suggestions from other users would be welcomed.

SONOS Error messge below:



Best answer by Corry P 2 May 2023, 10:03

View original

4 replies

Userlevel 7
Badge +18

Hi @gmendenh 

Thanks for your post!

This issue has not yet been addressed. There is still no ETA to share, unfortunately.


OK Cory,  Thanks for your answer.  Looking at several threads on this site, it seems that quite a few SONOS users are experiencing this serious bug and are unable to use their personal music libraries with SONOS.  I hope you can raise the priority with the software team fix this problem.  This is causing significant user dissatisfaction with an otherwise great ecosystem.


Please check to make sure this issue is still on the bug working list of the software team.

I found a solution that worked for me. Like everyone, I had tweaked the network, router, firewall etc, and kept on getting the same message.

Started to suspect that the error message may be misleading, or not entirely accurate.

Then, by chance, I browsed the music folders and noticed files that I think were created by Sonos in almost every folder. These files were called Folder.jpg, and AlbumArt*.jpg, and dated from 2021.  It made me wonder whether there was some issue related to these files, and decided to remove all of them. If Sonos needed them, I presume they would get re-created, or if Sonos was trying to remove them, maybe that caused an error.

After doing so, the re-index worked without error. I now have my Music Library back.

I hope that this works for others too, who have a USB/Network Drive with their music collection. In my case, the USB drive was inserted into my TP-Link router as I did not want to have my computer switched on to use Sonos.

btw, deleting these files is easier using the ’find’ feature to list all files in your Music folder with name folder.jpg and then deleting. Do the same file with all jpg files starting with AlbumArtwork.