Pocketcasts - Error, Unable to play, song not encoded properly or the connection was lost

  • 27 January 2021
  • 31 replies

Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

31 replies

Badge +1

Ugh. First problems with Apple podcasts, then Stitcher, now Pocketcasts. Getting tired of it. 

Userlevel 6
Badge +15

Hi everyone, thanks for reaching out to the Sonos Community!

As you have experienced, we are aware of an issue affecting Pocketcasts playback, particularly when attempting to skip forward or back, or when resuming from pause.

No ETA to share for a fix I’m afraid, however we are working with Pocketcasts to get everything working properly. In the mean time, if you are using an iOS device and have AirPlay capable speakers, you can AirPlay audio from the Pocketcasts app as a workaround.

Badge +1

I have been having the exact same problem for months. It seems to only happen when the podcast has been stopped and restarted. It has been a bug with Sonos for some time now. 

has anybody heard anything from Sonos about a solution?


I have started experiencing the “song not encoded correctly” error since the upgrade to 12.2.2.  It happens whether I am running a PocketCasts podcast using Sonos from my PC or from Android phone.  The fault occurs if I pause and restart or attempt to skip forwards or backwards.  I assume this is a Sonos bug rather than a PocketCasts issue.

What can I do to fix this problem?  Is this a known bug in the current release?  Where can I find it logged as such so that I don’t waste time looking for help? 


Has anyone else seen this error? The encoded error as well as the lost connection error are persistent & I have tried changing network channels, I have tried rebooting the system and I have tried uninstalling the service and adding it again.


The error codes persist despite these troubleshooting strategies.


Anyone else having this issue or have any suggestions?

I am getting this constantly over the past few months, on two separate Sonos systems.  The "lost connection” error fixes itself quickly, but the "not encoded correctly” problem does not.  


The thing I noticed is that pocketcasts seems to give this error only if you are trying to play a podcast from any position other than 0:00.  Since pocketcasts syncs across its system I go into the pocketcasts ios app, reset the position to 0:00 and then can play on sonos.  But don't try to fast forward or you'll get the error again unfortunately

One of the key things that I used to miss when I rebooted my system was the simple action of rebooting the router while the Sonos devices were unplugged. That way, I get fresh software across the board, as well as renewed IP addresses and DNS information. It’s not clear from your post one way or the other, so I thought I’d throw the idea out there.

Sometimes, people have also reported that removing PocketCasts from Sonos and then adding it back in has worked for them. I suppose it matters exactly why the error is existing as to which solution might work. 

However, if it continues after trying both those possibilities, I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it, or post the diagnostic number here for a Community Moderator to pick up.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution. Indeed, nothing better than hard data to look at.

When you speak directly to the phone folks, there are more options available beyond just the diagnostic analysis.