Answered

Plex unable to play certain songs "The connection to Plex was lost"


  • Contributor I
  • 2 replies

Trying to play music from Plex to my sonos. Some albums play, no problem. Some albums i get the following error message. - “Unable to play ‘song title’ - the connection to Plex was lost”

Things I have tried-

  1. Checked Sonos app for updates
  2. Checked Plex for updates.
  3. Restart plex.
  4. Restart phone
  5. Re-authorize Plex account
  6. Delete and reinstall plex service.
  7. Stop and re-start plex server

 

i have the same problem if I use the app on my phone or my computer. I am able to play these songs through “Plexamp” - which makes me think it is a Sonos problem?

My server is hosted on a Synology 920+

 

 

icon

Best answer by Corry P 5 June 2023, 13:29

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

This will almost definitely fix it:

 

Go to your plex server settings for Remote Access. Where you indicate your available upload speed. Change it to 0. 

 

Plex sees the Sonos streams as 10Gbps for some reason so it craps out. Removing this limit stops that from happening.

Worked for me thank you soooooo much! 

Thanks @Shawneau for the super fast reply.  FYI I think this is a plex pass feature and not available to free accounts (I’m on a free one still).

Userlevel 1
Badge

This will almost definitely fix it:

 

Go to your plex server settings for Remote Access. Where you indicate your available upload speed. Change it to 0. 

 

Plex sees the Sonos streams as 10Gbps for some reason so it craps out. Removing this limit stops that from happening.

 

@Shawneau do you still see this setting in your account?  I know you just posted this 8 days ago but I don’t see this setting in my server’s “Remote Access” tab (or anywhere) in Plex.

 

It’s there now

This will almost definitely fix it:

 

Go to your plex server settings for Remote Access. Where you indicate your available upload speed. Change it to 0. 

 

Plex sees the Sonos streams as 10Gbps for some reason so it craps out. Removing this limit stops that from happening.

 

@Shawneau do you still see this setting in your account?  I know you just posted this 8 days ago but I don’t see this setting in my server’s “Remote Access” tab (or anywhere) in Plex.

Userlevel 1
Badge

This will almost definitely fix it:

 

Go to your plex server settings for Remote Access. Where you indicate your available upload speed. Change it to 0. 

 

Plex sees the Sonos streams as 10Gbps for some reason so it craps out. Removing this limit stops that from happening.

Userlevel 7
Badge +18

Hi @krg 

You can see the connection signal strength if the speaker connects to WiFi rather than to SonosNet (Settings » System » [Room] » [tap on product] » Network), but not the connection speed. Your router is likely to give you that information though - log in to it’s settings page, and look for a list of connected devices.

With diagnostics, however, we can see the number of transmission retries and the amount of interference, so the information is more relevant than just how strong the signal happens to be. We can also check for other things that might be happening on the network, like multicast flooding, which would also limit the bandwidth available for normal functions.

I hope this helps.

ok - thanks. I did not know about that Support Diagnostic option. 

 

Is there a way to log onto my sonos product, and see the connection speed?

Userlevel 7
Badge +18

Hi @krg 

It’s working again? OK, in that case it has nothing to do with the file properties. In any case, my understanding is that Plex will transcode anything that can’t be played by a connecting client device anyway, so that should never be a concern.

Instead, I now rather suspect your network conditions are at fault - FLAC uses about 3x the bandwidth that lossy codecs such as mp3, wma or m4a tracks will use - it’s possible that the speaker failed to load a certain amount of the stream in a certain amount of time, and figured things weren’t going well enough to play. Intermittent results support my theory.

The best way to ascertain what the problem is is to wait until it happens again, submit a support diagnostic within about 10 minutes of it happening, then contacting our technical support team to give them the diagnostic number - they’ll be able to look at the speaker’s logs and see what the problem was.

I do recommend you first give our Reducing wireless interference help page a read, and ensure no WiFi devices are within 1m of your router and speaker(s).

I hope this helps.

thanks for the suggestion.

I checked that - as I thought it might be the issue, but it was not.  The problem was with some .flac files but other .flac files would play. 

I also tried doing the “Plex Dance” where I removed the library - and the files, emptied the trash and then installed the library again. Still the same problem. I think it was a Sonos issue, as the songs would play fine through other apps. 

This morning it is working again. I’ve no idea why. 

Userlevel 7
Badge +18

Hi @krg 

Welcome to the Sonos Community!

Is there anything that the tracks that fail to play have in common? A file type, perhaps, or a particular sample rate?

I have Plex installed but don’t use it very much - I’ll do some testing of my own in the meantime.