Cannot connect Youtube Music to Sonos One SL

  • 19 October 2022
  • 12 replies
  • 2385 views

Badge

I have a YouTube premium account but can't connect the service to my new sonos one SL.

I’m using Samsung S20 android and all apps are up to date.

When I select my existing Google account after I use the verification code it says "Success device connected" in Google but when I go back to the sonos app it says:

"Connection error. There was a problem adding the YouTube music account. A connection to YouTube music could not be made"


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

I had the same issue.. tried it 100 times with my phone didnt work... 1 time on a PC and it worked

 

1. Download the Sonos S2 App on PC or Laptop

After downloading open the Programm.

2. Sign in with your Account and try the same process -> Connect it to YouTube music with the Code like you did on youre phone... after that it should work. 

If you open the App on the phone it will show the connection to Youtube music.

(Hope i could help and greetings from germany)

Userlevel 7
Badge +21

Is there an option to re-authorise it?

Badge

Is there an option to re-authorise it?

To re-authorize the Sonos or Youtube Music? Youtube Music does not display in the Sonos. It connects on Google but when I return to the Sonos app it says:

"Connection error. There was a problem adding the YouTube music account. A connection to YouTube music could not be made"

Userlevel 7
Badge +21

There’s an option in the Sonos app. Failing that delete it and try again. 

Badge

Deleted the Sonos app and its still doing the same thing.

Do I need to create a fresh Sonos account?

Deleted the Sonos app and its still doing the same thing.

Do I need to create a fresh Sonos account?

I believe @bockersjv was suggesting you simply reauthorise your YT music account within the Sonos App, not remove the Sonos App... goto ‘Settings/Services & Voice’ and reauthorise it there, it needs the Google Assistant App on your controller device to be logged in with the same/correct Goggle account credentials, so perhaps check that is correct aswell.

Both your Google ‘language’ profile and your Sonos profile ‘country’ settings need to match and ensure the Google account has one Home only attached to it, which is linked to the same YT music account - reauthorise it too in the App, just for good measure.

Enter the credentials manually, not automatically, on your mobile device to ensure they are correct.

Badge

Deleted the Sonos app and its still doing the same thing.

Do I need to create a fresh Sonos account?

I believe @bockersjv was suggesting you simply reauthorise your YT music account within the Sonos App, not remove the Sonos App... goto ‘Settings/Services & Voice’ and reauthorise it there, it needs the Google Assistant App on your controller device to be logged in with the same/correct Goggle account credentials, so perhaps check that is correct aswell.

Both your Google ‘language’ profile and your Sonos profile ‘country’ settings need to match and ensure the Google account has one Home only attached to it, which is linked to the same YT music account - reauthorise it too in the App, just for good measure.

Enter the credentials manually, not automatically, on your mobile device to ensure they are correct.

Thanks for the advice. I can’t re-authorize the YT Music app in the Sonos because it doesn’t even get to the point of displaying as a service.

 

Thanks for the advice. I can’t re-authorize the YT Music app in the Sonos because it doesn’t even get to the point of displaying as a service.

Then check the language and country settings and the other things mentioned in my post - it’s possibly the Sonos online profile country setting. Check HERE

Badge

Thanks for the advice. I can’t re-authorize the YT Music app in the Sonos because it doesn’t even get to the point of displaying as a service.

Then check the language and country settings and the other things mentioned in my post - it’s possibly the Sonos online profile country setting. Check HERE

I’ve changed the language and country to match but still no change. Can you explain how I check if my Google account has one home attached to it? I’m not sure what you mean by this or where I see that?

If you have more than one Home, you can add the account to your App, and when you do that, you will see a dropdown list next to where the Home is shown in the Google Home App - see below…

 

Note @twelvetenz, if you did change language, as you’ve mentioned, then also fully close (slide off screen) and reopen the Sonos App

Userlevel 2

I tried all of the tips already mentioned with no success. I wound up deleting the app, power cycling all Sonos devices, power cycling my router, reinstalling the app, and choosing “Add a new system” (or create a new system -- whatever the alternative option is to “Join an existing system”).

After I completed the creation of the ‘new’ network, I was able to add YouTube Music.