Answered

Can't login to app even though I know password is correct and have reset multiple times


As title.

Can login on the web version (hence i can write this question!), but can’t login to use my Andriod app.

I have reset the password multiple times, have uninstalled the app, have reset the app, have tried to set up a new account… None of these things worked.

 

Help please!

Many thanks 

icon

Best answer by John B 4 May 2020, 17:46

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

46 replies

Userlevel 2
Badge +1

No, it was the same Account. 

 

Just the login Procedure is different, email and password in steps.

 

Think they are working on new Version anyway. 

Any solutions?

 

Same error here, cannot add new device, login in app fails, password is correct, tried different android versions.

 

Edit: Was able to login this way:

 

App → Settings → System → Transfer System Ownership → I can’t access this account

 

After that, login worked and I can manage/add devices.

 

Strange Software Path to add a new device 🙃 

It sounds like you simply transferred the system over to the account credentials that you were of, that’s all.
You should not need to do that the next time you add a new, or reset, Sonos product to your system. 

Userlevel 2
Badge +1

Any solutions?

 

Same error here, cannot add new device, login in app fails, password is correct, tried different android versions.

 

Edit: Was able to login this way:

 

App → Settings → System → Transfer System Ownership → I can’t access this account

 

After that, login worked and I can manage/add devices.

 

Strange Software Path to add a new device 🙃 

Generally short for “Customer Service”, aka Sonos support, I’d think. But I’ve never heard of support saying anything would be “fixed in 30 minutes”, either. 

Userlevel 7
Badge +17

Who is CS?

Any solution to this yet? Same problem here. (Logging in desktop app works though, only the mobile controler do not work)

I have the same issue 

There isn’t one as i can’t login to the app. But when I try to login I use the same email as the web version i’m currently logged in to…

 

I have the exact same problem , sent diagnostics to CS and they told me it would be resolved in 30 mins and it is not 

I suggest that you contact support.

I suggest  you read my message. There are never agents online to chat and the bot does not give any solution.

Maybe try transferring your system over to the Sonos account/credentials that you know are correct - see this support link:

https://support.sonos.com/en-us/article/transfer-your-sonos-system-to-a-new-account

I suggest that you contact support.

I suggest  you read my message. There are never agents online to chat and the bot does not give any solution.

I suggest that you contact support.

So i am also unable to login to the App. It used to work just perfectly fine and somehow i am logged off, can't login with the credentials I use here and on the login page it suggests an email i have no idea of. Reinstalled and nothing happens. When i start the app it briefly shows im logged in with my mail and then shows sign in straight away. It is so confusing, because it is not working on my phone, tablet and laptop….. chat support is nowhere to be found….

So i have just got a sonos SL speaker for Christmas today and i am having the same issue i can login through the browser site but not through the app, the speaker is usless with out the app working. I have read the comments on this thread and the comments are from a year ago, and this issue clearly has not been solved a year later, whats the point of selling sonos speakers if the app is usless. 

So when you reinstalled the app, and selected ‘connect to existing system’, does it do so?  If not, what error message do you get?  Only certain Settings are ‘behind’ a login so what happens if you tap Settings?

What version of Android are you running?

I have always had this issue with Sonos. Never able to login to the app over a 5 year period but can online. Sonos is garbage. 

@BeeO

I have the same problem, I cannot log in, and it's not possible to send a reset password to my mail. 

How am I supposed to get to the settings to transfer the system to my email when I cant do anything in the app?

/Emma

 


If your system and the app are all connected to the same Wi-Fi you don’t need to be logged in to transfer it. Open the  app, go to system - scroll to the bottom to Transfer System Ownership and begin the process. Since you’re logged into write your question it should be the same log information that you transfer it to. Good luck!

@BeeO 

I have the same problem, I cannot log in, and it's not possible to send a reset password to my mail. 

How am I supposed to get to the settings to transfer the system to my email when I cant do anything in the app?

/Emma

 

Hey everyone, I just figured this issue out. When you log into your app account, it's gonna have some weird email like s******@gmail.com or whatever. If you see this, you need to transfer your system to your email. There is an option to do it under the settings. After you do that, it should allow you to use your email account t to login regardless of using the correct password and getting the "incorrect password" issue. 


This absolutely works. Thank you for figuring it out. That was a ridiculous situation we were in. I updated my password a dozen times before I came across your post. 

Okay, final update. Got it working!!!! After I did the above things I mentioned, and it still doesn't work for you, go ahead and do a factory reset and the rest should be good to go. If it does not work, I guess you can throw the product out the window because this has taken me about 3 hours to figure out. 

Update, after getting the system ownership transferred to your email, I closed the app, and opened it back up. I was able to connect up to the point where it asks me for my wifi, it detected every wifi in my neighborhood except for mine..............................................................…

Patience is a virtue

Hey everyone, I just figured this issue out. When you log into your app account, it's gonna have some weird email like s******@gmail.com or whatever. If you see this, you need to transfer your system to your email. There is an option to do it under the settings. After you do that, it should allow you to use your email account t to login regardless of using the correct password and getting the "incorrect password" issue. 

Any solution to this yet? Same problem here. (Logging in desktop app works though, only the mobile controler do not work)

Yes it’s fixed, I’ve just tried it a few moments ago and it logged in first time - no issues.

I’ve tried both iOS and Android devices and each are working okay.

If it’s still not working for you, then I suggest perhaps contacting Sonos Support via this LINK.

Any solution to this yet? Same problem here. (Logging in desktop app works though, only the mobile controler do not work)

Haters gonna hate.

 

By the way, welcome back!  It’s been a while. 

Haters gonna hate.

Telling people to calm down and stop moaning is not really helpful especially when they seem calm and are not moaning but rightly expressing frustrated with the product. Drama? Seems to only be in your head.

Stop the judgements. You are helping no one with them.

 

 

“app is garbage”, “because it’s junk”, “probably going into the trash”, “Paperweights” is moaning and drama.  So is replying to a post that is a month old and probably long ago solved just because you don’t like someone’s answer. 

 

This SONOS S2 IOS app is garbage.  No matter what I do, I cant log into the app, and the App says there a network problem.  There is no network problem, my phone is working the network fine, and I can log into the SONONS website with my account just fine.    All of this totally defeats the purpose of the Sonos devices.  If I have to spend 2 hours trying to reconnect them to the network and then I cant use the app because it’s junk, what the point of having the devices?  They are probably going into the trash.  Two SONOS One devices.  Paperweights..  

 

First off, calm down.  Everybody here are users like you, volunteers who really don’t need to hear you moan.

Second, what do you mean by “can’t log into the app?”  Unless you are setting it up for the first time, the app requires no login.  Do you mean it won’t connect to your system?  If so, it may be that you are connected to the wrong band of your router.  Sonos is on the 2.4 GHz band.  Connect to that and see if that fixes it.

If not, let us know where the problem lies, but without all the drama.  It doesn’t get you help any faster, and most certainly will cause people to not bother helping at all. 

Telling people to calm down and stop moaning is not really helpful especially when they seem calm and are not moaning but rightly expressing frustrated with the product. Drama? Seems to only be in your head.

Stop the judgements. You are helping no one with them.