Question

BUG REPORT: Error Code 913 attempting to add Windows Folder to Music Library


Userlevel 2
  • Contributor I
  • 4 replies

This exact error has been widely reported here, but mostly for Macs. None of the official accepted “answers” for Windows provide a solution.

Running Sonos Controller for Windows 16.2.

This all started when I repped some of my CDs and tried to re-index the folder. It hung for hours. I let it run overnight, and it was still hanging. I closed and restarted the app. After that, any attempts to access the Music folder - or any subfolder - fails with the 913 error code.

I tried uninstalling and reinstalling the Controller. That has NO effect on this failure.

The Controller either suddenly won’t support WIndolws Folders, or it leaves some “residue” during indexing that cannot be removed by uninstalling the app. It could be hidden properties on the folders themselves, hidden Windows Registry keys, something.

 


49 replies

Userlevel 2

I am getting the same error, but I did not re-index the folder.

Some recent update to the Sonos app caused my local music library to disappear from available services. I went to the Sonos app on my Windows 11 computer to try to share the folder, using “Music Library Settings” from the “Manage” menu, clicked “Add”, navigated to the folder containing the library, and clicked “Next”.  After a few moments, I got the error “Sonos was unable to add the shared folder”, with the error code 913.

As with the previous user, this is in Windows, so the suggested solutions for MacOS do not apply.

Sonos, please fix this bug ASAP!!!!

What is the use of spending several hundred dollars on speakers when they cannot play any of my music??????

Userlevel 2

Why don’t Sonos comment publicly on these issues and make their next steps clear for all users?

Userlevel 1

SONOS is great, until it stops working, and then it’s crap. One hour waiting on the phone to figure why my music library disappeared and won’t let me reinstall it. ERROR 913. Thanks a lot, Sonos.

Userlevel 2

I got mine to work again about a week ago allowing all possible sharing options of my Music folder with the Sonos system on Windows. Yesterday evening, when swapping from music played from the local library to a Line-In for watching TV from an old Laptop (yes, I know… it’s an interim setup), I could see that the local library had disappeared from the new app on my phone, and voilà this morning it had also disappeared from the Windows Desktop App. I have no idea what’s exactly happening there and why it works some times and other times it doesn’t :( 
This is more than frustrating for someone who is very particular about the music they listen to and gets irritated easily by the wrong song on a radio station…. I dearly hope they can address the local library issue quickly with a new update

A quick search around the forum shows the following as the fix for error 913 - it’s  just a folder permission error on the PC…

  1. Right click on the Music folder and click on PROPERTIES at the bottom of the menu.

Click on the SHARE tab and then click on the first SHARE button…

  1. A new window opens and you click on the ‘v’ drop-down list option next to the ADD button.
  2. Click on "Sonos Wireless HiFi System" then click on the ADD button and finally click on SHARE.
  3. Open your Sonos app on your PC and add your music library.

Also see this earlier thread with screenshots…

https://en.community.sonos.com/controllers-and-music-services-229131/can-t-add-folder-to-music-library-913-6893981

Userlevel 1

I have this issue too.

I have returned the one Sonos unit just purchased. But would still like the make the others work while I research alternates to Sonos

Badge

Hello,

I have received the exact same message and was unable to connect to my “Music” folder on my PC until I performed the following steps:

  1. Right click on the “Music” folder
  2. Select properties
  3. Select the “Sharing” tab
  4. Select Share
  5. Select “Sonos Wireless HiFi System” in the dropdown box
  6. Click on “Share”
  7. Back at the top “Music Properties” dialog box click on “Advanced Sharing”
  8. Click the “Share this folder” box in the upper left corner
  9. At the bottom of the dialog box click “Apply” and then click “OK”
  10. Go back to the Sonos controller and add your local “Music” folder

This worked for me.

Hope this helps.

daveintennessee

Userlevel 1

According to Sonos support, the reason for this breakage is that they have, without warning, ended support for http and SMBv1 protocols for accessing network drives, out of a supposed concern for our security. Your network share must use SMBv2 or SMBv3 protocol. This is something you would adjust on the device which is doing the sharing. If, as in my case, this is not a Windows system, the proposed fix for Windows PCs will not be useful even if you are using the Windows application. So for instance, in my case, since my music is on a flash drive plugged into a Netgear router, I would go to the router administration page in my browser (192.168.1.1 in my case) and see whether there’s a way to select the SMB version level.

This is a complete  joke for a product that is not cheap . Access to your own library should be a simple task . Not spending hours with tech support trying to resolve. I’m sure the CEO of Sonos is having a lovely weekend in the Hamptons while loads of us won’t be be to listen to music this holiday weekend . Why the hell don’t Sonos actually make a comment on this instead of leaving it to the customers sort out . Ahhhhhhhhrrr. 

I bought the One SL to playback from my music library. So impressed I bought another for he full stereo experience. Not cheap, but more than happy with the set up. Since the recent update I now have a very expensive stereo radio. Not happy anymore.

A quick search around the forum shows the following as the fix for error 913 - it’s  just a folder permission error on the PC…

  1. Right click on the Music folder and click on PROPERTIES at the bottom of the menu.

Click on the SHARE tab and then click on the first SHARE button…

  1. A new window opens and you click on the ‘v’ drop-down list option next to the ADD button.
  2. Click on "Sonos Wireless HiFi System" then click on the ADD button and finally click on SHARE.
  3. Open your Sonos app on your PC and add your music library.

Also see this earlier thread with screenshots…

https://en.community.sonos.com/controllers-and-music-services-229131/can-t-add-folder-to-music-library-913-6893981

THIS WORKED!  Thank you!

i am also facing the same issue. Not able to see my library either in my windows 11 as well as Iphone . Not able to access ‘My Library’ , Error 913 .

A quick search around the forum shows the following as the fix for error 913 - it’s  just a folder permission error on the PC…

  1. Right click on the Music folder and click on PROPERTIES at the bottom of the menu.

Click on the SHARE tab and then click on the first SHARE button…

  1. A new window opens and you click on the ‘v’ drop-down list option next to the ADD button.
  2. Click on "Sonos Wireless HiFi System" then click on the ADD button and finally click on SHARE.
  3. Open your Sonos app on your PC and add your music library.

Also see this earlier thread with screenshots…

https://en.community.sonos.com/controllers-and-music-services-229131/can-t-add-folder-to-music-library-913-6893981

THIS WORKED!  Thank you!

That worked for me also after a long wait to get to tech support and not being resolved. Thanks, my music plays again!

Thanks to some extremely good comments in this thread I was able to solve this.

From this it is clear to me that with some clear and well articulated instructions, and some warning in advance, this would not be a problem.  As it is -- Sonos has really created a giant clusterfork for nothing.  What a ridiculous fiasco.

 

They did send out a warning, but IMHO, it wasn’t sufficient.  It merely stated that SMB v1 and HTTP sharing will no longer be supported.  They should’ve done more to let people know in less technical terms what to expect and how to rectify.

Thanks to some extremely good comments in this thread I was able to solve this.

From this it is clear to me that with some clear and well articulated instructions, and some warning in advance, this would not be a problem.  As it is -- Sonos has really created a giant clusterfork for nothing.  What a ridiculous fiasco.

 

They did send out a warning, but IMHO, it wasn’t sufficient.  It mere stated that SMB v1 and HTTP sharing will no longer be supported.  They should’ve done more to let people know in less technical terms what to expect and how to rectify.

I never received any warning.  And just stating that is ridiculously inadequate.  They should have given detailed instructions.

A quick search around the forum shows the following as the fix for error 913 - it’s  just a folder permission error on the PC…

  1. Right click on the Music folder and click on PROPERTIES at the bottom of the menu.

Click on the SHARE tab and then click on the first SHARE button…

  1. A new window opens and you click on the ‘v’ drop-down list option next to the ADD button.
  2. Click on "Sonos Wireless HiFi System" then click on the ADD button and finally click on SHARE.
  3. Open your Sonos app on your PC and add your music library.

Also see this earlier thread with screenshots…

https://en.community.sonos.com/controllers-and-music-services-229131/can-t-add-folder-to-music-library-913-6893981

This works for my laptop, but not my NAS. Does anyone know how to change the SMB on an older wd mycloud device - there’s no option to amend it in settings when accessing via the wd mycloud UI?

Having read many of the posts about this problem, and having it myself, I have sent the following email to the CEO. It will be interesting if I get an answer, and hopefully a solution:

Good morning

I have returned from a business trip to find that I can no longer play my iTunes library through my Sonos system. I have used this facility succesfully for at least 5 years.

I have tried everything to remedy this, but the iTunes folder will simply not load - and error code 913 is shown every time. I have checked the file, and sharing is enabled / allowed. I run Windows.

Looking on your forum, I see this is a new problem and everyone seems to have it who tries to play their iTunes library through Sonos..

What are your plans to rectify this please? If you are not going to rectify it, my Sonos system is no use, and I really would not expect that.

I would also ask, why does Sonos not reply to the thousands of comments on your own platform (Sonos community) relating to this issue?

I look forward to your reply, and a solution.

Thank you! The music file sharing instructions as given by several of you in this thread worked for me (Windows 11). After countless “error code 913” tries I can once again play my iTune music files on what I was calling my expensive paperweights these last few weeks. Why couldn’t anyone from SONOS provide this relatively simple solution?

Userlevel 2

I got mine to work again about a week ago allowing all possible sharing options of my Music folder with the Sonos system on Windows. Yesterday evening, when swapping from music played from the local library to a Line-In for watching TV from an old Laptop (yes, I know… it’s an interim setup), I could see that the local library had disappeared from the new app on my phone, and voilà this morning it had also disappeared from the Windows Desktop App. I have no idea what’s exactly happening there and why it works some times and other times it doesn’t :( 
This is more than frustrating for someone who is very particular about the music they listen to and gets irritated easily by the wrong song on a radio station…. I dearly hope they can address the local library issue quickly with a new update

Realised later on that I just had to re-boot my laptop. It’s all working again but it appears that it keeps crapping out every now and then, potentially related to updates in the new app interfering with the existing setup. So, making sure that from the Windows side, the music directory is shared to the Sonos system at multiple levels appears to salvage playing of local libraries. With the occasional hickup :) Should get us through until the June update for which they promise local libraries back, though :)

This solution worked for me: 

 

Anyone have an ETA on the fix for this?  TYVM.  

According to Sonos support, the reason for this breakage is that they have, without warning, ended support for http and SMBv1 protocols for accessing network drives, out of a supposed concern for our security. Your network share must use SMBv2 or SMBv3 protocol. This is something you would adjust on the device which is doing the sharing. If, as in my case, this is not a Windows system, the proposed fix for Windows PCs will not be useful even if you are using the Windows application. So for instance, in my case, since my music is on a flash drive plugged into a Netgear router, I would go to the router administration page in my browser (192.168.1.1 in my case) and see whether there’s a way to select the SMB version level.

I think that is my case: my NAS is a bit too old and it’s using SMB version 1 protocol. When visiting it from a Windows terminal I can adjust it for the connection, but in Sonos app there is no such option or known possibility, although I completely accept this security risk. I don’t have the plan to replace my NAS because I have too many devices connecting to it. I guess I have to replace my Sonos to another brand, then.

This problem happens also on a local library on a windows computer (not only on a NAS network shared folder). Lucky for us this is easy to solve!!!
I was in a hurry so i was able to quickly solve it sharing that folder (Music in my case) on network and allowing access to everyone (read/write).
So this is surely a network sharing access permission problem. So I’m sure that just following this suggestion will help too (and it will be a little more “secure”):
Please right-click on the Music Folder > Properties > Advanced Sharing > Add “Sonos Wireless HiFi System” (it’s a user) >» Flag Read/Write permission.

Source:
https://en.community.sonos.com/controllers%2Dand%2Dmusic%2Dservices%2D229131/fixing%2Dthe%2Dlibrary%2Derror%2Dcode%2D913%2Dfor%2Dwindows%2Dusers%2D6895367?tid=6895367

Has anyone solved this for Mac’s yet?    Was told by online chat to phone tech support but it’s a 75 min wait right now

Thanks!

Hi - I just want to emphasize one aspect of the solution to the 913 issue kindly documented above by davefromtennessee. I am running Windows 10 and the latest Sonos PC controller build. 79153290. Simply adding a share for your Music Folder (Properties->Sharing ) is not enough. You need to utilize Advanced Sharing ( Properties->Sharing->Advanced Sharing->Share this Folder(check this). While I was there I also did the following from this screen:Permissions->Add->Advanced->Find Now->click Sonos->OK->OK. After that I went back into the Sonos PC Controller and it successfully added the Music Library. I’m providing a screen shot of the nested Permissions screen below. Also, before doing this, I had a chat with Sonos Support and their diagnostic said that I was trying to use SMB1 so they told me that was the problem. I doubted this based on my own experience and as you see it had nothing to do with the problem so watch out - I know they are trying hard but their own diagnostics may be giving bad info. Good luck. 

 

Reply