WiFi password incorrect

  • 14 October 2019
  • 34 replies

I've spent 3 days trying to get my playbar, sub, and 2 play-3 speakers set up and it keeps saying the WiFi password is incorrect even when I copy-paste from the router settings.
It accepts the range extender network password, which is the same as the other one, but then tells me I can't use the speakers without the Boost.
So now I'm stuck with thousands of dollars of speakers that don't work.
I've tried changing the network password, deleting and reinstalling the app, resetting the speakers. I've tried plugging a speaker into the router but then the app doesn't even find it when searching for speakers to set up.
Can anyone suggest something else to try?

Best answer by nik9669a 14 October 2019, 12:13

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

34 replies

I had the same problem with me Play 3. Tried many things.


I called my internet provider and ask them if the could reset my WiFi router. I also told them to use lower case and no spaces between letters for the name of the network.


I use the 2.4 Ghz band.


it worked. 

Userlevel 7
Badge +23

Please don’t turn on UPNP on your router, it opens a wide security hole. It is not necessary for Sonos unless you have an old, crappy router. If you actually find it necessary, please share the router model # so others can learn from it.

Even I had the same issue. And after I did the following changes, it resolved my issue.

Ensure that wifi is 2.4 GHz b/g/n

I contacted sonos customer care & the following changes done resolved the issue for me:

  1. Change the wifi channel mode from auto to manual, the sonos uses channel 6, so its best to select channel 1 or 11 as these channels have the least overlap with channel 6.
  2. The second setting is is turn on UPNP.

Hope it works for you.


The WiFi was set to 802.11b/g/n tried to put it as b/g

Reset sonos 5

New password 

New name on wifi

Still same problem. The sonos 5 claim its the wrong password, it's not. 

Trying also to re do the whole setup. The app can't find the speaker (green lamp) 

Btw, it did work before, this happened the other day and now I can't make it wire less. Any other suggestions? 

Userlevel 7
Badge +23

Make sure the router supports 802.11b/g - if it is set to 802.11 N-only then Sonos won’t connect with a password error.

By the way disabling 5GHz will not affect surround sound Sonos devices, they use their own network, not your router’s.


Disable 5g - no success

Change passwords - no success

Still saying its wrong password when it's not

New diagnostic report 681472499

But how do I solve the problem? My sonos 5 gen 2 keep insisting it's incorrect password when it's not.

What do I do?


Diagnostic report 438006721


Userlevel 5
Badge +14

Hi @Gustav_l.

Welcome, thank you for reaching out to Sonos Community, I totally understand where you're coming from and I’m here to help.

I suggest not to turn off the 5Ghz the reason behind that is this can be used for Sonos home theater speakers.

Also, other electronic devices like tablets, phones, laptops can also use 5ghz. 

But if you really insist I suggest contacting your cable provider or the manufacturer of the router.

If you need help with any other information, please be sure to let us know.

Got the same problem.

Ok, but how do I disable the 5G on the router? 

I had this yesterday. I have 2 x Sonos One in separate rooms. One unit initially developed a patchy wifi connection then completely lost connection - the other unit followed suit. Tried reconnecting but “Wifi Password Incorrect” came up along with an Error code 1001.

Removed the wifi (forget the network) and tried a reconnect, same thing, unplugged and replugged - same. Did a factory reset - same issue. 

Worked fine through ethernet cable during this time. 

Turned wifi off fully at the router for 5 mins and tried again - was able to connect to the Wifi straight away and everything now working fine again. 

SO - despite not changing anything and everything else in the house working fine, i do recommend turning your router off and on before doing anything else. 

Userlevel 7
Badge +17

Good that it worked for you, but disabling the 5Ghz network should not be necessary to get Sonos to work.

I experienced this issue on a new Sonos 5. It was a pain to figure out but disabling the 5Ghz network did the trick. This is a huge problem for users who don’t know much about advanced settings. Sonos please fix this. Very disappointed in the amount of time it took me to figure this out.

Userlevel 7
Badge +17

So not a Sonos problem at all then….. The one case where the Sonos help stating you are using the wrong password is actually true.

I just found a possible problem/solution on this enraging problem after reading about the 2.4 v 5 GHz issue. I looked into which frequency our system uses, and found out that 1) our modem uses both, and 2) when my partner reset the WiFi password the other day, she made a slightly different password for the 2.4 GHz and the 5 GHz channels -- one letter was a different case. So I was typing in the password that worked on 5GHz, and it was telling me I was entering the wrong password when I knew I wasn’t. Problem solved as soon as I located and entered the right password. 

Please check if you router is on 2,4 GHz wifi. If so, is it on 2,4 GHz b/g/n, not “n only”, or as stated above “change (Wifi) to allow all types of 2.4Ghz”.

This worked! Thanks so much! 👏🏻

Userlevel 7
Badge +17

Please check if you router is on 2,4 GHz wifi. If so, is it on 2,4 GHz b/g/n, not “n only”, or as stated above “change (Wifi) to allow all types of 2.4Ghz”.

Hi, wonder if you can help? I have the same problem with the password being incorrect. Rogers recently upgraded my modem and now the only thing that doesn’t work is Sonos. I’ve tried unplugging, resetting etc as above but nothing has worked. I have the Ethernet in but would like the WiFi to work again. Any help much appreciated!

I am not too sure but it suddenly started working which I assume was the WiFi change to allow all types of 2.4Ghz types and/or the reboot.  THANK GOD but I am still out 3 hrs today

I guess I said it wrong, my is a Sonos One Gen2.  Just came in the mail today.  I went into my WiFi modems settings and am trying different things but now I can’t seem to even communicate with it so I am trying to reset things back

Because it doesn’t know the new SSID and password until you wire it directly to the router with an Ethernet cable, would be my guess. The PLAY:1 does not have the same BLE that the Sonos One does due to its age, so there’s no way to transfer the new network information to it until you wire it directly. Once it has the new data, it should connect wirelessly to the 2.4Ghz b/g network. 

I just got Play One as a 10yr gift from work and can’t get Wifi working due to the Incorrect Password issue.  Spend a couple hours now trying the various recommendations.  A dozen devices up to 10yrs old work on it so why doesn’t a brand New Sonos product work?  Our Telus Wifi has a smart feature that does 2.4 or 5 so I am puzzled why it won’t connect wirelessly using my current WiFi password.  If I could return this product I would

I just purchased a playbase and ran into the same issue.  I was able to work around the issue by setting up an older wifi access point in legacy 802.11bg mode.  It seems the device cannot connect to a 802.11g network.  Hope this helps.

Hello @Bfish. Welcome to the community. Please submit a diagnostic report of your system, while your Play:5 is wired to the router with an Ethernet cable. Once that is done, please reply back to this thread with the confirmation number so I can take a further look for you.

@Alex_uhh, were you able to submit a diagnostic report as well? If so, could you also provide your confirmation number?

I’m having the same problems at @sneakmeister @Alex_uhh can you help me too Sonos. Already plugged in to Ethernet and wired it works fine but will not accept my WiFi password so I can move it back to original location. 

Try rebooting your router, mobile controller and All Sonos devices. Switch off (temporarily) any other wifi Access points, extenders, repeaters, or secondary Hubs.

On reboot of the devices, check that the mobile controller device has re-connected direct to the routers 2.4ghz WiFi.

Next re-enter the 2.4ghz Wifi credentials (case sensitive) in “Settings/System/Network/Wireless Setup” in the Sonos App. 

If that still does not work....

Perhaps change the 2.4ghz password on your router and remove/avoid any ‘unusual’ characters and stick to an alphanumeric case sensitive password, then reboot the router again and reconnect your mobile controller device to the wifi using the new credentials. 

Then try entering the new password again in “Settings/System/Network/Wireless Setup” in the Sonos App.

If that works, you can then go onto change the password on all your other wireless devices connected to your 2.4ghz wifi network.

It’s sometimes worthwhile to perhaps change the WiFi credentials, from time to time anyway, for added network security.

I’m having the same problems at @sneakmeister @Alex_uhh can you help me too Sonos. Already plugged in to Ethernet and wired it works fine but will not accept my WiFi password so I can move it back to original location.