Sonos One disconnected overnight "WiFi password incorrect" fix.

  • 20 October 2019
  • 30 replies
  • 18524 views

Dear Sonos-ers!

TLDR;

Issue; “Incorrect password” for wifi set up even though you enter the right password.

Fix; 

“Incorrect password” → Factory reset → Ethernet to router → create new router password for network on router → set up speaker again with Ethernet still in → “create wifi network” via app → Enter your new router created password → should work!
I am creating this as hopefully my first and last post on this community thread.

=============================================

I have spent the last 2 hours troubleshooting this issue, so creating this in the hope that this helps you further. Hopefully this will improve my karma!

I went to sleep last night with the Sonos One speaker working perfectly, with a smile in the corner of my mouth. Waking up, the Speaker was essentially a brick, went through the “whats wrong” troubleshooting several times via the app to no positive effect.

Then, I eventually got the “enter your wifi” option, entered my password, and got “password is incorrect”. I thought I might have missed a character, then realized no, I wasn’t at fault here. I even used “forget network” on my phone to make sure the password did work.

So I went to the extreme of connecting the sonos via Ethernet(digging through several drawers) and connected and…. yes it sprung back to life!

I was so puzzled, the wifi was not working, but the Ethernet was. So I searched this, and went through several threads, filled with raging sonos users, and others using the classic “have you turned it on/off” trick. 

So finally, I logged onto my router, changed the password on it for the entire network .

Then, I factory resetted the Sonos One (steps in other articles), Ethernetted the speaker again, and then via the app, I used the “create wifi network” option. 

I entered the new password and HALLELUJAH it worked!

Why changing the password on the router worked, or why it somehow stopped working overnight, is a puzzle to me. I did go through some firewall settings on my laptop, I was messing with Stream what you hear, but not sure how they could have effected things here?

Anyway, I went through this pain so you don’t have to!

Great speaker, amazing mind blowing sound and features, but Sonos if you are reading this;

  1. No compatability with Windows audio? Why? This should be such an easy solution. Why only Airplay2/Apple compatability? I would like to not think this is some sinister way to get us to buy sound bars and other products?
  2. The community threads are a mess here, I don’t understand why they are allowed to be a forum for people to kill each other. Toxic users should be pruned, it makes for a terrible experience having to search through them. Like look at the replies on this; https://en.community.sonos.com/troubleshooting-228999/sonos-says-network-password-is-wrong-only-its-sonos-which-is-wrong-6831182
  3. After factory reset, the sonos controller DELETED all my presets and favourites, yeah again, this should be an easy fix!

Anyway, happy to have this up and running, and really enjoying the experience (now!).

Thanks,
Philip


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

30 replies

Userlevel 7
Badge +23

Logins have been an issue for routers that have 802.11b/g disabled (ie 802.11n-only).

OK, if I factory default the Play:1, conect direct to router with ethernet. Configure the Wireless Password while connected using the ethernet, then remove the ethernet and reset, it DOES login to the Orbi WiFi and I can stream again.

Halelujah!

Hi, I had the same experience today, just woke up and no speakers were connected to WiFi, powering off and on did not help, etc.  Play:1 and Play:5 on S2 12.1.

Plugging in a network cable and deleting / attempting to rejoin the network only resulted in WiFi password incorrect, even after a factory reset.

I eventually solved after finding this thread.  Had to disable 5GHz (make it 2.4GHz only) on my WiFi network, then I was able to join OK.  Have since re-enabled 5GHz and restarted the speakers and they join OK.

If it happens again I guess I’ll just setup a separate SSID as a 2.4GHz only network for Sonos.

My router, switch and AP are all UniFi gear, if it makes a difference, but sounds like this is happening to everyone.

Userlevel 7
Badge +17

If there is, and enough people call it in, I'm sure Sonos will notice it….

I did see some posts about Sonos being able to connect to 5Ghz networks, so maybe that happened when the 2,4Ghz network was shut.

If there is some incompatibility with authenticating on 2.4GHz on Orbi systems then there ought to be some kind of application note made available for us!

Userlevel 7
Badge +17

I did see some posts about Sonos being able to connect to 5Ghz networks, so maybe that happened when the 2,4Ghz network was shut.

I don’t think that you can “I have switched off Ethernet b/g/n 2.4 GHz network on my Netgear Orbi router.”

You can disable the SSID Broadcast, but that just leaves the 2.4 GHz network not broadcasting its name. The wireless network is still there and devices can still connect to that network.

So I can’t see this as a solution to the problem of Sonos Play:1 not connecting to a Netgear Orbi mesh network.

I wish I could solve this problem once and for all for me!!

I blogged about my issue here

https://digitaldavo.wordpress.com/2020/10/10/sonos-play1-wont-authenticate-to-netgear-orbi-password-incorrect/

Userlevel 5
Badge +14

Hi @Mountainhippo.

Welcome, thank you for reaching out to Sonos Community and sharing your workaround in fixing your problem with the wifi password incorrect.

with the newer release of the S2 application, this link will give you some idea why Sonos created the S2 application.
 

If you need help with any other information, please be sure to let us know.

Had exactly the same issue. Repeated hard factory resets of my Sonos One (which had worked for a couple of years fault free then just dropped off the network) did not work. Went through the reset, add, password incorrect, connect to ethernet, device not found loop enough times to scream. 

Rebooted router. No effect.

Edited access control tables of router to delete MAC address of Sonos One. No luck

In the end, having read this thread, I have switched off Ethernet b/g/n 2.4 GHz network on my Netgear Orbi router. 

Sonos One then miraculously no longer reports incorrect password and is working perfectly.

Gearing up to see what happens when I switch 2.4GHz back on

Would be fair to say that I am underwhelmed by Sonos’s crappy support site and even crappier error messages. But massive kudos to this community for suggesting some stuff that actually appears to work.

I was a huge fan of Sonos in the old days. But quality control has dropped, the forced upgrade fiasco left a really sour taste in the mouth (even though they rowed back from their hard line eventually) but this is certainly not the amazing “just works” kit that it used to be.

I’ve got 8 Sonos devices of various flavours, so migrating to something else is going to be tough, but sadly I’ve had to start thinking about it.

 

10 months later and I am having word by word the same issue, the only exception being I’m using a S1.

 

This is nonsense, no other product requires me to change my router password. I have it working cabled at the moment and will give a few days in hope for an update before getting over the product.

So what the hell do I do if I keep getting the password incorrect error and none of these tips have helped? 

 

I’ve wasted hours trying to fix this now. Seriously, how incompetent do you have to be to just display the same error message for different problems. There’s no reason to do that, it only leads to frustration. 



I wish I could give a good answer.  They released a whole new version update to their app and it did NOTHING to solve this issue.  I deal with this *all of the time* - it’s beyond frustrating!

So what the hell do I do if I keep getting the password incorrect error and none of these tips have helped? 

 

I’ve wasted hours trying to fix this now. Seriously, how incompetent do you have to be to just display the same error message for different problems. There’s no reason to do that, it only leads to frustration. 

Sonos is a FKN joke. Seriously, it can not negotiate frequency bands properly but would rather tell you that the "password is incorrect".

 

The latest update was done by a bunch of amateurs. It is shocking to see a listed company with such a small product range being unable/unaware that wifi does not only exist on 2.4GHz. 

 

Added to that the fact that, statistically speaking, it is highly improbable that only myself and the few people that mentioned the issue here, have this issue. Fix your FKN code Sonos.

 

 

 

 

 

 

Guys, Sonos isn’t going well with WiFi range extenders. Switch over to SonosNet by wiring a unit to the router (the left one, if it's a stereo pair ; don’t use the Sub or speakers that are set up as surrounds for that purpose)

 

  1. Unplug the range extenders / powerlines during the changeover
  2. Wire one Sonos component to the router (see above)
  3. Remove the WiFi credentials from the system: On iOS or Android: From the Settings tab, tap System > Network > Networks. Select the WiFi network you'd like to remove, and tap Remove. Subsequently wait about 10 min, then go to Settings → System → About my Sonos system and see if WM:0 is being displayed next to each unit

  4. If yes, plug the extenders / powerlines back in

When I go into System > Network > Networks, it just shows mine but has it as IN USE and I can’t select it to remove like you express.

Guys, Sonos isn’t going well with WiFi range extenders. Switch over to SonosNet by wiring a unit to the router (the left one, if it's a stereo pair ; don’t use the Sub or speakers that are set up as surrounds for that purpose)

 

  1. Unplug the range extenders / powerlines during the changeover
  2. Wire one Sonos component to the router (see above)
  3. Remove the WiFi credentials from the system: On iOS or Android: From the Settings tab, tap System > Network > Networks. Select the WiFi network you'd like to remove, and tap Remove. Subsequently wait about 10 min, then go to Settings → System → About my Sonos system and see if WM:0 is being displayed next to each unit

  4. If yes, plug the extenders / powerlines back in

I replied previously - I was having the “password incorrect” message problem with the Beam even though I have never had issues with the other Sonos products I have! 
 

I was able to get the Beam working again after doing factory reset by:

1. turning off the device, pressing the “reset” button (looks like the infinity symbol)

2. plugging back in the device and holding the reset button for 30 more seconds.
3. After that, I set up as a new device.

 

The above worked for a day but the device disappeared from the Sonos app a few hours later.

 

Has anyone reached out to Sonos support yet? I’m afraid that we might have to trade this device for one that might be more tested.

I have this problem every time the power goes out. I have a Sonos Beam and three Sonos Ones throughout the house.  When the router comes back on following a power outage, it typically finds only the Beam and two of the Sonos Ones.

One time, I got the third Sonos One back online by plugging it into an Ethernet cable from the router. This was after I kept getting the “incorrect password” response as indicated in prior posts.  But somehow, plugging it into the router was all that it needed.

But yesterday, it was much more difficult, and it wouldn’t respond to the Ethernet method. I tried to get the Sonos App to “find missing product,” but it kept telling me I had the wrong password. Ultimately, I had to disable the 5GHz frequency on my router In order to get it to recognize the password.  At that point, though, my WiFi extender wouldn’t work.  So I had to turn the 5GHz signal back on, but thankfully, the Sonos One has continued to work.

It appears that some trial and error is what it takes to get these things back online.

Having this issue with the Beam. Installed it and worked fine yesterday. I have tried troubleshooting - the Sonos has created its own network - but I get an error that says the wifi password is incorrect even though I can log into the same network with the password. Will give this a try! Thank you.

What worked for me is disabling the 5 ghz network on my router (it has 2 antennas for 2.4ghz and 5ghz, both with the same ssid and password). After disabling it the Sonos box immediately accepted the password that it had rejected multiple times before.

 

I already had the 802.11 "mixed" (a/b/g/g/n) activated, so that was not the solution for me. 

 

The most frustrating part of the whole experience is that Sonos keeps telling you that the password you entered is wrong and doesn't offer any other option then to try again. And apparently there are quite a few things you can try to get it to work. 

This took me days to figure out unfortunately. Thanks to all before me... What worked for me: hooked up Sonos to Ethernet, checked channel setting in Sonos app network settings. It was set to 6. Then in router, updated firmware, set WiFi network mode to "WPA mixed" and channel number to 6. Tada...

Badge

In Wifi router for 2.4 GHz set channel to 6 or 11 (instead of Auto). This has worked for me.

Pawelb is my hero. Once I figured out how to find/change this setting in my router. Voila!  Accepted correct password and Sonos working on new router. 

On Router I had permanently set 802.11n and SONOS did not pass my correct password. After the change to "mixed" (a/b/g/g/n) the application immediately accepted the network password.

 

Hi,

I would like to thank you Pawel for your tip. It works for me like a charm.
Changing to mixed was the only think I had to do.

I had the wifi password incorrect problem with my Sonos One. I called Sonos for support but they were unable to debug my problem.  They finally said it was a router problem or maybe it was interference from my cordless phone.  I tried putting the Sonos One on a guest network but that didn’t work either. I finally decided to reboot the router (I didn’t want to do that since every other wifi device was working fine) but the reboot fixed the incorrect wifi password issue.  I didn’t have to change the wifi password.  

Userlevel 3
Badge

I had this issue as well, and tried the above to no avail.  What worked was creating a new SSID with open authentication, factory resetting the play 1, connecting it to the new SSID, then adding mac authentication to the new SSID.  Hope this helps someone.