Answered

Shell Energy / Technicolor router compatibility

  • 8 August 2022
  • 5 replies
  • 128 views

Hi, I recently switched broadband to Shell Energy following a house move.  They supplied a Technicolor DGA0122NLK router. I have two Play 3s.  Music will play perfectly for 5 to 8 minutes before stopping.  Error messages include ‘Song not encoded properly’ and ‘Wi-fi connection unstable’.

Are there any other Shell Energy or Technicolor router users who’ve had similar problems and have found a fix? 

Thanks in advance.

icon

Best answer by Ken_Griffiths 8 August 2022, 15:53

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

If the Sonos products are using your router WiFi and not SonosNet, then maybe try a different 2.4Ghz WiFi channel on your router - the best channel to use is usually a ‘fixed’ non-overlapping WiFi channel 1, 6 or 11 and if the router allows, set the channel-width to 20Mhz only, as that may help improve things too.

Those type of errors might also indicate a duplicate IP issue, although depending on the lease renewal settings, that should go away at some point. However, there may be a case for a simple network refresh, by unplugging all your Sonos devices from power, and then rebooting your router. Once the router comes back up, you can plug back in your Sonos devices. 

OMG!! this is also happening to me. Shell broadband telephone technicians, bless them, are useless. 
I have change Sonos to 2.4 Ghz but the same thing happens. I keep rebooting the router and again, it works 5 to 8m and then stops. I don't know what to do next. any help. Im

OMG!! this is also happening to me. Shell broadband telephone technicians, bless them, are useless. 
I have change Sonos to 2.4 Ghz but the same thing happens. I keep rebooting the router and again, it works 5 to 8m and then stops. I don't know what to do next. any help. Im

I see you have switched the players to the 2.4Ghz band, but did you set that to a non-overlapping channel 1, 6 or 11?

Also, if the router allows, set the channel-width on that band to 20Mhz only to reduce interference. If the problems persist after doing those things, then I would try running your speakers on their SonosNet connection instead simply by wiring one Sonos product to your router but keep it at least one metre away from the router. It maybe worthwhile rebooting all the Sonos players too after wiring the one device.

Yes the exact thing happens to us since we got shell router … I’ve tried restoring factory settings, I’ve changed 2.4 wifi channel multiple times - nothing changes it. I get approx 5 mins then it pauses and kills the internet