Question

S1 controller gives message that "Bridge needs Update" but update fails

  • 25 November 2022
  • 5 replies
  • 31 views

I set up new S1 system with a ZP90 that I had at my lake cabin. The controller gives the message “Bridge needs an update”. When I attempt to update, it fails immediately. I will add that the controller says (unused) next to it on the app. However, my system is basically functioning from the mobile apps. It will not function from the PC app. I cannot use the bridge to add a product. I have to connect another component to the router to add to the system. I also am unable to register any products as long as the bridge requires an update. How can I get the bridge to update so I can get full system functionality?

Bridge     ZP90   Sonos One (Gen2)


5 replies

Userlevel 7
Badge +21

Why are you wanting to use the Bridge?

It is likely the Bridge power supply has partially failed, you could try replacing it but you’d be better off to just quit using the Bridge.

My first question is, why do you need the Sonos Bridge? - it sounds like you are possibly running the setup in WiFi mode?

Anyhow…

  • Are the lake cabin WiFi credentials stored in the Sonos App network settings? or ..
  • Do you have the ZP90 wired to your router?
  • Have you tried wiring both devices to the router and then trying to update the Bridge?

I’m a little confuse on the responses that question my use of the bridge. It was my understanding that S1 systems require one component to be wired to the router. I have confirmed that with this system. No CAT6, no Sonos network.

Userlevel 7
Badge +17

Sonos has not needed a component wired to the router since around 2014: https://rainnews.com/sonos-simplifies-its-wifi-speakers-ditching-the-ethernet-cable/

YeahThatGuy,

It depends on the age of the documentation you are reading. Originally at least one wired unit was required. The BRIDGE was used in situations where it would be inconvenient to wire a player. The competition dumped on SONOS, accusing SONOS of lying about being “wireless”. The competition forgot to mention that the SONOS approach was very reliable compared to the not so reliable competition’s approach. At one point SONOS was giving away BRIDGE’s, but the competition still dumped on SONOS. Eventually, SONOS gave in and enabled WiFI. It was a cheap trick for SONOS and it instantly deflated the competition.

Anyway, most of the regulars here prefer the SONOS wireless approach (SonosNet) rather than WiFi. SonosNet requires one or more wired components and the system will automatically switch to SonosNet after a wired unit is detected.

In your case there are two, common potential issues. First, the BRIDGE power supply could be causing issues. At this point I assume that this is the case until proven otherwise. If you have a voltmeter, the BRIDGE power supply should measure slightly over 5V. Less than this there will be intermittent, very hard to describe issues. A very simple test is to power down BRIDGE and wire another unit. As others have suggested, you don’t need BRIDGE for SonosNet (wire something else), it’s just a convenience.

Second, if you want to use WiFi rather than SonosNet, I suggest that you power down BRIDGE and temporarily wire another unit. While the other unit is wired, insert the correct WiFi credentials. Now you can disconnect the network cable and use WiFi. But, as I’ve said, I prefer SonosNet. If BRIDGE is EOL (End Of Life) you can replace it with BOOST.

If this does not solve your issues, we’ll need more information about your SONOS system and your network. We need model numbers and layout.

Reply