Here we go again...

  • 19 December 2021
  • 67 replies
  • 1002 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

67 replies

Userlevel 1
Badge +3

The physical setup here is as follows:

Main house

   WiFi router wired to incoming internet, WiFi network named “HOUSE”

   PLAY3 connected to router

   Three other PLAY3 units setup earlier.

   One is the main house, two in the Casita

Casita

   A WiFi extender wirelessly connected to “HOUSE” and generating two networks “HOUSE_2G” and “HOUSE_5G”

   Two PLAY3 units, setup without issues earlier, setup in the Casita 

   ROAM setup a few minutes ago - message in app said it was being connected to “HOUSE_2G”

   The phone itself, while in Casita, was auto connected to “HOUSE_2G” (the strongest signal when in Casita).

 

The credentials are identical for all three wifi networks.

   

 

 

 

The ‘wifi repeater’ should ideally have the same SSID/Password/WiFi Channel and channel-width (20MHz preferably for 2.4Ghz band) as your main router.

If you have different SSID’s for your WiFi network, at the very least you will need to add those to your Sonos App network settings (see screenshot example), but I think you’re much better off ‘mirroring’ the WiFi of your router (same SSID’s etc.) on your repeater.

 

   A WiFi extender wirelessly connected to “HOUSE” and generating two networks “HOUSE_2G” and “HOUSE_5G”

   Two PLAY3 units, setup without issues earlier, setup in the Casita 

   ROAM setup a few minutes ago - message in app said it was being connected to “HOUSE_2G”

   The phone itself, while in Casita, was auto connected to “HOUSE_2G” (the strongest signal when in Casita).

 

The credentials are identical for all three wifi networks.

  

So just to clarify, is your router WiFi called HOUSE_2G (2.4Ghz band) and HOUSE_5G (5Ghz band) and is this the same as your repeater SSID’s? (They should be the same). .. if you add devices to your 2.4Ghz band, I would also the 5Ghz SSID to your Sonos App network settings too and ensure each separate band on your router and repeater are on the same channels, so as an example you might have…

HOUSE_2G SSID on both router and repeater set on channel 11 (20MHz channel width)
HOUSE_5G SSID on both router and repeater set on channel 48 (20/40/80MHz channel width)

and both SSID’s listed in your Sonos App network settings. 

In the above example, don’t forget when using SonosNet for your non-portable Sonos devices, to set the SonosNet channel in the Sonos App, so it’s at least 5 channels away from your chosen 2.4Ghz WiFi channel... so in this (example) case you would set SonosNet to channel 1 or 6 …and not 11.

Userlevel 1
Badge +3

 

   A WiFi extender wirelessly connected to “HOUSE” and generating two networks “HOUSE_2G” and “HOUSE_5G”

   Two PLAY3 units, setup without issues earlier, setup in the Casita 

   ROAM setup a few minutes ago - message in app said it was being connected to “HOUSE_2G”

   The phone itself, while in Casita, was auto connected to “HOUSE_2G” (the strongest signal when in Casita).

 

The credentials are identical for all three wifi networks.

  

So just to clarify, is your router WiFi called HOUSE_2G (2.4Ghz band) and HOUSE_5G (5Ghz band) and is this the same as your repeater SSID’s? (They should be the same). .. if you add devices to your 2.4Ghz band, I would also the 5Ghz SSID to your Sonos App network settings too and ensure each separate band on your router and repeater are on the same channels, so as an example you might have…

HOUSE_2G SSID on both router and repeater set on channel 11 (20MHz channel width)
HOUSE_5G SSID on both router and repeater set on channel 48 (20/40/80MHz channel width)

and both SSID’s listed in your Sonos App network settings. 

 

Hi Ken,

The main router - wired to the external internet is named HOUSE (not really it’s name but you get the idea). The extender - situated in our casita - exposes two networks HOUSE_2GEXT and HOUSE_5GEXT

Naturally these two networks provide a stronger signal to devices situated inside the casita like my desktop PC and a TV etc as well as portable devices people bring into the casita.

As for the specific RF channels used, I’ve simply never looked at these and have no idea what they are set to, I haven’t even “logged in” to either the router or extender for years!

 

Also bear in mind the ROAM was working fine most of the time until yesterday’s running around, the only difference now is that the BRIDGE has gone and one of the PLAY3 units is wired to the router (HOUSE).

I wasn’t aware about any sensitivity regarding specific RF channels, is there a doc somewhere?

Thx

 

 

 

 

Userlevel 1
Badge +3

The sonos app on the iPhone, under “Network” says:

Manage Networks   >

SonosNet Channel  >

Channel 1

 

Clicking the “Manage” arrow, lists the single name:

HOUSE_2GEXT

there’s an Update Networks option too, it displays:

“Do you want to add a trusted network to Sonos or make a change to an existing network?”

I really have no idea where this leads or whether any of this plays a part with the ROAM misbehaving.

 

 

Userlevel 1
Badge +3

I can’t find a manual, detailed documentation on the S2 app, anywhere, even this just talks about what the app is used for but not the meaning of numerous features and options.

Userlevel 1
Badge +3

This is a huge problem IMHO, with modern computer centric products. The user is often compelled to resort to experimentation, trial and error using a mix of judgement and experience to resolve issues.

Familiar questions like “did you try resetting” or “did you pull the power cord” or “have you tried resetting your router” and so on.

These really indicate to me that the company - Sonos - does not have a firm grip on the technology, not sufficient anyway to make customers lives much easier.

I’m a competent software engineer, decades of experience and a former hardware engineer with significant experience of radio, audio, radio, digital and analog electronics and even I get frustrated like hello with all this.

It seems Sonos just don’t care, it’s not important and can I blame them? most computer based products today are like this, designed to work easily for the simplest configurations but simply not caring when things are out of the ordinary.

The crazy thing is that if Sonos did invest more effort in these areas they’d start to reap benefits like:

  1. Customer support calls would be both fewer in number and less difficult to resolve.
  2. Their own staff would benefit in their ability to test these products as they enhance them.

For example a “debug sonos” app or mode might be hugely helpful in that it could gather lots of data about the user’s network(s) channels, attached devices etc etc etc and make it much easier to identify conflicts or poorly set configuration.

If my ROAM doesn’t appear in my S2 app then why not leverage the fact that the app was able to communicate with the ROAM because I was able to go through the ROAM setup? Why can’t the app connect to the ROAM over bluetooth and interrogate it as a an aid to understanding the problem?

There is no way at all that I can “see” inside the ROAM to see what it is doing or anything.

Perhaps its time to run the old Intel UPnP power tools...

Userlevel 1
Badge +3

The ROAM certainly is not accessible or not responding to UPnP probe messages:

 

Every UPnP device on the network should have responded to the UDP probe requests that thos tool just sent...

Userlevel 1
Badge +3

I reran the ROAM setup from the iPhone app and during that I used the spy tool to rescan the network. At no point did the ROAM appear on the network, not even after the iPhone said that device had been connected to HOUSE_2GEXT.

Userlevel 1
Badge +3

OK here’s some details:

This is the wifi settings for the main house router, I don’t care that you can see the SSID name, I’m past caring!

 

Here are the settings for the extender a Netgear WN2500RP:

 

These are the settings that have been in place for several years.

 

Userlevel 1
Badge +3

The SonosNet channel in the iPhone S2 app is set to 1 and I think it has been throughout this excercise.

Userlevel 1
Badge +3

I tried setting up again but same behavior, never appears in System tab of S2 app.

Here’s a source of confusion for me, the iPhone connects to the strongest SSID so that varies as I move from house to casita.

The S2 app also has network settings and I have no idea what this mean, in my app it says under Network Settings one network - HighChaparral_2GEXT

What is this? the app runs on the phone so will leverage its internet services, so why does the app even care about SSID? 

If two of my PLAY3 devices are in the house near HighChaparral and the other two are in the casita near HighChaparral_2GEXT then why does the app list just a single SSID? what does the app do with that SSID? 

I can see Update Networks and when I select that I get a question about do I want to add a trusted network and so on, if I click Yes it says “Make sure all your products are powered on, this could take 1 - 2 minutes”.

I’m concerned that this might upset the entire system after all the effort it took to get the PLAY3 devices connected.

Without documentation for this all and all these options and setting, this becomes a guessing game.

 

I would just call your router and extender access points HighChapparall_2G for their 2.4Ghz bands and set those to fixed channel 11, rather than ‘Auto’. 

Similarly, just call your router and extender access points HighChapparall_5G for their 5Ghz bands and set those to fixed channel(s) too, rather than ‘Auto’.   

Add both bands/SSID’s to your Sonos App network settings as mentioned previously - if problems persist, then it will likely be that SSDP multicast discovery/broadcast is not working correctly over the entire subnet, either between the two bands, and/or between the two different access points, which is not unheard of with a few devices …and there maybe other settings available on your router/access point that ‘may’ need to be set, such as IGMP snooping, or in some cases you may have to enable multicast and broadcast data if that is set to ‘disabled’ on the device by default ( …just as examples of some device settings).

Finally, channel 1 for SonosNet for all the non-portable Sonos devices should be fine.

I hope that information assists.

Userlevel 1
Badge +3

OK I can see that all the PLAY3 devices are connected to the SSID in the house - HighChaparral - despite the app knowing only about HighChaparral_2GEXT.

Even the PLAY3 devices in the casita (where HighChaparral is weak and HighChaparral_2GEXT is strong) are connected to HighChaparral the weaker of the two SSIDs.

Those devices were connected using the phone while I was in the casita too.

This is so so bewildering...

Userlevel 1
Badge +3

I would just call your router and extender access points HighChapparall_2G for their 2.4Ghz bands and set those to fixed channel 11, rather than ‘Auto’. 

Similarly, just call your router and extender access points HighChapparall_5G for their 5Ghz bands and set those to fixed channel(s) too, rather than ‘Auto’.   

Add both bands/SSID’s to your Sonos App network settings as mentioned previously - if problems persist, then it will likely be that SSDP multicast discovery/broadcast is not working correctly over the entire subnet, either between the two bands, and/or between the two different access points, which is not unheard of with a few devices …and there maybe other settings available on your router/access point that ‘may’ need to be set, such as IGMP snooping, or in some cases you may have to enable multicast and broadcast data if that is set to ‘disabled’ on the device by default ( …just as examples of some device settings).

Finally, channel 1 for SonosNet for all the non-portable Sonos devices should be fine.

I hope that information assists.

Thanks Ken, I will play around with this some more, but my wife and I also use the wifi for work and I’m hesitant to make adjustments like this sometimes, hate to mess up everything else that’s working.

So in your experience its fine to have the SSID the same for the router and the extender? (for a given frequency band I mean).

We have TVS and stuff all setup so adjusting these name is possible, it might be my best bet for now to just adjust the HighChaparral_2GEXT in the extender to be named HighChaparral the router also only supports 2.4 GHz.

That way only casita stuff might be impacted and the only 5G access anyway is via the extender so leaving that as is makes sense.

 

 

Userlevel 1
Badge +3

Next year I’m gonna dump that old gateway (DSL, but that’s my only option) and get the newer ones that support 5G too.

OK I can see that all the PLAY3 devices are connected to the SSID in the house - HighChaparral - despite the app knowing only about HighChaparral_2GEXT.

Even the PLAY3 devices in the casita (where HighChaparral is weak and HighChaparral_2GEXT is strong) are connected to HighChaparral the weaker of the two SSIDs.

Those devices were connected using the phone while I was in the casita too.

This is so so bewildering...

Aren’t those non-portable devices using a SonosNet signal? I thought you had one device wired?

I would just call your router and extender access points HighChapparall_2G for their 2.4Ghz bands and set those to fixed channel 11, rather than ‘Auto’. 

Similarly, just call your router and extender access points HighChapparall_5G for their 5Ghz bands and set those to fixed channel(s) too, rather than ‘Auto’.   

Add both bands/SSID’s to your Sonos App network settings as mentioned previously - if problems persist, then it will likely be that SSDP multicast discovery/broadcast is not working correctly over the entire subnet, either between the two bands, and/or between the two different access points, which is not unheard of with a few devices …and there maybe other settings available on your router/access point that ‘may’ need to be set, such as IGMP snooping, or in some cases you may have to enable multicast and broadcast data if that is set to ‘disabled’ on the device by default ( …just as examples of some device settings).

Finally, channel 1 for SonosNet for all the non-portable Sonos devices should be fine.

I hope that information assists.

Thanks Ken, I will play around with this some more, but my wife and I also use the wifi for work and I’m hesitant to make adjustments like this sometimes, hate to mess up everything else that’s working.

So in your experience its fine to have the SSID the same for the router and the extender? (for a given frequency band I mean).

We have TVS and stuff all setup so adjusting these name is possible, it might be my best bet for now to just adjust the HighChaparral_2GEXT in the extender to be named HighChaparral the router also only supports 2.4 GHz.

That way only casita stuff might be impacted and the only 5G access anyway is via the extender so leaving that as is makes sense.

 

In the past all my WiFi access points had the same name/SSID for their 2.4Ghz band - Localnet_2G …and the 5Ghz band was called - Localnet_5G, I didn’t want my ‘Move’ device to use the 2.4Ghz band, so I put that on the 5Ghz band only. I therefore just added the Localnet_5G to my Sonos system via the network settings in the App.. however all my non-portable devices ran on SonosNet, rather than my WiFi - I just mainly used the access points for connecting my controller (and the Move) to the LAN.

Of course network changes can take a while to do sometimes - I’m just offering some suggestions but it’s entirely upto you what bits you choose to take onboard - I’m just trying to provide you with some suggestions, that’s all.👍

I think having the casita 2.4GHz SSID and password the same as that for the main router is the way to go.  Then have that as the only network in the Sonos app.

@Korporal - please then check in the app Settings under ‘About My System’.  All the speakers should have WM=0 next to them (indicates SonosNet) except for the Move, which should show WM=1.

Userlevel 1
Badge +3

OK I can see that all the PLAY3 devices are connected to the SSID in the house - HighChaparral - despite the app knowing only about HighChaparral_2GEXT.

Even the PLAY3 devices in the casita (where HighChaparral is weak and HighChaparral_2GEXT is strong) are connected to HighChaparral the weaker of the two SSIDs.

Those devices were connected using the phone while I was in the casita too.

This is so so bewildering...

Aren’t those non-portable devices using a SonosNet signal? I thought you had one device wired?

 

Yes, that’s interesting I may have been hasty, I just checked again here’s what I actually see:

 

Three zone players connected to the network:

 

Now, this is most odd:

 

According to the router the same three zone players are all connected via ethernet not wifi !!

But only one is connected by cable the other two are definitely connected over wifi, they are in the casita with me now!

So this is the actual status of these.

I am supposing that the wired device is well, wired and the other two are connecting to that unit over the artifical “SonosNet” wifi network that I saw mentioned during setup, that is “mesh” I am guessing, the wired PLAY3 is generating a distinct SSID (but I can’t see it listed on my phone...)

For that reason they appear as devices that are connected via the physical LAN cable, this seems to explain what I’m seeing.

 

 

 

Userlevel 1
Badge +3

This article is shedding more light on this for me too:

 

https://livingspeaker.com/what-is-sonosnet/#:~:text=SonosNet%20is%20a%20type%20of,the%20router%20through%20Ethernet%20cable.

 

 

Userlevel 1
Badge +3

I would just call your router and extender access points HighChapparall_2G for their 2.4Ghz bands and set those to fixed channel 11, rather than ‘Auto’. 

Similarly, just call your router and extender access points HighChapparall_5G for their 5Ghz bands and set those to fixed channel(s) too, rather than ‘Auto’.   

Add both bands/SSID’s to your Sonos App network settings as mentioned previously - if problems persist, then it will likely be that SSDP multicast discovery/broadcast is not working correctly over the entire subnet, either between the two bands, and/or between the two different access points, which is not unheard of with a few devices …and there maybe other settings available on your router/access point that ‘may’ need to be set, such as IGMP snooping, or in some cases you may have to enable multicast and broadcast data if that is set to ‘disabled’ on the device by default ( …just as examples of some device settings).

Finally, channel 1 for SonosNet for all the non-portable Sonos devices should be fine.

I hope that information assists.

Thanks Ken, I will play around with this some more, but my wife and I also use the wifi for work and I’m hesitant to make adjustments like this sometimes, hate to mess up everything else that’s working.

So in your experience its fine to have the SSID the same for the router and the extender? (for a given frequency band I mean).

We have TVS and stuff all setup so adjusting these name is possible, it might be my best bet for now to just adjust the HighChaparral_2GEXT in the extender to be named HighChaparral the router also only supports 2.4 GHz.

That way only casita stuff might be impacted and the only 5G access anyway is via the extender so leaving that as is makes sense.

 

In the past all my WiFi access points had the same name/SSID for their 2.4Ghz band - Localnet_2G …and the 5Ghz band was called - Localnet_5G, I didn’t want my ‘Move’ device to use the 2.4Ghz band, so I put that on the 5Ghz band only. I therefore just added the Localnet_5G to my Sonos system via the network settings in the App.. however all my non-portable devices ran on SonosNet, rather than my WiFi - I just mainly used the access points for connecting my controller (and the Move) to the LAN.

Of course network changes can take a while to do sometimes - I’m just offering some suggestions but it’s entirely upto you what bits you choose to take onboard - I’m just trying to provide you with some suggestions, that’s all.👍

 

Thanks Ken, I do appreciate your help here, despite my grumbling, none of that is directed at you of course, just expressing my frustration!

 

Thanks

 

Userlevel 1
Badge +3

I think having the casita 2.4GHz SSID and password the same as that for the main router is the way to go.  Then have that as the only network in the Sonos app.

@Korporal - please then check in the app Settings under ‘About My System’.  All the speakers should have WM=0 next to them (indicates SonosNet) except for the Move, which should show WM=1.

 

OK they do all have WM:0 (all three) as for the ROAM that is yet to appear, it has not appeared on the network despite many attempts.

I’ll do as suggested later, rename the extender SSID for 2.4 GHZ to be the same as main gateway’s SSID (they already share the same password).

 

Thx