Zoneplayer S5 - Not able to set it up with the controller

  • 13 August 2018
  • 1 reply

  • Contributor I
  • 0 replies
Hi, I have a Sonos Zoneplayer S5 that I am trying to use after a gap of 5 years and having changed countries - UK to India. while it was working fine in UK, I have been unable to set it up using the controller app on iOS. I have tried both the options - setting up as a new system or connecting to an existing system ( as it was set up before). Also I have tried connecting the player directly to my router with which my iOS device is also paired - again no luck. The Sonos controller keeps on saying 'unable to find the speaker', Did a factory reset as well, again with no results. Any help/guidance will be appreciated. Thanks

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

If it wasn't in use for a period of 5 years then the installed device firmware version must be ancient and probably isn't compatible with your updated controller app version. Give Sonos support a call to see if they can remotely push a firmware upgrade to your player.