Speakers cut out with turntable/TV

  • 20 June 2018
  • 6 replies

I recently bought a turntable and am using Line In to a new generation Play:5. Other speakers in my apartment (Master Bedroom, Master Bath, plus others) cut out regularly. I've changed the channel to all other options, still the same. I've reordered the Rooms to use the Play:5 first as well as the Living Room, same problem.

This also happens when I watch TV and try to stream the audio to all other speakers. Any other audio options (SiriusXM or Spotify) work just fine and never cut out.

The diagnostic I just ran is 1873011857.

For reference, I was troubleshooting the TV audio problems in December last year with Mitchell. The reference for that issue (never resolved) was 171205-002379.

I live alone so it's not other users consuming wireless bandwidth. I'm running 5GHz only and don't need 2.4.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7
Badge +19
Hey, cameronross. Thanks for posting. Typically audio cutouts are from problems regarding connectivity or latency on the network. The diagnostic report you submitted was either incomplete or corrupt which tells me that there was trouble getting the information to/from the Sonos system on the network. Could you tell us a little more about your home network? What is the make and model of the router you are working with? Are any Sonos devices plugged into the network via Ethernet cable? Feel free to submit another diagnostic report and I will be happy to take another look.

Thanks in advance.
Hi Keith

I use a latest-generation Apple Airport Extreme operating on 5GHz only. There are no 2.4GHZ devices. I don’t use any other extenders or APs. I am open to switching over to some mesh setup if you think that will solve this issue.

I’ve been running diagnostics from my Mac but I ran another from my iPhone in case the connectivity works from there: 1968059326 This was just after the issue occurred using Line-in to my Office Play:5 as the audio controller. The cut outs are particularly bad on the Living Room setup as well as Master Bedroom and Master Bath.

Userlevel 7
Badge +19
Thanks for the fresh diagnostic report, Cam. It seems that the Office Play:5 is having a hard time getting the signal from the TV/Turntable to the rest of Sonos. Your Sonos system is set up in the Boost configuration, which is great. This allows Sonos devices to speak player-to-player in a "Telephone" like fashion. The challenges come into play when using Line-In. In this case, the source is connected to one of the Sonos players, rather than being fed to Sonos through the Boost. This means your signal (turntable / TV) needs to be sent wirelessly to the Boost, and then back to the Office player which is responsible for feeding the rest of the group (your entire household). All while each connection dealing with the wireless interference between the two points.

That being said, I typically find it a good rule of thumb to plug in any line-in device into the local network using an Ethernet cable. This will ensure that the player responsible for feeding the rest of Sonos has a solid connection to start with. At that point, it is down to the wireless environment in your location.

Is this possible? Even if for a quick test? Thanks!
I had submitted an email of this issue to Support as well. Someone there got back to me and asked me to change the compression setting to Compressed. I had been using uncompressed and/or Automatic. It seems better for now. There have been a couple of drops especially when I'm streaming the TV to the whole apartment but not as many as before.

I can try the ethernet cable to the Play:5. I know I've tried that before on my own and Sonos told me to disconnect it. It was causing some confusion while the other products were operating wifi. I may wait and see if the cut-outs start to come back more frequently. Then I'll be able to tell if the hardwire approach solves anything.

This is only a 1,000 sq. ft. apartment. I realize the structure and my neighbors' wifi networks can interfere. Not sure if you see better performance when users have a 3 station mesh network setup? I'll switch to whatever gives the best results.

I was having a similar problem with music dropping out when being played from my Chromecast Audio through the line-in, where music played from Sonos or Spotify Direct played perfectly. Found a solution that fixed the problem for me. Try this:

Go to the LINE-IN settings for the room where the line-in speaker is used, and change the name of the Line-In Source Name to "AirPlay Device". The Line-In Source Level may change to 4, but you can change it back to what you want after the source name has been changed. Apparently this is an undocumented feature that increases the buffering of line in inputs.

It worked for me. Good luck.
I see this is an older post. But I thought I would add I was having a similar issue with a turntable on the line in cutting out to the newest speakers I added. I tried the solution above setting to airplay device. Worked, no more cutting out. It was previously set to turntable.