Answered

Sonos Sub too far from AMP


Badge
  • Trending Lyricist I
  • 13 replies

I am wanting to set a sonos sub up in a room where i have ceiling speaker connected to a sonos Amp.

The Amp is in a closet where I have a “home run” setup.  It seems the Sub is too far from the AMP to get a signal from it in the room, I can move it to a different room, closer to the Amp and it will work.

 

Evidently the sub talks directly to whatever its paired to and not separately like other sonos speakers.

 

Is there any way to get a better signal to the Sub?  current setup is WM:1

 

thx

icon

Best answer by Jean C. 5 April 2020, 19:20

Hello @Mayo,

Welcome to the Sonos Community and thank you for reaching out with your set-up question.

Since the Sub communicates to its parent Sonos player via 5ghz, if the Sub is out of range of your Amp you will not be able to bond the two reliably if at all. 

There are three options available to you from what I can understand of your set-up:

  1. You can opt to bond your Sonos Sub to a different product that is within 10-15 feet of the Sub. 
  2. Relocate the Amp physically within 5g range of of the Sub and the ceiling speakers.
  3. Try wring the Sub to your network (I personally don’t like to recommend this) as this will put the Sub directly in network communication with your Amp.

I’d be interested to hear about which option works best for you and you can certainly submit a diagnostic report from your system if you have any difficulty. Include the confirmation number in your response and we will be happy to look this over for you. 

    

View original

30 replies

Userlevel 7
Badge +22

So it’s running off your home WiFi not connecting to sonosnet  

best bet then is to put another sonos device half way between the two to repeat the sonosnet signal.  Could be a beam - even a rather cheap Sonos one sl.  

 

But actually this may. Not work

this is a more unusual one were paired devices are not near each other.  I have to say I have never run in to this.  I’m going to see if issue doing the same at my house with the paired device not direct connecting but via another Sonos unit.   I’m thinking still won’t work because paired devices are supposed to maintain a low latency 5ghz connection bwteeen them meaning they have to talk directly 

There was a similar case a short while ago. In that case the user had wired the Amp in the closet, and the suggestion was to disable its radios to force the remote Sub to use whatever 2.4GHz SonosNet connection it could find.

Userlevel 7
Badge +22

Interesting. Thx ratty  So the sub could communicate paired via the 2.4ghz as long as it wasn’t looking for the signal from the amp. 
 

mayo are these the only 2 Sonos devices you have.  If you have others are any hooked to router as well?

The Sub won’t move to 5GHz until it’s told to do so by the parent HT device, so should in theory revert to 2.4GHz. Latency spikes could however strain the quality of the bonded connection.

Badge

I have 4 beams, 4 amps(all in that one closet), 4 Ones, 3 subs, and a pair of Play 5s

none of the speakers are hard wired to the router, they are all using my mesh wifi(orbi 6)

I looked at my 3 subs they are all WM:2 so paired via 5ghz - so is there a way to pair it to the amp not through 5ghz?

I have 4 beams, 4 amps(all in that one closet), 4 Ones, 3 subs, and a pair of Play 5s

none of the speakers are hard wired to the router, they are all using my mesh wifi(orbi 6)

I looked at my 3 subs they are all WM:2 so paired via 5ghz - so is there a way to pair it to the amp not through 5ghz?

I think the suggestion from @ratty is the only show in town for this. Prevent the 5GHz connection from operating by turning off the wireless radio in the room settings for the Amp (badly described as 'disable WiFi' in the app. But then the Amp must be wired to your network as ot has no other means of connecting. 

Userlevel 7
Badge +22

He does have his Amp wired to his router.

Further thought, although might be worth seeing if @ratty thinks it's  OK.

If you cannot easily connect the Amp to your router by Ethernet, you might wire it to one of the other Amps then wire one of your other Sonos devices to your network. 

This is going to change your network topology quite a bit.

He does have his Amp wired to his router.

Not if the Subs are showing WM:2.

Userlevel 5
Badge +16

Hello @Mayo,

Welcome to the Sonos Community and thank you for reaching out with your set-up question.

Since the Sub communicates to its parent Sonos player via 5ghz, if the Sub is out of range of your Amp you will not be able to bond the two reliably if at all. 

There are three options available to you from what I can understand of your set-up:

  1. You can opt to bond your Sonos Sub to a different product that is within 10-15 feet of the Sub. 
  2. Relocate the Amp physically within 5g range of of the Sub and the ceiling speakers.
  3. Try wring the Sub to your network (I personally don’t like to recommend this) as this will put the Sub directly in network communication with your Amp.

I’d be interested to hear about which option works best for you and you can certainly submit a diagnostic report from your system if you have any difficulty. Include the confirmation number in your response and we will be happy to look this over for you. 

    

Further thought, although might be worth seeing if @ratty thinks it's  OK.

If you cannot easily connect the Amp to your router by Ethernet, you might wire it to one of the other Amps then wire one of your other Sonos devices to your network. 

This should work. However the controller may prevent the Amp from disabling its radio, as it won’t see a fully wired path. Or it will appear to disable, then re-enable a couple of minutes later. It may be necessary to temporarily wire the Amp to the core of the network in order to disable its radio, then move it back to the daisy-chain connection off another device afterwards.

(It used to be so much easier with the hidden /wifictrl URL, but when Sonos put its official stamp of approval on disabling the radio they put all kinds of checks into the controller to prevent a user marooning a device accidentally.)

Badge

Thanks for all the replies.

My router is in the same closet as the Amps, So I can wire it directly to my network and assume disable wifi via the app - but the question then is will the sub be able to talk to the Amp still, as Jean says above   they talk via 5ghz -- is this the only way they can communicate?

Userlevel 7
Badge +22

They can talk via ethernet if the Sub were plugged into router.

Wire that Amp and at least one other node before disabling the relevant Amp’s radio.

So long as the Sub can see a 2.4GHz connection to another Sonos node I think it will try and connect that way in the absence of a direct 5GHz signal from its parent Amp. I would try it and see how it performs. 

Badge

ratty - why do you say wire at least one other node before disabling?

Because you’re going to be disabling the radio on the Amp in question. You need at least one other wired device with an active radio to enable SonosNet operation.

Badge

Because you’re going to be disabling the radio on the Amp in question. You need at least one other wired device with an active radio to enable SonosNet operation.


ok I can wire 2 of the amps to the router, or could I also connect the amp in question to another amp via Ethernet (disabling the radio in the amp in question on both scenarios)?

I think either would work, but might ss well wire them both direct to router.

It should only be a matter of minutes to test it - just give it a try!

Badge

Appears this is working!  I did have to connect 2 amps the router, couldn’t piggy back from one to the other- although wasn’t connected to the same one that was connected to the router.  Non the less this is working so far.  Will let y’all know if any issues arise 

 

thanks to all!

I double-checked this on a Beam + Sub. After disabling the radios on the Beam and powercycling the Sub the latter eventually connected to 2.4GHz and everything played fine. 

See how things go. As I remarked earlier, latency spikes could occasionally upset the Sub as the connection is potentially having to take a rather circuitous route.

Badge

Looks like it’s having issues today.  Sonos app says the sub is “not configured”.  Unplugged it and it was able to connect for a short time then disconnected again.  It may be just be I cannot place it where it is... 

Badge

Actually…..appears my 15 year old unplugged the Amp from the router, so up and running again….

Badge

So final outcome is it does have issues when grouping several amps together for music, I assume this is the latency spikes ratty was mentioning.  I have decided to go back to having the system use my WIFI instead of the sonosnet, I can tell the app itself is overall more responsive this way.

Maybe sonos will have an update that allows the sub to resort to 2.4ghz if it can't get a good 5ghz signal.

Again, appreciate all the help here.

thanks

-mayo

Badge

would a Sonos boost help my situation(the latency spike issue)  if i were able to wire it into my Satellite Orbi(which is hard wired to router), there would then be about 10’ of distance b/t the boost and the sub?

-mayo

Badge

Ratty - it is possible for me to add 2 Sonos boost, one at each orbi router(which are hardwired together). I could then plug in an amp to the boost and piggy back the other 3 into each other and disable their radios.   The 2nd boost, as I mentioned above, would be about 10’ from the sub.

would this be a good solution?  And would this be less susceptible to the latency spikes?

 

-Mayo 

Reply