Answered

Sonos Port: Wired connection but still music is interrupted


Userlevel 1
Badge +4

I'm using a sonos port which is connected to my recordplayer. The Port is connected via a LAN cable to my router (Sonosnet channel 1) and the music has been set to compressed...and is played via multiple One's

Still I'm losing audio; The music sometimes is not played for 10-20 seconds before it starts playing again.

Also the sonos s2 app (on my Iphone) states that it can't connect to Sonos

Any idea how to resolve this? Eventhough sonos is wired, can it have something to do with my wifi?

icon

Best answer by ratty 24 October 2020, 12:49

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

104 replies

And I have lost count of the number of times that @ratty , I and others have suggested that this causes needless hassle for users who understandably mistake its purpose. 

Userlevel 1
Badge +4

Gents

 

I'm eternally grateful. Have applied all above tips and finally had set the audio delay to 2000ms.

After having all my Sonos artifacts being on WM:0, no dropouts have occurred anymore

Enjoying my lazy Sunday now, spinning record without any audio drops :-)

 

BR

Sven

  1. The colour reflects the ambient noise level and the amount of rejection by the wireless card. The latest wireless modules don’t return such data is a form that’s compatible with the matrix, hence the white cells.
  2. 0 to somewhere over 80. I’m unsure what the upper limit is these days. In the low 20s a connection may start to struggle. Below 20 can be nonviable.
  3. There are 4 zeroes from the latest radios, which as I say are incompatible with the matrix display. The earliest radios (which also display OFDM Weak Signal Level) have a single figure, the later ones three. I’m unsure of the range, but I’ve not seen anything much below -120dB.
  4. Correct.
  5. Similar, see above.
  6. Secondary nodes are those directly connected -- in STP terms -- to the root bridge. Tertiary is everything else.
  7. Again, it depends on the generation of radio. The oldest version has two signal strength figures, the others one. As for the range see 2 above.
  8. Ditto.
  9. Open virtual ports are in the ‘forwarding’ state; those that are closed to avoid loops are ‘blocking’. Read up on the basics of STP. Google is your friend.

I believe the setting needs to be disabled in order to enable a wired connection.

Incorrect. I don’t know where you got that idea from. You’ve killed its ability to be the ‘root’ node for the SonosNet wireless mesh. The signal from your Port is having to go a roundabout route through the router and out over WiFi to reach your Ones.

Re-enable “WiFi” -- it’s actually SonosNet, and is awfully misnamed -- in the controller and see how you get on. Wait 5 minutes and then check in Settings/System/About My System. All the devices should be showing “WM:0”.

If your playback problems go away, I’d advise you to remove your router’s WiFi details from the Sonos system, via Settings/System/Network. This will prevent a relapse. 

I truly believed this was the way to connect via a LAN cable. Thanks for educating me. (Ps. I do agree with the awful misnaming)

I can assure you that you’re by no means the first to be confused by this option.

The setting to disable the onboard radio used to be a hidden one, primarily used by installers. Sonos brought it into the open, protecting it with some checks to ensure a user couldn’t accidentally disconnect a device, but for some reason got the naming totally wrong. 

Trueplay doesn't need to be redone. All that's changed is the network connection. 

SonosNet uses 2.4GHz. 

Start by controlling your unruly router. Auto channel selection is asking for trouble, as it often fails to detect SonosNet. And auto channel width is almost certainly using the greedy and damaging 40MHz. Always use 20MHz at 2.4GHz. 

You don't need to fiddle with 5GHz. 

Userlevel 5
Badge +14

Hi @svleuken.

Welcome, thank you for reaching back to Sonos Community and providing the diagnostic.

Try unplugging all Sonos devices from power, then reboot your router and access point. Once the router comes back up, plug your Sonos devices back in.

Also try to enable the wifi to the Sonos port.

Let us know if it works. If you need help with any other information, please be sure to let us know.

The About display not populating is a symptom of packet loss. 

The red cell is a symptom of interference, not the cause. 

You mention wireless sources other than WiFi. I suggest you turn them off in an attempt to determine which could be responsible. 

Well at least the Port has apparently connected to the 5GHz. That may help.

Way back in this thread I suggested possible interferers. The change could also be as simple as a neighbour doing something different.

@ratty is, as always, correct.  Having this setting as 'disabled' is crippling the operation of your system. 

Good evening all,

Unfortunately, my initial issue is back. After having read the entire thread, I believe I'm also facing the “STP” issue. When playing Spotify or watching movies, no glitches whatsoever occur. 

I somehow doubt it. You go on to state that your Port is the only wired device. There can be no “STP issue” under such circumstances.

 

When playing vinyl via the Port, the glitching starts...playback is interrupted and also the Sonos app (on my iPhone) sometimes states that it can't connect anymore.

That sounds like straightforward packet loss. Often the culprit is intermittent wireless inteference. Indeed your matrix shows evidence of heavy ambient noise (the red cell) on the one node capable of displaying this info. 

 

After it reconnects, I see (sorry for the Dutch screen) that the connected system (gekoppeld product) has changed. Previously it connected to IP 192.168.1.150 (which is my UTP connected PORT); Now it seems to be connected to 192.168.1.114 which is my 'wireless’ connected playbar.

You can ignore all that. The ‘Associated Product’ is just the first player the controller finds when it starts. The controller uses it to obtain information about the system. It doesn’t have to concide with the player that the controller is actually focussed on.

 

Try the Settings/System/Audio Compression setting on Uncompressed to improve the stream quality. If you subsequently suffer any dropouts you can increase the Audio Delay (and hence buffer depth) in Settings/System/(roomname)/Line-In.

Sonos is not supported on a guest network. In general guest networks use client isolation, which prevents Sonos from working at all.

Also, guest networks are on a different IP subnet, so by design they’re isolated from the main network. 

The wired One is a surround. You should not use a home theatre satellite as the sole wired connection. It can cause instability.

On that basis, and if you’re unable to wire anything else, wiring a Boost instead might help. Adding a Boost without wiring it to the network would be a waste of time; it would be ignored.

 

The signal strengths between the nodes are good and, again, the red cell in the left column suggests that everything is fighting interference. (The white cells in that column are because the latest radio modules don’t return ambient data in a compatible format. The full diagnostic -- visible only to Sonos -- would tell the complete story.)

 

Instead of investing in a Boost, have you tried running your system on your router’s WiFi in “wireless” mode? 

The matrix is almost meaningless for WiFi mode, except that it still depicts the ambient RF conditions in the left column. There’s no SonosNet, hence there are no active SonosNet connections.

The signal strengths between the nodes are good and, again, the red cell in the left column suggests that everything is fighting interference. 

No idea what is causing the interference at the playbar. There are NO other (Wifi enabled) devices in its proximity. The TV has been switched off. The only device nearby is the SUB. Is the SUB causing this interference for the playbar?

No. As mentioned a couple of months ago it’s likely to be a non-WiFi actor in the 2.4GHz band, quite possibly Hue.

@ratty : Hope you don't mind me asking;

What is the impact of a wired connection of the playbar in combination with sonosnet when I'm NOT streaming internet related content? In other words: How will the sonosnet, wired via the playbar,  prevent fall outs when playing vinyl via the port? Thanks upfront for educating me.

Whether or not there’s communication with the internet there’s still a local network topology, for the devices to talk to one another. The active SonosNet wireless links are indicated by the coloured squares in the matrix.

To be honest, I’m not sure wiring your Playbar is going to be the silver bullet, though having just the surround wired was definitely an incorrect configuration. 

No. As mentioned a couple of months ago it’s likely to be a non-WiFi actor in the 2.4GHz band, quite possibly Hue

Damn. Never thought of those...Thanks!…..Have multiple HUE lights active. Any idea why the playbar is heavily affected by these and the other SONOS products aren't?

Everything on 2.4GHz would be affected, but as I’ve already remarked the other units can’t report the ambient RF noise in a way that the matrix is able to display. 

 

I think you should try the suggestion to put your system into “wireless” (WiFi) mode. The One (Gen 2), One SL and Port can now connect to 5GHz WiFi, if the correct SSID is configured into the system, so it would be worth seeing whether that helps.

One small question...as I've learned that the SONOS app is working like a ‘remote’ for the Sonos system. Should my iPhone now also connect to the 2.4Ghz wifi? ...as it currently (automatically) connects to my 5 Ghz wifi. (The SSID for 2.4Ghz and 5 Ghz are currently the same)

It doesn’t matter, as your system is in SonosNet/’wired’ mode*. A controller on either band should work fine. In fact, in view of your apparent 2.4GHz interference issues it would help to keep as much as possible on 5GHz.

 

(*With a system in WiFi/’wireless’ mode it can sometimes matter as a few routers don’t correctly forward certain types of traffic between their WiFi bands. A controller on 5GHz may therefore have difficulty seeing Sonos units attached to the 2.4GHz WiFi.)

Userlevel 1
Badge +4

It's getting stranger and stranger…

The line in (ingangsbron) is not found, but music is playing...as to be seen with the 3 vertical icons on the right

 

So I'm playing vinyl via the port (line in), even though the systems doesn't recognize the "draaitafel” (turn table)

So I'm completely lost now.

How can I play music via a device (port) which officially isn't know to the sonos app?

Connecting to wifi is getting worse and worse by the day. (The drop outs are almost gone, but operating the sonos via the app is almost undoable) (Randomly devices are disappearing as they're no longer seem to be connected/detected)

 

 

No idea, though the Line-In function would be separate from the playing function. Have you tried rebooting everything?

Userlevel 1
Badge +4

Hi Ratty
 

Thanks again. The ones in my kitchen are gen2. (one of the ones is a one SL)
Any idea how to switch those 2 ones to 5ghz
For the playbar I understand this is not possible

You can't force them. They'll just pick the best signal available.