Question

Sonos Amp w/ Klipsch Sub

  • 7 November 2019
  • 6 replies
  • 271 views

Currently have a Sonos Amp, and a Klipsch KSW 12, barely getting any bass from device.  I realize that the Sonos is rated 8ohm, and the sub is 4 ohms.  Have tried to turn power all the way up, phase is both set to zero.  Have tried just LFE single connection, and also tried a 2-in-one connection.  

 

Wondering what issue might be?


6 replies

Userlevel 7
Badge +22

You are using the the LFE output from the Sonos Amp correct to the single LFE input on the Klipsh.   Since the crossover is in the Sonos Amp I would set the crossover on the Klipsch all the way up to 120hz so that it doesn’t add additional crossover.

Then of course the volume controlled on the Klipsch as far as its output level.

 

Have you tried different source material as to the bass level from the Sonos Amp

 

There are sub settings under the Sonos Amp system settings… go to system … pick the Sonos Amp ..  Scroll down to sound...sub audio … you can adjust sub output level and crossover there.    Also under the prior menu there is EQ settings where you can bump up bass level some.

Userlevel 7

Hi micahawitt

I suggest you start your setup again. Use the sub out of the Amp to the LFE of your sub. Set Phase to 0 and level to 3. Allow the Amp to make all adjustments.  You can make further adjusts in the Sonos App if necessary.

FYI, the ohm specification for your sub has no bearing on the AMP as it (the Amp) is not supplying power to drive the sub when using Sub out. The AMP is analyzing the incoming source signal frequencies and directing them accordingly to the speaker terminals (which place an ohm load on the amp) and sub (being powered does not place a load on the Amp) via a crossover point.

awesome, thanks for  the replies, and i i will test this!

Hmm, still not working, i have a 10 polk sub that sounds better.  Just dont understand why i cant get more sound out of this thing.

well, i have now hooked up the Polk sub that was oriniginally in there, and that sounds very muted as well.  The app had some different setting options a while back.  Even after another hard reset, there is seemingly no bass here.

micahawitt,

 

Did you ever get this working?

Reply