Answered

Quality reduction 4 speakers on AMP

  • 19 January 2022
  • 5 replies
  • 62 views

Hi - I am setting up an new Sonos AMP to 4 speakers. 
First 2 speakers: excellent sound.
Third speaker: still excellent sound.
Fourth speaker: I experienced a severe loss of quality of one of the channels and thus speakers. 

Monaco SPE-82/HQ 100 watt 8 Ohm speakers.

2 speakers on 1 channel thus 4 on 2 channels. 

Any explanation? Ideally anybody a fix?

icon

Best answer by HJB-NL 19 January 2022, 23:53

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7

Check your connections and make sure the speakers are wired in parallel like this:

 

Is/was the case. 
I have removed all wires and connected the speakers solitaire/separately. Each speaker gave sound as one would expect. I will reconnect the whole thing again as I initially did (and in line with the suggested scheme) and see what happens  

Fingers crossed. 

Userlevel 2
Badge

You might also verify the impedance of the speakers at the Amp.  If you have one that ends up being significantly different, you might have a bad speaker or wiring.  For example one at 6ohms while the rest are 8ohms.  By itself the Amp will handle it just fine, with another 8ohm speaker though maybe not.

Userlevel 7
Badge +21

If none of the above works try hooking up different combinations of speakers to see if you can find one that is the problem.

Looks like it is fixed. 
As speaker wiring was fixed (behind wall) I removed all wiring from the wall socket to the amp and reconnected each of the speakers separately. All speakers gave HQ sound. 
Then i reconnected everything as I did initially and according to scheme (parallel). 
 

I think the issue may have been caused by not only having the copper wire in the AMP connector but in one case also the plastic wire shield causing poor signal to the speaker.

Do not know if that makes sense but it’s my logic. Fingers crossed the fix is there to stay. 
 

let me know if it does(n’t) make sense. 
thanks