Port Compressed vs Uncompressed vs Automatic

  • 1 December 2019
  • 6 replies

So, I’ve discovered a quirk I think the Sonos folks might want to be aware of.  I recently got a Port to connect a turntable.   I discovered that to make my turntable work properly I had to use the Compressed setting because my surrounds that are bonded to my Playbar/Sub would start to get glitchy and drop out. That’s all fine and dandy but when I switch it back to Automatic in order to stream the normal things like Pandora, Apple Music etc, my surrounds that are bonded to my Playbar/Sub start to get out of sync.  The only way I can get them back in sync is to try turning off the surrounds and back on or stopping the music for a few moments and then start again or some varying combination of these things.  I haven’t been able to nail down one thing that works all the time but eventually they start to sync back of after some tinkering.  Anyway, I’m willing to live with this but am hoping for some software fix at some point.  My main point is I think switching from Compressed to Automatic isn’t an instantaneous thing with Playbar/Sub/Surround setup.  It seems it sort has to “catch back up” in order to be synced.  

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Why do you need to switch it back and forth? The setting applies to only line in signals, so it should not matter to any other use if you leave it in compressed mode.

I agree, that’s exactly what I thought.  But as soon as I changed the setting to compressed in order for records to play properly, I had trouble when going back to regular streaming (leaving the setting compressed, presumably for “line in”).   I’ve been able to duplicate the scenario described multiple times.  The only way to get things back in line is to go back to automatic or uncompressed and then automatic and stop music, turn off surrounds, then back on etc.  Like I said, this is that part I haven’t nailed down a specific sequence that works right off the bat but eventually the surrounds are synced and stay synced.  As soon as I play records again compressed, it will be after that the problem will start again once going back to normal streaming.

There are two unconnected things going on here.

Compressed etc definitely affects only the line-in.

There is a problem at the moment with surrounds going out of sync in certain circumstances.  Sonos are working on a solution.  I believe a temporary workaround is that if you are grouping other speakers with a Playbar then if you start the group from the Playbar the sync problem doesn’t occur.  Perhaps give that a try?

John, I am not sure OP is grouping anything; as I understand it, the playbar/Sub/Surround are bonded together, not grouped. Presumably the line in on the Port is set to autoplay on the playbar, and the surrounds work fine there when the needle is lowered to the groove. If the Playbar is now selected in the app to instead play music, from Apple Music for example, why would the surrounds not sync?

I was thinking of the issue on this thread, although I note that the OP has already posted on that thread.

I think John B maybe correct here. The OP is perhaps encountering two issues… the first issue about the bonded speakers going out of sync, which are mentioned in these three threads…

The other is the matter about the line-in audio source dropping out.

I would try to resolve each issue separately…

If grouping devices, I would start by making the HT device the group controller and to stop the line-In dropouts I would change the buffer size by choosing the AirPlay device as the ‘source name' for the line in. (Note that the 'source name' can be renamed to something more appropriate after it has been selected).

i think addressing both issues, as John B suggests, seems to perhaps be a good place for the OP to start, at least.